Results 1 to 9 of 9

Thread: Xvkbd Problem

  1. #1

    Question Xvkbd Problem

    Hi

    I'm running openSUSE 11.1 on an HP TC1100 Tablet and every time I logon, I'm presented with the Xvkbd virtual keyboard. I can't seem to close this under my account and if possible, would like to disable completely as I don't use anyway. How do I go about doing this?

    Also, I have two shortcuts, "Online Help" and "openSUSE" which I cannot delete from my desktop. Any advice on how to get rid of those?


  2. #2
    Join Date
    Jul 2008
    Location
    Netherlands
    Posts
    1,140

    Default Re: Xvkbd Problem

    If you're using KDE 4, rightclick on the desktop (or whatever you need to do on a tablet to bring up the context menu) and select Unlock widgets.

    Then rightclick the icon and select "Remove this icon" and lock the widgets again again after you're done.
    Special effects <- KDE 4.2 Showing off
    More KDE -> PINK KDE

  3. #3

    Default Re: Xvkbd Problem

    Hi Axeia

    Thanks for your reply . I'm using Gnome but do have KDE4 installed also. Should I be able to delete under Gnome or is this something that has to be done under KDE4?



    Edit: Under Gnome, "Move to Wastebucket" is greyed out.

  4. #4

    Default Re: Xvkbd Problem

    Just logged onto KDE4 and I don't have those shortcuts on the desktop.

    Reagrding the virtual keyboard (xvkbd), I now have 4 of them loaded (taking up the screen) and I can't close any of them .


  5. #5

    Smile Re: Xvkbd Problem

    Bump .


  6. #6

    Default Re: Xvkbd Problem

    Double bump

    Any ideas? Do other tablet users have this problem? (it's really annoying). I can kill these windows in Gnome using "Force Quit" but what is the equivilent in KDE4?


  7. #7

    Default Re: Xvkbd Problem

    My old Acer C301 did the same thing when I installed 11.1 Live CD. I just went into the Yast>software, searched for the keyboard program...dont remember what it was called, but you have it listed in your post. Anyway, search for it and delete it...no more problem with that annoying keyboard multiplying like the gremlins..
    Take care,
    Jeff

  8. #8
    jtanen NNTP User

    Arrow Re: Xvkbd Problem

    Yes, I have a tablet and deal with the xvkbd issue as well. Same as you, I can kill it through the System Monitor, force quit, or as root using kill jobid, but I can't just close it as a user. I can't see where it is being loaded in the first place, either - not in inittab, not in startup programs in sessions. Not really a killer problem, but irritating. I guess I could write a script to kill it when Gnome loads. Anyone else found a solution to this annoyance? Without just uninstalling (which I guess is an option, too)?
    Last edited by jtanen; 29-Jul-2009 at 17:00. Reason: Clarification of question

  9. #9

    Default Re: Xvkbd Problem

    i have the same problem on my R20, and since nobody provided a solution, i will post back when i figure out a way to keep it without always running in-case you want/need to use it in tablet mode

    the reason it cannot be closed is its executed by root, users cannot kill root's processes. i will dig and find what tells it to start, (Likely GDM since it runs before the window manager loads)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •