Results 1 to 3 of 3

Thread: expansion error : nothing provides libwxgtk2.8-dev

  1. #1
    jromang NNTP User

    Default expansion error : nothing provides libwxgtk2.8-dev

    Hi all, I try to build a package with OBS build service ; no problems to create RPMs so far (OpenSUSE/Fedora/Mandriva) ; but I face a problem with xUbuntu 8.10, after providing the debian files, the build fails with :
    Code:
    expansion error  	 nothing provides libwxgtk2.8-dev, nothing provides wx2.8-headers
    I'm afraid that libwxgtk isn't included in the default Ubuntu repository, it seems to be in the 'universe' one. Is there a away to use libwxgtk in the OpenSUSE build service ?

  2. #2

    Default Re: expansion error : nothing provides libwxgtk2.8-dev

    You can steal this package from Ubuntu repository to your OBS project. Just download .dsc, .diff.gz and .orig.tar.gz from Ubuntu -- Details of source package wxwidgets2.8 in intrepid and add them to a package.
    You can disable publishing for this package so that it wouldn't duplicate package from "Universe".

  3. #3

    Default Re: expansion error : nothing provides libwxgtk2.8-dev

    Is there no way I can tell OBS to use the universe repository of ubuntu? In debian it works without adding seperate packages and I would prefere that the debian packages are linked against their own, and ubuntu against their own too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •