Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: update popups becoming really annoying

  1. #1

    Default update popups becoming really annoying

    Hi i have had suse installed now for a little while but im just not using it anymore because of an annoying problem with the updater (Update Applet 0.3.11).

    I allways have popup messages saying updates are being installed but no matter howmany time i click on 'do not show this again' i always get these messages.

    i have set the 'software update' program not to display popup messages but this doesnt seem to have any effect. i have even left the computer on for a 24hr period hoping the updates would have finished but it still continues surely there cant be that many updates.

    how can i stop this from happening as i loose nearly half my screen?

  2. #2
    palladium NNTP User

    Default Re: update popups becoming really annoying

    - open YaST, give root password, then

    --go Software > Software Repositories and

    -- check that you have ONLY four repos enabled, the four listed here:
    http://tinyurl.com/ylan8lw

    --disable all others (including the CD/DVD), then

    --go Software > Online Update, wait for it to finish updating itself,
    then when you see the list of updates (if any) click accept, then

    --have fun

    --
    palladium
    Have a lot of fun..

  3. #3

    Talking Re: update popups becoming really annoying

    Ok i have done this, i've disabled the cd/dvd and added the packman repository as this wasn't there for some reason but hey all seems ok at the moment.

    Thanks

  4. #4
    palladium NNTP User

    Default Re: update popups becoming really annoying

    > Thanks

    -welcome-

    --
    palladium
    Have a lot of fun..

  5. #5

    Default Re: update popups becoming really annoying

    Hi im afraid its still happening, it started happening this evening after being logged on for about 10min.

    I've restarted and have stop packagekitd from starting by opening the online update app at the same time ive noticed that there aren't any updates to actually install.

    would this suggest a problem with packagekitd?

  6. #6

    Default Re: update popups becoming really annoying

    is there a config file for packagekitd?

  7. #7
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: update popups becoming really annoying

    Since 10.2 I disable the updater and do my updates through Yast. for a home/workstation system I don't think that everyday updates are necessary, usually I do it once every week or two. Of course, if you're running a server it's a different story.

  8. #8

    Default Re: update popups becoming really annoying

    i have found a log file /var/log/zypp/history that shows some updates have taken place and this would have been the time lots of pop ups kept coming up so i think packagekitd is working OK but i don't think the front end is not saving my options

    when i type 'gconftool-2 -R /apps/gnome-packagekit' i get a list as follows

    enable_codec_helper = true
    notify_update_complete_restart = true
    enable_font_helper = true
    auto_update = none
    update_battery = false
    notify_errors = true
    notify_update_started = true
    enable_mime_type_helper = true
    session_startup_timeout = 300
    autocomplete = false
    notify_update_failed = true
    notify_critical = true
    notify_available = true
    enable_check_firmware = true
    frequency_get_updates = daily
    notify_distro_upgrades = true
    notify_complete = true
    banned_firmware =
    notify_message = true
    notify_update_complete = true
    enable_check_hardware = true
    frequency_refresh_cache = daily
    force_get_updates_login = false
    show_depends = true
    frequency_get_upgrades = weekly
    notify_update_not_battery = true
    show_copy_confirm = true
    /apps/gnome-packagekit/application:
    filter_basename = false
    filter_newest = true
    category_groups = false
    /apps/gnome-packagekit/repo:
    show_details = false
    /apps/gnome-packagekit/update_viewer:
    precache_details = true

    if the line in red could be changed to false could this stop the popups from appearing if so how could i change this? i can't find any file with this information saved in.

  9. #9
    palladium NNTP User

    Default Re: update popups becoming really annoying

    > if the line in red could be changed to false could this stop the popups
    > from appearing if so how could i change this? i can't find any file with
    > this information saved in.


    i don't see any red (because i don't use the web interface's html) so
    i can't answer...but, i go along with 'brunomcl': just turn off the
    openSUSE Updater (right click the greeen goblin icon, and . . . [i
    can't tell you more because there isn't one running on my task bar--i
    got tired of it popping into service every time i booted and slowing
    down/gumming up the works for 10 or 15 minutes])

    just turn it off, and use YaST > Online Update at the exact time YOU
    want it to run (instead of when it wants to run)..

    simple.
    non-obtrusive.
    works. (you do need to be young enough to remember to do it every once
    in a while....weekly is probably ok....this is not a frail Windows
    that can get cracked if you don't patch every two minutes..)

    --
    palladium
    Have a lot of fun..

  10. #10

    Default Re: update popups becoming really annoying

    The red line read
    'notify_update_started = true'

    i don't mind turning off auto updates but i do have a tendency to forget to update.

    i don't mind the updates running as long as i don't have to see all the notification.

    so not sure wot to do really.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •