Results 1 to 6 of 6

Thread: Yast refers to repos by repo_? alias

  1. #1
    Join Date
    Sep 2008
    Location
    Canada
    Posts
    3

    Default Yast refers to repos by repo_? alias

    Since I upgraded to 11.1 from 11.0, Yast has started referring to all the repositories by their repo_* aliases rather than by their names.

    For instance, it uses repo_1 instead of Main Repository (OSS).

    I find this very confusing when I'm trying to determine which version of a package I have installed/want to install. It didn't do this with my 11.0 clean install.

    How do I make it use the repository names again? Thanks in advance for any help or pointers.

  2. #2

    Default Re: Yast refers to repos by repo_? alias

    I find it too confusing (it is confusing only if You got many repositories). In Gnome it's a lot easier as it shows normal names, i assume then that You got KDE ? Just use yast2 gnome version (Yuo need to set it up in YaST sysconfig if i'm not wrong) System-->>YaST2-->>GUI-->> wanted gui. Try that, if you don't like then just reverse it.
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  3. #3
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,562

    Default Re: Yast refers to repos by repo_? alias

    I too hate this change. I spent an hour trying to work out why I couldn't see anything listed from the packman repo in Yast 2 then realised it was showing as "pm"

    Can the developers please change it back to how it used to be?

  4. #4
    Join Date
    Jul 2008
    Location
    Netherlands
    Posts
    1,140

    Default Re: Yast refers to repos by repo_? alias

    For what it is worth, I'm also annoyed by this change.. but too lazy to file a bug/feature report.
    Special effects <- KDE 4.2 Showing off
    More KDE -> PINK KDE

  5. #5
    Join Date
    Jun 2008
    Location
    Levin, New Zealand
    Posts
    227

    Default Re: Yast refers to repos by repo_? alias

    It is a pain but you can rename your repos in YaST>Software>Software Repositories>Edit

    I also find that if you don't uncheck the remain subscribed box when using 1-click it adds the repo again using a different name

  6. #6
    Join Date
    Sep 2008
    Location
    Canada
    Posts
    3

    Default Re: Yast refers to repos by repo_? alias

    I found the openSUSE bugzilla and there's a bug report for this problem at https://bugzilla.novell.com/show_bug.cgi?id=456099 for the Qt interface. It seems the problem will be fixed.

    nzlbob23, thanks, I'll try renaming the repositories. I noticed that a new repository I added through a .ymp file is referred to by the full name rather than by the repo_? alias.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •