Results 1 to 2 of 2

Thread: yast/zypper dependency mechanism

  1. #1

    Default yast/zypper dependency mechanism

    I'm running Opensuse 11.1 and installed opera 10 alpha few days back.

    Each time I upgrade:
    $ zypper dup

    It downgrades opera to 9.63.

    It seems that zypper/yast only looks at its own database for dependencies and not honor package versions installed on the system.

    Is there a way I can tell to zypper to automatically not to downgrade opera?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,396
    Blog Entries
    1

    Default Re: yast/zypper dependency mechanism

    You could do

    zypper al -t opera

    to lock this package

    zypper --help for more info

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •