Code:
Your kernel was built with "gcc" version "4.3.2", while you are trying to use
"/usr/bin/gcc" version "4.3". This configuration is not recommended and VMware
Server may crash if you'll continue. Please try to use exactly same compiler as
one used for building your kernel. Do you want to go with compiler
"/usr/bin/gcc" version "4.3" anyway? [no]
I did choose yes at this point and it still fails.

It seems to me the whole problem is SLE 11 64-bit didn't ship with the correct version of gcc for the kernel.

I could attempt to update gcc or rebuild the kernel but this seems pretty ridiculous and isn't really an acceptable option.