Results 1 to 5 of 5

Thread: Pidgin OTR plugin has dependency problem (libgcrypt)

  1. #1
    Markus8219 NNTP User

    Default Pidgin OTR plugin has dependency problem (libgcrypt)

    Hi,

    I am trying to install the OTR plugin for Pidgin and it is telling me that I am missing a dependency which I think I have. These are the installation steps I have taken:



    The configuration script then runs...
    Code:
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    ...
    checking for LIBGCRYPT - version >= 1.2.0... no
    configure: error: libgcrypt 1.2.0 or newer is required.
    But when I check in YaST, it shows that I have version 1.4.0.3-1 of libgcrypt installed.

    I am using openSUSE 11.0. Thanks for any help.

  2. #2

    Default Re: Pidgin OTR plugin has dependency problem (libgcrypt)

    Quote Originally Posted by Markus8219 View Post
    Hi,

    I am trying to install the OTR plugin for Pidgin and it is telling me that I am missing a dependency which I think I have. These are the installation steps I have taken:



    The configuration script then runs...
    Code:
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    ...
    checking for LIBGCRYPT - version >= 1.2.0... no
    configure: error: libgcrypt 1.2.0 or newer is required.
    But when I check in YaST, it shows that I have version 1.4.0.3-1 of libgcrypt installed.

    I am using openSUSE 11.0. Thanks for any help.
    I'm running into the same problem on Ubuntu 13.04, except that synaptic shows I already have libgcrypt11 v. 1.5.0-3ubuntu2.1

    This seems like a bug to me.

  3. #3

    Default Re: Pidgin OTR plugin has dependency problem (libgcrypt)

    Quote Originally Posted by SoManyAccounts View Post
    I'm running into the same problem on Ubuntu 13.04, except that synaptic shows I already have libgcrypt11 v. 1.5.0-3ubuntu2.1

    This seems like a bug to me.
    And why are you writing this in the openSUSE forums?

    For compiling stuff yourself you have to have the devel package installed.
    On openSUSE this would be libgcrypt-devel. On Ubuntu it's called libgcrypt11-dev I think...

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Pidgin OTR plugin has dependency problem (libgcrypt)

    On 05/31/2013 06:26 PM, SoManyAccounts wrote:
    > I am using openSUSE 11.0


    openSUSE 12.1 sailed past its end of life and support in July 2010
    (cite: http://en.opensuse.org/Lifetime) and has received
    *no* security patches since..

    suggest you move to a currently supported version (today those are
    12.2, 12.3 and Evergreen 11.2/11.4
    http://en.opensuse.org/openSUSE:Evergreen)

    --
    dd

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Pidgin OTR plugin has dependency problem (libgcrypt)

    On 05/31/2013 10:34 PM, dd wrote:
    > openSUSE 12.1


    well, that was supposed to say openSUSE *11.0*

    --
    dd


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •