Results 1 to 5 of 5

Thread: Help - 11.1 upgrade broke vmplayer usb connections

  1. #1
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    10

    Question Help - 11.1 upgrade broke vmplayer usb connections

    I have WinXP running in VMplayer 2.5.1 on openSuSE. Upgrading to openSuSE 11.1 has stopped my PDA talking to the WinXP guest OS when it worked perfectly under 11.0. My USB memory stick has also stopped working.

    When I connect the PDA (Dell Axim X51 running WinCE) or memory stick WinXP beeps for a USB device connected, but ActiveSync can't find the PDA and the disk doesn't appear to be mounted. The device manager reports that the driver encountered an error.

    As this is the identical VM that was running and working under 11.0 I don't think the problem lies with the WinXP guest OS.

    Running VMplayer from the console reports no errors. Both lspci on the host openSUSE and guest WinXP report the devices correctly.

    Anyone got any hints please?

    mark

  2. #2
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    10

    Smile Re: Help - 11.1 upgrade broke vmplayer usb connections

    Not sure I should answer my own post so rapidly, but I was digging and digging and found the solution to the PDA problem:

    adding the following to /etc/modprobe.d/blacklist
    blacklist ipaq

    fixed the problem.

    Hope this helps someone else.

    mark

  3. #3

    Default Re: Help - 11.1 upgrade broke vmplayer usb connections

    Hi Mark. I'd be interested to know how you went about setting up the WinXP installation in VMWare Player. I just posted about this in the following thread:

    virtualization options for win xp guest in opensuse - openSUSE Forums

    Would I be right in assuming you're using the official proprietary version of VMPlayer, downloaded from the VMWare site? If so, do they provide a SUSE-specific package in rpm form? And did you make a fresh WinXP virtual machine installation or did you manage to copy an existing installation?

  4. #4
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    10

    Default Re: Help - 11.1 upgrade broke vmplayer usb connections

    Hi Gumb,

    Not sure that I can help. I run VMware Player 2.5.1 downloaded from the VMware site as a *.bundle file. I installed it by running as root:
    sh ./VMware<version>.bundle

    As I had an older version I had to do the fix of removing the old /usr/lib/vmware/modules/binary folder as found on google.

    The virtual machine (WinXP) was built for me as a standard role-out VM by the work IT dept. I just open it with vmplayer and off it goes.
    Cheers

    Mark

  5. #5

    Default Re: Help - 11.1 upgrade broke vmplayer usb connections

    Okay thanks.

    Sounds like it's still very much a proprietary package and specialised procedure, which is a bit of a shame. I just hope that if I go down this route, I won't find that in the future when I come to upgrade SUSE or the kernel, etc., that they've stopped providing the VMPlayer package or changed its configuration.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •