Results 1 to 9 of 9

Thread: mount problem

  1. #1
    bolvadur NNTP User

    Default mount problem

    Hi

    I just installed openSuse 11.1 with kde4.1 and noticed some things working differently from other distros I have used before.

    I wanted to mount some partitions so I try dolphin (dolphin has on default hdds on left side of an open window) and it said:
    Code:
    An error occured while accessing 'Volume (ext3)', the system responded:
    org.freedesktop.Hal.Device.PermissionDeniedByPolicy:
    org.freedesktop.hal.storage.mount-fixed auth_admin_keep_always
    <-- (actoin, result)
    does that mean I have to change some settings in openSuse or hal-system-storage-mount? Im completely lost on that one.

    Also when I try to mount normally (from terminal) it will give me strange results. It just hangs without any feedback, so I have to ctrl+c it... but that doesnt work, forcing me to close the terminal or open new tab.

    Code:
    # mount /dev/sda1 /mnt
    ^C
    Then all is ok except that the mount failed... and this
    Code:
    $ cd /
    $ ls
    ^C^C^C^C^C^C
    Now I cannot find the content of / but I see that there is a /
    After that I cannot open anything on the panel (menu, window switcher, workspaces...)

  2. #2

    Default Re: mount problem

    I had the error message you posted until I installed and ran:

    NTFS-3g & NTFS-Config from Yast

  3. #3
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default Re: mount problem

    Hi. Please post the output of "fdisk -l" and "mount" and maybe your /etc/fstab as well.
    When you mount a volume don't mount it to /mnt but to a subdirectory of /mnt or anywhere else. You will have to create this directory before mounting. Then you need to specify the filesystem with -t in the mount command. For an ext3 partition:
    Code:
     mount -t ext3 /dev/sda1 /mnt/something
    And for ntfs:
    Code:
     mount -t ntfs-3g /dev/sda1 /mnt/something
    [quote]

  4. #4
    bolvadur NNTP User

    Default Re: mount problem

    Quote Originally Posted by supertimorplusfort View Post
    Hi. Please post the output of "fdisk -l" and "mount" and maybe your /etc/fstab as well.
    oh *insertCurseWords* I forgot to say that the partitions are not selected to be auto mounted, so by default they should not be in fstab.

    fdisk does not work for some reason
    Code:
    fdisk -l
    fdisk: command not found


    I did not think of having type as flag but it works perfectly after making a folder with me as a user and 777 rights, with the standard 731 (rwxr-xr-x ) dolphin didn't display any files even though I could ls everything on the terminal.


    So thank you very much for your help.

    now I just have to find out why it doesnt mount from dolphin (and why I cannot run dolphin as super user). but Im happy I have always just used scripts to mount partitions any way

    # dolphin

  5. #5
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default Re: mount problem

    fdisk does not work for some reason
    Only root can run fdisk on openSUSE. And I think only root can mount volumes.

  6. #6
    bolvadur NNTP User

    Default Re: mount problem

    Quote Originally Posted by supertimorplusfort View Post
    Only root can run fdisk on openSUSE. And I think only root can mount volumes.
    indeed. that is why I was trying to launch dolphin as root.

    $ is user and # is root in standard bash prompt isn't it? I am confused why this isn't in opensuse

    *added*
    how do I mark the thread as solved?

  7. #7

    Default Re: mount problem

    See sump.org: KDE4: USB stick access fails with Hal.Device.PermissionDeniedByPolicy there's no need to be root to mount a USB pen drive etc.
    Gigabyte GA-MA770-UD3 r1.0 F9E|AMD Athlon II X4 635|6 GB 667MHz DDR2|XFX Radeon HD 6750|LG GSA-H30N|Netgear WG311T| opensuse 12.2 x86_64 (Intel 330, X-18M)|LG IPS236V 1920x1080 DVI|Logitech MX3000 & MX Air|Freecom USB DVB-T 25452| JBL Spot|Logitech C310

  8. #8

    Default Re: mount problem

    Sorry to bump this old thread, but I got the error mentioned by the op when trying to access my NTFS volumes in a new installed of openSUSE 11.1.

    I solved this by simply installing and running ntfs-config from the repo. It took me 30 seconds to enable write access on the two partitions I needed to use and it works perfectly as Maestro said. A happy bunny am I!

    Anyway, I thought I'd mention this in case it helps anyone else.

    Cheers,
    Lealoc

  9. #9

    Default Re: mount problem

    Yeah I am getting this issue too. The ntfs-config way works but it generates an fstab entry instead of using dynamic mounting through HAL.

    I think there's a bug in Dolphin's integration with PolicyKit in opensuse. The default implicit authorizations should cause Dolphin to prompt for a root password upon mounting (this is the way it works in Kubuntu), but this dialog is not displayed. Dolphin never gets authorization so fails with the PermissionDeniedByPolicy error.

    The quick workaround is to grant yourself explicit policykit permissions using the PolicyKit-kde tool in System Settings->Advanced. Find org.freedesktop.hal.storage.mount-fixed and add yourself to the user list.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •