Results 1 to 4 of 4

Thread: Help me get samba to work on 11.1?

  1. #1

    Default Help me get samba to work on 11.1?

    This should have been easy. I started smb and nmb and copied my smb.conf file from 11.0 (which worked great) and I have no shares. Bummer!

    To be precise, smb is running:

    Code:
     ps -A | grep smb
     6161 ?        00:00:00 smbd
     6162 ?        00:00:00 smbd
    the smb.conf file appears to be valid:

    Code:
     testparm /etc/samba/smb.conf
    Load smb config files from /etc/samba/smb.conf
    Processing section "[virtualbox]"
    Processing section "[mailbox]"
    Loaded services file OK.
    Server role: ROLE_STANDALONE
    Press enter to see a dump of your service definitions
     
    [global]
    	netbios name = BUDDA
    	server string = Samba
    	security = SHARE
    	guest account = pcguest
    	os level = 1
    	lm announce = Yes
    	domain master = Yes
    	wins proxy = Yes
    	wins support = Yes
    	preload = yes
    	guest ok = Yes
    
    [virtualbox]
    	comment = Data Share
    	path = /media/fat32/data/
    	read only = No
    	guest only = Yes
    	hosts allow = 192.168.178., 127.0.
    
    [mailbox]
    	comment = Public Share
    	path = /media/fat32/public/
    	read only = No
    	guest only = Yes
    	hosts allow = all
    but there are no shares:

    Code:
     smbstatus -v
    using configfile = /etc/samba/smb.conf
    
    Samba version 3.2.4-5.2-1985-SUSE-CODE11
    PID     Username      Group         Machine                        
    -------------------------------------------------------------------
    Opened /var/lib/samba/connections.tdb
    
    Service      pid     machine       Connected at
    -------------------------------------------------------
    
    No locked files
    Any ideas? I have tried putting in sample smb.conf files with the same results. I just don't see what's going on, and could use some suggestions. Thanks!

    - John

  2. #2
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default Re: Help me get samba to work on 11.1?

    Hi. I had no shares on my 11.1 box until I read this sticky: Opening Samba ports in the Firewall in openSUSE 11.1 - openSUSE Forums. smbstatus does only show a share when someone is currently connect to it. Good luck!

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Help me get samba to work on 11.1?

    smbtree -N is better for looking around the network. Including looking at yourself from the server.

    11.1 has a bug that stops the firewall from opening via Yast, as supertimorplusfort found.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  4. #4

    Default Re: Help me get samba to work on 11.1?

    Quote Originally Posted by supertimorplusfort View Post
    Hi. I had no shares on my 11.1 box until I read this sticky: Opening Samba ports in the Firewall in openSUSE 11.1 - openSUSE Forums. smbstatus does only show a share when someone is currently connect to it. Good luck!
    Well, that got it done. It took several permutations of order and restarting - I really don't know why it didn't solve the problem on the first attempt. In frustration I gave up and turned the firewall off. My shares showed up, then, and and when I subsequently turned the firewall back on the shares remained. They have survived several further restarts, so I guess they are good to go.

    Weird. Thanks for the help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •