Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: shutdown problem

  1. #1

    Default shutdown problem

    Hello

    Each time I try to shut down my system it fails to unmount fuse control filesystems. Another message tells me that system could not lock lock file. Then it hangs trying to unmount file systems. Please
    suggest.

    Thank you.

  2. #2
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: shutdown problem

    This would suggest that there are still files open on the failing unmount point.

    Which mount points do you have and which one is failing?
    Might be good to post the contents of /etc/fstab.
    Have a lot of fun!

  3. #3
    Magic31 NNTP User

    Default Re: shutdown problem


    This would suggest that there are still files open on the failing
    unmount point.

    Which mount points do you have and which one is failing?
    Might be good to post the contents of /etc/fstab.


    --
    Have a lot of fun! *WJM*
    ------------------------------------------------------------------------
    Magic31's Profile: http://forums.opensuse.org/member.php?userid=289
    View this thread: http://forums.opensuse.org/showthread.php?t=403976


  4. #4

    Default Re: shutdown problem

    Magic31 wrote:
    > This would suggest that there are still files open on the failing
    > unmount point.
    >
    > Which mount points do you have and which one is failing?
    > Might be good to post the contents of /etc/fstab.
    >
    >

    my fstab:
    /dev/disk/by-id/ata-ST9120821AS_5PL4ZYQ9-part7 swap swap defaults 0 0
    /dev/disk/by-id/ata-ST9120821AS_5PL4ZYQ9-part8 / ext3 acl,user_xattr 1 1
    /dev/disk/by-id/ata-ST9120821AS_5PL4ZYQ9-part9 /home ext3 acl,user_xattr 1 2
    /dev/disk/by-id/ata-ST9120821AS_5PL4ZYQ9-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/ata-ST9120821AS_5PL4ZYQ9-part5 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0
    /dev/disk/by-id/ata-ST9120821AS_5PL4ZYQ9-part6 /windows/E ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0

    my mtab:
    /dev/sda8 / ext3 rw,acl,user_xattr 0 0
    /proc /proc proc rw 0 0
    sysfs /sys sysfs rw 0 0
    debugfs /sys/kernel/debug debugfs rw 0 0
    udev /dev tmpfs rw 0 0
    devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
    /dev/sda9 /home ext3 rw,acl,user_xattr 0 0
    /dev/sda1 /windows/C fuseblk rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
    /dev/sda5 /windows/D vfat rw,noexec,nosuid,nodev,gid=100,umask=0002,utf8=true 0 0
    /dev/sda6 /windows/E fuseblk rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
    fusectl /sys/fs/fuse/connections fusectl rw 0 0
    securityfs /sys/kernel/security securityfs rw 0 0

  5. #5
    Cross_AM NNTP User

    Default Re: shutdown problem

    Magic31 wrote:
    > This would suggest that there are still files open on the failing
    > unmount point.
    >
    > Which mount points do you have and which one is failing?
    > Might be good to post the contents of /etc/fstab.
    >
    >

    my fstab:
    /dev/disk/by-id/ata-ST9120821AS_5PL4ZYQ9-part7 swap swap defaults 0 0
    /dev/disk/by-id/ata-ST9120821AS_5PL4ZYQ9-part8 / ext3 acl,user_xattr 1 1
    /dev/disk/by-id/ata-ST9120821AS_5PL4ZYQ9-part9 /home ext3 acl,user_xattr 1 2
    /dev/disk/by-id/ata-ST9120821AS_5PL4ZYQ9-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/ata-ST9120821AS_5PL4ZYQ9-part5 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0
    /dev/disk/by-id/ata-ST9120821AS_5PL4ZYQ9-part6 /windows/E ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    debugfs /sys/kernel/debug debugfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0

    my mtab:
    /dev/sda8 / ext3 rw,acl,user_xattr 0 0
    /proc /proc proc rw 0 0
    sysfs /sys sysfs rw 0 0
    debugfs /sys/kernel/debug debugfs rw 0 0
    udev /dev tmpfs rw 0 0
    devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
    /dev/sda9 /home ext3 rw,acl,user_xattr 0 0
    /dev/sda1 /windows/C fuseblk rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
    /dev/sda5 /windows/D vfat rw,noexec,nosuid,nodev,gid=100,umask=0002,utf8=true 0 0
    /dev/sda6 /windows/E fuseblk rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
    fusectl /sys/fs/fuse/connections fusectl rw 0 0
    securityfs /sys/kernel/security securityfs rw 0 0

  6. #6
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: shutdown problem

    Thanks for the output. It looks fine at first glance.

    Are you having problems with all the mount points? Or specifically one (like /windows/D)?

    Do you also have a dismount issue when booting and shutting down right after a successful boot (meaning: not having run any other applications that might be locking one of the files on the partitions)?

    lsof is a command you can use to check what the kernel is reporting as open file(s).
    To check files open on the windows partition mounts:

    su - #to elevate to root
    lsof | grep /windows/
    Have a lot of fun!

  7. #7
    Magic31 NNTP User

    Default Re: shutdown problem


    Thanks for the output. It looks fine at first glance.

    Are you having problems with all the mount points? Or specifically one
    (like /windows/D)?

    Do you also have a dismount issue when booting and shutting down right
    after a successful boot (meaning: not having run any other applications
    that might be locking one of the files on the partitions)?

    lsof is a command you can use to check what the kernel is reporting as
    open file(s).
    To check files open on the windows partition mounts:

    su - #to elevate to root
    lsof | grep /windows/


    --
    Have a lot of fun! *WJM*
    ------------------------------------------------------------------------
    Magic31's Profile: http://forums.opensuse.org/member.php?userid=289
    View this thread: http://forums.opensuse.org/showthread.php?t=403976


  8. #8
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    400

    Default Re: shutdown problem

    I had the same problem you describe, starting about a week after a fresh install of 11.1 on a ThinkPad T23, using KDE 4.1.3. I found other users mentioning this problem in some other forum threads.

    The fuse problem seems related to a problem with jexec. The fix seems to be Yast->System->System Services (Runlevel), scroll to "jexec" in the list, select it, and click Disable.

    I have been running smoothly for several days after making this fix, and have noticed no bad side effects. I am puzzled why 11.1 ran well for me for about a week, then started these problems.
    Regards,
    Howard

  9. #9
    crmrhm NNTP User

    Default Re: shutdown problem


    I had the same problem you describe, starting about a week after a fresh
    install of 11.1 on a ThinkPad T23, using KDE 4.1.3. I found other users
    mentioning this problem in some other forum threads.

    The fuse problem seems related to a problem with jexec. The fix seems
    to be Yast->System->System Services (Runlevel), scroll to "jexec" in the
    list, select it, and click Disable.

    I have been running smoothly for several days after making this fix,
    and have noticed no bad side effects. I am puzzled why 11.1 ran well for
    me for about a week, then started these problems.
    Regards,
    Howard


    --
    crmrhm
    ------------------------------------------------------------------------
    crmrhm's Profile: http://forums.opensuse.org/member.php?userid=8967
    View this thread: http://forums.opensuse.org/showthread.php?t=403976


  10. #10
    Cross_AM NNTP User

    Default Re: shutdown problem

    crmrhm wrote:
    > I had the same problem you describe, starting about a week after a fresh
    > install of 11.1 on a ThinkPad T23, using KDE 4.1.3. I found other users
    > mentioning this problem in some other forum threads.
    >
    > The fuse problem seems related to a problem with jexec. The fix seems
    > to be Yast->System->System Services (Runlevel), scroll to "jexec" in the
    > list, select it, and click Disable.
    >
    > I have been running smoothly for several days after making this fix,
    > and have noticed no bad side effects. I am puzzled why 11.1 ran well for
    > me for about a week, then started these problems.
    > Regards,
    > Howard
    >
    >

    I think this happened after I installed java 6 from Sun. I think that's why jexec is involved because for once I also noted an indefinite hang during booting and it stuck at starting jexec services.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •