Results 1 to 5 of 5

Thread: Mouse buttons reversed in rdesktop

  1. #1
    Join Date
    Jan 2009
    Location
    Toronto, Ontario
    Posts
    188

    Default Mouse buttons reversed in rdesktop

    Hi all,

    Has anyone else noticed that since upgrading to 11.1 if you've got the mouse buttons set to left handed in KDE when you rdesktop to a windows machine with the mouse buttons set to right-handed the mouse behaves as a right-handed one?

    I guess this is technically more correct than keeping the left-handed settings but kinda irritating. Is there a way to get rdesktop to keep the left-handed mouse settings? Or is it just me doing (or not doing) something clearly evident?

    Thanks in advance
    kev.

  2. #2
    Join Date
    Jan 2009
    Location
    Toronto, Ontario
    Posts
    188

    Default Re: Mouse buttons reversed in rdesktop

    should've mentioned using rdesktop version 1.6.0-37.4-x86_64. Don't remember which version I was using on 11.0.

  3. #3
    matthias_mueller NNTP User

    Default Re: Mouse buttons reversed in rdesktop

    Re-Hi,
    yep, on 11.1-32bit with gnome after upgrading from 10.3 I have the same behaviour.

    Greetings and Happy 2009
    mm

  4. #4
    Join Date
    Jan 2009
    Location
    Toronto, Ontario
    Posts
    188

    Default Re: Mouse buttons reversed in rdesktop

    Humm, so I'm not losing my mind. Well, maybe I am losing my mind but this is happening.

  5. #5
    Join Date
    Jan 2009
    Location
    Toronto, Ontario
    Posts
    188

    Default Re: Mouse buttons reversed in rdesktop

    Hi again,

    Found a solution to this. There's a patch available on the sourceforge page for the rdesktop project submitted by someone with the name stlman. (SourceForge.net: rdesktop: Detail: 2038819 - left handed mouse (cont.))

    So the solution was to uninstall the rdesktop package through Yast, download the source and the diff (link at the bottom of the page linked to above). Apply the patch to the untared source. There's a variety of ways you can do this but I used kompare. Then it was just a matter of ./configure, make, sudo make install.

    When running rdesktop after that use the -M flag and the mouse buttons will stay left handed in the remote session.

    If I get a chance I'll put an article on the suse wiki about this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •