Results 1 to 5 of 5

Thread: Sound problem: SuSE 11.1 on ASUS M2N78 PRO motherboard

  1. #1
    Join Date
    Jul 2008
    Location
    Santa Cruz, CA
    Posts
    250

    Default Sound problem: SuSE 11.1 on ASUS M2N78 PRO motherboard

    It just doesn't work. Sometimes, I can hear some faint scratchy sounds, but mostly no sound at all. /var/log/messages may have some hints, but I haven't read the source to understand them:

    Jan 4 06:38:22 beethoven pulseaudio[4953]: alsa-util.c: Error opening PCM device hw:0: Device or resource busy
    Jan 4 06:38:22 beethoven pulseaudio[4953]: module.c: Failed to load module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_10de_774_sound
    _card_0_alsa_playback_0 tsched=1"): initialization failed.
    Jan 4 06:38:57 beethoven kernel: hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...
    Jan 4 06:38:57 beethoven kernel: ALSA sound/pci/hda/hda_codec.c:3047: autoconfig: line_outs=4 (0x14/0x15/0x16/0x17/0x0)
    Jan 4 06:38:57 beethoven kernel: ALSA sound/pci/hda/hda_codec.c:3051: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
    Jan 4 06:38:57 beethoven kernel: ALSA sound/pci/hda/hda_codec.c:3055: hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
    Jan 4 06:38:57 beethoven kernel: ALSA sound/pci/hda/hda_codec.c:3056: mono: mono_out=0x0
    Jan 4 06:38:57 beethoven kernel: ALSA sound/pci/hda/hda_codec.c:3064: inputs: mic=0x18, fmic=0x19, line=0x1a, fline=0x0, cd=0x0, aux=0x0

    running alsaconf and alsamixer seem to go okay, but speaker-test produces no sound, but prints this:

    # speaker-test

    speaker-test 1.0.18

    Playback device is default
    Stream parameters are 48000Hz, S16_LE, 1 channels
    Using 16 octaves of pink noise
    Rate set to 48000Hz (requested 48000Hz)
    Buffer size range from 2048 to 8192
    Period size range from 1024 to 1024
    Using max buffer size 8192
    Periods = 4
    was set period_size = 1024
    was set buffer_size = 8192
    0 - Front Left
    Time per period = 2.836261
    0 - Front Left
    Time per period = 2.986717
    0 - Front Left
    [[[etc.]]]

    Help, please? Thank you.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,525
    Blog Entries
    37

    Default Re: Sound problem: SuSE 11.1 on ASUS M2N78 PRO motherboard

    Quote Originally Posted by bkorb View Post
    It just doesn't work. Sometimes, I can hear some faint scratchy sounds, but mostly no sound at all. .....

    Jan 4 06:38:57 beethoven kernel: hda_codec: Unknown model for ALC883, trying auto-probe from BIOS....
    I think that is very indicative. When alsa ran, it appears the auto probe for your hardware audio codec had difficulty. It identified your hardware audio codec as an ALC883, but it could not determine what options to apply for that.

    There is a way to manual assign the appropriate option, when the auto probe does not work. The list of possible options for an ALC883 is listed in the ALSA-Configuration.txt file for 1.0.18a of alsa as follows:
    Code:
    	ALC883/888
    	  3stack-dig	3-jack with SPDIF I/O
    	  6stack-dig	6-jack digital with SPDIF I/O
    	  3stack-6ch    3-jack 6-channel
    	  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
    	  6stack-dig-demo  6-jack digital for Intel demo board
    	  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
    	  acer-aspire	Acer Aspire 9810
    	  medion	Medion Laptops
    	  medion-md2	Medion MD2
    	  targa-dig	Targa/MSI
    	  targa-2ch-dig	Targs/MSI with 2-channel
    	  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
    	  lenovo-101e	Lenovo 101E
    	  lenovo-nb0763	Lenovo NB0763
    	  lenovo-ms7195-dig Lenovo MS7195
    	  lenovo-sky	Lenovo Sky
    	  haier-w66	Haier W66
    	  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
    	  6stack-dell	Dell machines with 6stack (Inspiron 530)
    	  mitac		Mitac 8252D
    	  clevo-m720	Clevo M720 laptop series
    	  fujitsu-pi2515 Fujitsu AMILO Pi2515
    	  3stack-6ch-intel Intel DG33* boards
    	  auto		auto-config reading BIOS (default)
    Those model options can be applied only one at a time, and there is a possibility that applying one of the model options from that list will solve your problem. I would need to see the content of your PC's /etc/modprobe.d/sound file before I could recommend the exact change to make.

    Also, there is always the possibility there is another reason for the audio problem you are experiencing, and hence it would be helpful if you could provide more information to improve the odds of an accurate assessment as to the problem you are experiencing (and solution(s) to try fix the problem). So can you provide more very detailed information so a good recommendation can be given? You can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and typing:
    /usr/sbin/alsa-info.sh

    that will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. I need that output to understand better your PC's configuration. If the script notes an update is available, either select NO (and do not update it, but run it anyway) or select YES, watch the update fail, and then re-run the script with root permissions (which will allow an update to the diagnostic script to be made). Don't forget to post the output URL here provided by a successful running of the diagnostic script.

    Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound
    I also need that output. Hopefully with that I can make a good recommendation.

  3. #3
    Join Date
    Jul 2008
    Location
    Santa Cruz, CA
    Posts
    250

    Default Re: Sound problem: SuSE 11.1 on ASUS M2N78 PRO motherboard

    Hey, thank you "oldcpu". Sorry, I just don't have the
    energy to mess with this that often.
    Anyhow, some output for you (hope you're still there....):

    Your ALSA information is located at
    http://www.alsa-project.org/db/?f=c5...da56ce8d0bc709
    $> rpm -qa | egrep 'alsa|pulse'
    alsa-oss-32bit-1.0.17-1.37
    pulseaudio-module-zeroconf-0.9.12-9.5
    alsa-oss-1.0.17.git20080715-2.7
    alsa-tools-1.0.18.git20081201-1.5
    libpulse-browse0-0.9.12-9.5
    alsa-utils-1.0.18.git20081122-1.7
    libpulse0-0.9.12-9.5
    pulseaudio-module-jack-0.9.12-9.5
    alsa-driver-kmp-default-1.0.18.20090104_2.6.27.7_9.1-1.1
    alsa-firmware-1.0.17.git20081202-2.3
    pulseaudio-module-bluetooth-0.9.12-9.5
    libxine1-pulse-1.1.15-20.8
    alsa-1.0.18.git20081212-1.1
    libpulse-mainloop-glib0-0.9.12-9.5
    libpulsecore4-0.9.12-9.5
    pulseaudio-0.9.12-9.5
    pulseaudio-module-x11-0.9.12-9.5
    alsa-devel-1.0.18.git20081212-1.1
    pulseaudio-module-lirc-0.9.12-9.5
    alsa-plugins-pulse-1.0.18.git20081122-1.11
    alsa-plugins-1.0.18.git20081122-1.11
    pulseaudio-utils-0.9.12-9.5
    pulseaudio-esound-compat-0.9.12-9.5
    $> uname -a
    Linux beethoven 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux
    $> cat /etc/modprobe.d/sound

    options snd slots=snd-hda-intel
    # M71A.GTi64jAMZRE:MCP78S [GeForce 8200] High Definition Audio
    alias snd-card-0 snd-hda-intel

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,525
    Blog Entries
    37

    Default Re: Sound problem: SuSE 11.1 on ASUS M2N78 PRO motherboard

    Quote Originally Posted by bkorb View Post
    Anyhow, some output for you (hope you're still there....):

    Your ALSA information is located at
    http://www.alsa-project.org/db/?f=c5...da56ce8d0bc709
    OK, start by looking at your mixer. I've copied and pasted the following lines from that diagnostic script, indicating some mixer settings you need to look at. Green is "good". Red indicates you should check this. Red bold is DEFINITELY set wrong.
    !!Amixer output
    !!-------------

    !!-------Mixer controls for card 0 [NVidia]

    Card hw:0 'NVidia'/'HDA NVidia at 0xfe020000 irq 20'
    Mixer name : 'Realtek ALC1200'
    Simple mixer control 'Master',0
    Mono: Playback 31 [100%] [0.00dB] [on]
    Simple mixer control 'PCM',0
    Front Left: Playback 0 [0%] [-51.00dB]
    Front Right: Playback 0 [0%] [-51.00dB]
    Simple mixer control 'Front',0
    Front Left: Playback 23 [74%] [-12.00dB] [on]
    Front Right: Playback 23 [74%] [-12.00dB] [on]
    Simple mixer control 'Surround',0
    Front Left: Playback 0 [0%] [-46.50dB] [on]
    Front Right: Playback 0 [0%] [-46.50dB] [on]
    Simple mixer control 'Center',0
    Mono: Playback 0 [0%] [-46.50dB] [on]
    Simple mixer control 'LFE',0
    Mono: Playback 0 [0%] [-46.50dB] [on]
    Simple mixer control 'Side',0
    Front Left: Playback 0 [0%] [-46.50dB] [on]
    Front Right: Playback 0 [0%] [-46.50dB] [on]
    Simple mixer control 'Line',0
    Front Left: Playback 0 [0%] [-34.50dB] [on]
    Front Right: Playback 0 [0%] [-34.50dB] [on]
    Simple mixer control 'CD',0
    Front Left: Playback 0 [0%] [-34.50dB] [on]
    Front Right: Playback 0 [0%] [-34.50dB] [on]
    Simple mixer control 'IEC958',0
    Mono: Playback [on] Capture [off]
    Simple mixer control 'IEC958 Default PCM',0
    Mono: Playback [on]
    Simple mixer control 'Channel Mode',0
    Items: '6ch' '8ch'
    Item0: '6ch'
    You have your PCM volume at 0%. That is DEFINITELY wrong. Move it up to 95% for testing your audio. You can reduce it to a lower % after audio is established.

    You also have many other controls "ON", but at 0%. IMHO you should either move their volume controls UP when ON, or switch them OFF if (and only if) you are certain they do not affect your volume.

    Quote Originally Posted by bkorb View Post
    $> rpm -qa | egrep 'alsa|pulse'
    alsa-oss-32bit-1.0.17-1.37
    pulseaudio-module-zeroconf-0.9.12-9.5
    alsa-oss-1.0.17.git20080715-2.7
    alsa-tools-1.0.18.git20081201-1.5
    libpulse-browse0-0.9.12-9.5
    alsa-utils-1.0.18.git20081122-1.7
    libpulse0-0.9.12-9.5
    pulseaudio-module-jack-0.9.12-9.5
    alsa-driver-kmp-default-1.0.18.20090104_2.6.27.7_9.1-1.1
    alsa-firmware-1.0.17.git20081202-2.3
    alsa-1.0.18.git20081212-1.1
    alsa-devel-1.0.18.git20081212-1.1
    alsa-plugins-pulse-1.0.18.git20081122-1.11
    alsa-plugins-1.0.18.git20081122-1.11
    This looks ok, although there is a newer 1.0.19 of alsa available. I do NOT see the output of "rpm -q libasound", so I have to assume it is also ok.


    Looking at the diagnostic script, I see your PC has an ALC1200. Searching the alsa web site for the ALC1200 (which is reported by the script) I see the following: Search results for alc1200 - AlsaProject where the ALC1200 codec support was only recently added, and it is almost compatible with an ALC888. Hence you could update your alsa to 1.0.19. Alsa-update - openSUSE Note you MUST restart after updating alsa.

    Hence if fixing your mixer and if updating your alsa (to 1.0.19) does not work, then you could try some model options in your /etc/modprobe.d/sound file.


    Quote Originally Posted by bkorb View Post
    Code:
    options snd slots=snd-hda-intel
    # M71A.GTi64jAMZRE:MCP78S [GeForce 8200] High Definition Audio
    alias snd-card-0 snd-hda-intel
    So if you were to try an edit to this file , lets say to apply the "auto" option from the ALC883/888 list, then the edited file would look like this:
    Code:
    options snd-hda-intel model=auto
    options snd slots=snd-hda-intel
    # M71A.GTi64jAMZRE:MCP78S [GeForce 8200] High Definition Audio
    alias snd-card-0 snd-hda-intel
    and then one needs to restart one's alsa sound drive with su -c 'rcalsasound restart' and enter root password when prompted for a password, restart one's mixer, check the mixer and test one's sound. When testing the sound, try both of these speaker tests as both a regular user, and as user root:
    speaker-test -Dplug:front -c2 -l5 -twav
    Note Linux is case sensitive, and D is not the same as d. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set to 95% for initial testing, then back off to a lower % once sound established. Note the test for surround sound is different. If that test yields errors, try instead this more simple test:
    speaker-test -c2 -l5 -twav


    Then if "auto" does not work, replace "auto" in the /etc/modprobe.d/sound file with another model from the list provided above (in a previous post), such as "3stack-dig", resart alsa, restart one's mixer, and test one's sound.

    Good luck.

  5. #5
    Join Date
    Jan 2009
    Location
    Fremont, California, United States, Earth, Sol
    Posts
    7

    Default Re: Sound problem: SuSE 11.1 on ASUS M2N78 PRO motherboard

    Just wanted to note that the tips in this thread worked well for my ASUS M3N78 PRO motherboard.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •