Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: No Mic Output Selection In Kmix

  1. #1

    Default No Mic Output Selection In Kmix

    I've been running PCLinuxOs 2007 on my desktop for the past year and just installed OpenSUSE on my hp laptop.Kmix in PCLinux presents three tabs: input, output, and switches. These tabs aren't present in the kmix mixer window I see in SUSE. What is happening is when I speak into the microphone I'm hearing myself through the speakers.... very annoying when on Skype. I addressed this on my desktop by turning the mic setting under the output tab all the way down. Anyone have a solution to my dilemma?

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,570
    Blog Entries
    38

    Default Re: No Mic Output Selection In Kmix

    The mixer with the KDE4 desktop has a menu item which allows one to add additional controls to the mixer.

  3. #3

    Default Re: No Mic Output Selection In Kmix

    Thank you for your reply. I had found that feature and added the mic controls to the mixer window, but mic output doesn't seem to be an option..... only the mic input.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,570
    Blog Entries
    38

    Default Re: No Mic Output Selection In Kmix

    Quote Originally Posted by longgraybeard View Post
    Thank you for your reply. I had found that feature and added the mic controls to the mixer window, but mic output doesn't seem to be an option..... only the mic input.
    Why would you want a mic output?

  5. #5

    Default Re: No Mic Output Selection In Kmix

    I need to see the mic output selection so I can turn it off. The default seems to be on. That's why I'm hearing myself through the speakers. I would like to have mic input on, mic boost on, and mic output off. I've accomplished the first two but not the third.

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,570
    Blog Entries
    38

    Default Re: No Mic Output Selection In Kmix

    Quote Originally Posted by longgraybeard View Post
    I need to see the mic output selection so I can turn it off. The default seems to be on. That's why I'm hearing myself through the speakers. I would like to have mic input on, mic boost on, and mic output off. I've accomplished the first two but not the third.
    I do not know about PCLinuxOs 2007 , but in most Linux versions I thought that (hearing yourself thru the speakers) was known as loopback?

    Which version of openSUSE are you running? If running openSUSE-11.1 you could, with your PC connected to the internet, type:
    /usr/sbin/alsa-info.sh

    and that will provide a URL (if it asks to update, you may need to re-run it as root to ensure the update works). Please post here the output URL you get after a successful run of the script.

  7. #7

    Default Re: No Mic Output Selection In Kmix

    Thank you for taking the time to help. I ran Alsa-info.sh as su and it did update. The resulting URL is http://www.alsa-project.org/db/?f=14...a245b857e3d9ba

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,570
    Blog Entries
    38

    Default Re: No Mic Output Selection In Kmix

    Quote Originally Posted by longgraybeard View Post
    Thank you for taking the time to help. I ran Alsa-info.sh as su and it did update. The resulting URL is http://www.alsa-project.org/db/?f=14...a245b857e3d9ba
    I don't see anything obviously wrong there. I do note your PC has a Cx20468 (uses the snd_ali5451 kernel module). do you get this mic effect with arecord? if not, then it could be a skype problem. You can run arecord as follows, typing in a gnome terminal or a kde konsole:
    arecord -d 10 myrecording.wav
    where "-d 10" specifies a 10 second recording. Record 10 seconds there and then a play back "myrecording.wav" with a nominal player. While recording, do you still hear your voice being looped back to you?

    It may be that your sound config is not properly configured by alsa. I do not see any options specific to the CX20549, although there are some conexant model options in the ALSA-Configuration.txt list for 1.0.18a of alsa:
    Code:
     	Conexant 5045
    	  laptop-hpsense    Laptop with HP sense (old model laptop)
    	  laptop-micsense   Laptop with Mic sense (old model fujitsu)
    	  laptop-hpmicsense Laptop with HP and Mic senses
    	  benq		Benq R55E
    	  test		for testing/debugging purpose, almost all controls
    			can be adjusted.  Appearing only when compiled with
    			$CONFIG_SND_DEBUG=y
    
    	Conexant 5047
    	  laptop	Basic Laptop config 
    	  laptop-hp	Laptop config for some HP models (subdevice 30A5)
    	  laptop-eapd	Laptop config with EAPD support
    	  test		for testing/debugging purpose, almost all controls
    			can be adjusted.  Appearing only when compiled with
    			$CONFIG_SND_DEBUG=y
    
    	Conexant 5051
    	  laptop	Basic Laptop config (default)
    	  hp		HP Spartan laptop
    I do not know if any of those are applicable to your laptop. But it would not hut to test them one at a time. I can provided a recommend syntax for an edit to your /etc/modprobe.d/sound file to test them. Accordingly, can you provide the output of:
    Code:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    uname -a
    cat /etc/modprobe.d/sound

  9. #9

    Default Re: No Mic Output Selection In Kmix

    Yes, the mic is heard through the speakers at all times when plugged in; even when Skype isn't running. If I tap on it, blow, whistle, speak, the sound is coming right through them.

    You mentioned the configuration of Alsa. When setting up my desktop I ran something called alsaconfig. I don't see that listed in the SUSE repositories. Is that a tool that isn't necessary with this distribution?

    results for rpm -qa | grep alsa:

    alsamixergui-0.9.0rc1-584.132
    alsa-1.0.18-8.7
    alsa-plugins-1.0.18-6.12

    results for rpm -qa | grep pulse:

    pulseaudio-module-zeroconf-0.9.12-9.6
    libpulsecore4-0.9.12-9.6
    pulseaudio-utils-0.9.12-9.6
    pulseaudio-module-jack-0.9.12-9.6
    libpulse0-0.9.12-9.6
    libpulse-mainloop-glib0-0.9.12-9.6
    alsa-plugins-pulse-1.0.18-6.12
    pulseaudio-module-lirc-0.9.12-9.6
    pulseaudio-0.9.12-9.6
    pulseaudio-module-bluetooth-0.9.12-9.6
    libpulse-browse0-0.9.12-9.6
    pulseaudio-esound-compat-0.9.12-9.6
    libxine1-pulse-1.1.15-20.8
    pulseaudio-module-x11-0.9.12-9.6

    results for uname -a:

    Linux linux-xinm 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 i686 athlon i386 GNU/Linux

    results for cat /etc/modprobe.d/sound:

    options snd slots=snd-ali5451
    # H0_h.9IOAySjxlQ5avilion ze4400 builtin Audio
    alias snd-card-0 snd-ali5451

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,570
    Blog Entries
    38

    Default Re: No Mic Output Selection In Kmix

    Quote Originally Posted by longgraybeard View Post
    Yes, the mic is heard through the speakers at all times when plugged in; even when Skype isn't running. If I tap on it, blow, whistle, speak, the sound is coming right through them.

    You mentioned the configuration of Alsa. When setting up my desktop I ran something called alsaconfig. I don't see that listed in the SUSE repositories. Is that a tool that isn't necessary with this distribution?
    alsaconfig? Do you mean "alsaconf" ? alsaconf comes with alsa-utils, which you do not appear to have installed.

    Quote Originally Posted by longgraybeard View Post
    results for rpm -qa | grep alsa:

    alsamixergui-0.9.0rc1-584.132
    alsa-1.0.18-8.7
    alsa-plugins-1.0.18-6.12
    Are you certain you did not forget to copy any applications as a result of typing: "rpm -qa | grep alsa" ? I'm really surprised alsa-utils is not present, as that is installed by default. It provides both alsaconf and alsamixer.

    I recommend you also install alsa-tools and alsa-utils, reboot and see if you have any additional mixer selections.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •