Results 1 to 3 of 3

Thread: Qt (...) (library qt-mt) not found.

  1. #1

    Question Qt (...) (library qt-mt) not found.

    Tried to compile klibido first and then kwebget. In both cases during configure I get:
    "checking for Qt... configure: error: Qt (>= Qt 3.0.2) (library qt-mt) not found. Please check your installation!
    For more details about this problem, look at the end of config.log.
    Make sure that you have compiled Qt with thread support!"
    I think the section in the log pertaining to this is:
    "configure:19124: rm -rf SunWS_cache; g++ -o conftest -O2 -fno-exceptions -fno-check-new -I/usr/lib/qt3/include -I. -DQT_THREAD_SUPPORT -D_REENTRANT -L/usr/lib/qt3/lib -L/usr/lib64 -lqt-mt -lpng -lz -lm -ljpeg -ldl -lXext -lX11 -lSM -lICE -lresolv -lpthread 1>&5
    /usr/lib64/gcc/x86_64-suse-linux/4.3/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/qt3/lib/ when searching for -lqt-mt
    /usr/lib64/gcc/x86_64-suse-linux/4.3/../../../../x86_64-suse-linux/bin/ld: cannot find -lqt-mt
    collect2: ld returned 1 exit status".

    I found is a link to

    I tried all kind of things to no avail. I only found one openSUSE Forums entry on this, from 2004 and it doesn't apply.

    OS: Linux x86_64
    System: openSUSE 11.1 (x86_64)
    KDE: 3.5.10 "release 33.1"

  2. #2
    Join Date
    Jun 2008

    Default Re: Qt (...) (library qt-mt) not found.

    Do you have qt3-devel installed?

  3. #3

    Post Re: Qt (...) (library qt-mt) not found.

    Yes, qt3-devel 3.3.8b-88.5 is installed.
    Judging by the config.log "skipping incompatible /usr/lib/qt3/lib/ when searching for -lqt-mt" the is deemed "incompatible", for some reason.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts