Results 1 to 10 of 10

Thread: High X server CPU utilization in 11.1 when X session idle

  1. #1

    Question High X server CPU utilization in 11.1 when X session idle

    I've been using openSuSE 11.1 for almost two weeks and am generally impressed with how smoothly the installation went and the stability of the platform. I do have a few X server (or perhaps nvidia driver) issues that I'd like some help with.

    1) (The most serious problem.) When an X session (running KDE4) is idle for some period of time (say about 10 minutes) its CPU utilization shoots to 100%. I disabled the screensaver to rule that out and it made no difference. If I have two X sessions running (on vt7 and vt8), the one not currently selected will go to 100% while the one I am using behaves normally. If both sessions are idle, I can see from the text-based console that both X processes have moved to 100% (it's a dual core machine). I don't see any telling messages in the X log files or dmsg. As soon as I switch to the inactive window, it's X CPU utilization drops to normal (even if I don't type anything or move the mouse) and everything works just fine after that. X is very stable (no crashes so far), but the CPU utilization when idle is hard to explain and very "expensive."

    2) This appears to be entirely a cosmetic problem, but KDE4 widgets or defined rectangular regions in the task bar occasionally blink between "normal" and "mostly black". Mousing over them seems to get them to behave for a while. Nothing crashes and I cannot see any lasting effects of the problem. My wife says she's seen entire windows do this, but I've never seen that (yes, my non-technical wife uses Linux... I am blessed). This happens with both the fancy KDE4 effects enabled and disabled.

    3) DPMS doesn't work if a screen saver is enabled (I saw someone else mention this as well). Disabling the screen saver will allow DPMS to turn off the monitor, as expected, after the time expires.

    I cannot find any references to my first or second problem, so I am wondering if this is an interaction with my nvidia driver (which is up to date). Here's the info about it:

    root@alpha /etc/postfix cat /proc/driver/nvidia/cards/0
    Model: Quadro FX 540
    IRQ: 16
    Video BIOS: 05.43.02.64.35
    Card Type: PCI-E
    DMA Size: 39 bits
    DMA Mask: 0x7fffffffff
    Bus Location: 08.00.0
    root@alpha /etc/postfix cat /proc/driver/nvidia/version
    NVRM version: NVIDIA UNIX x86_64 Kernel Module 177.82 Tue Nov 4 16:50:05 PST 2008
    GCC version: gcc version 4.3.2 [gcc-4_3-branch revision 141291] (SUSE Linux)


    I know my way around the server side of Linux pretty well, but have never really developed any expertise with X so I am not sure how to debug this or what other info the X experts might find useful. Let me know!

    Thanks for any insights.

  2. #2
    tbrauer01 NNTP User

    Default Re: High X server CPU utilization in 11.1 when X session idl

    I have experienced exact same problem with x-window on SUSE 11.1 64-bit using ATI X1300 (old) video card. Also updated the video driver - no affect. After idle for approx 10 mins - starts using 100% of CPU. I do not have solution, but wanted to note have experienced same issue with different video card / system.

  3. #3

    Default Re: High X server CPU utilization in 11.1 when X session idl

    My previous 11.1 install did this. But my current install (in which I did nothing different AFAIK) does not. Go figure.

    Someone suggested that it was the PSU fan making all the noise, but I don't know if this is the case.

    Gentlemen, I believe we have a bona fide OpenSuse mystery on our hands.

  4. #4

    Default Re: High X server CPU utilization in 11.1 when X session idl

    Hi,

    I'm experiencing the same issue with my HP nc6120 [intel 915GM video card].
    I'm running opensuse 11.1 with KDE3 [KDE4 is not a way I want to go now]. But I still have few KDE4 packages that have been installed automatically.

    The key words of the issues are: kded4, DPMS and powerdevil.

    Here is an interesting link [go through the previous threads]:
    Re: 100% CPU usage of Xorg after 15 minutes
    ...and the related powerdevil bug:
    https://bugs.kde.org/show_bug.cgi?id=174897
    Stress is bad...

  5. #5

    Default Re: High X server CPU utilization in 11.1 when X session idl

    As I do not really care about KDE4 applications, I've choose to take the easy way and uninstall powerdevil:

    # zypper remove powerdevil-1.4.1-4.3 kdebase4-workspace-4.1.3-10.1.i586 kdebase4-openSUSE-11.1-66.4.i586

    I'm not experiencing the X hight CPU issue anymore using opensuse 11.1 and KDE3...

    If you are a KDE4 user you should wait for the packagers to port the latest powerdevil 1.4.2 that will probably fix the issue:
    PowerDevil KDE-Apps.org

    If you want to check if the latest version has been ported to opensuse:
    Software.openSUSE.org
    Stress is bad...

  6. #6

    Default Re: High X server CPU utilization in 11.1 when X session idl

    I disabled "dim display after x min" in power management settings, and load is now normal.

  7. #7
    Join Date
    Jun 2008
    Location
    Utah
    Posts
    22

    Default Re: High X server CPU utilization in 11.1 when X session idl

    I'm experiencing the same thing on a Dell Precision M4400 with an nVidia Quadro FX 770M display adapter. The software is openSUSE 11.1 and NVidia 177.82-1.1. The backlight can be off or on, lid closed or open, and no indications of what's going on in the logs that I can find.

    I would prefer not to leave my backlight on 24-hours a day as I typically don't shut the computer down at night.

  8. #8
    Join Date
    Jun 2008
    Location
    Utah
    Posts
    22

    Default Re: High X server CPU utilization in 11.1 when X session idl

    Found this:
    https://bugzilla.novell.com/show_bug.cgi?id=461335

    It appears that powerdevil-1.4.1-17 fixes the issue.

    You can find the package in this openSUSE BuildService repository:
    http://download.opensuse.org/reposit...openSUSE_11.1/

  9. #9
    Join Date
    Jun 2008
    Location
    Australia
    Posts
    103

    Default Re: High X server CPU utilization in 11.1 when X session idl

    god****! I had the same issue with my last install. I tried everything (including reinstall). My resolution was to change GPU. The card giving errors was a gigabyte GV-8400. I swapped it for an older 7950XT (I paid a **** load for this card originally) that fixed my out of control CPU usage. There is a chance that this is a reporting issue. It has popped up a few times already in this thread. should we BUG this??
    if it aint broken...dont let me near it

  10. #10

    Default Re: High X server CPU utilization in 11.1 when X session idl

    I have this problem too
    DELL XPS m1530 ,opensuse 11.1 ,NVidia 177.82
    gnome with compiz enabled.
    when my pc is idle and screensaver is active,
    my computer consume lots of CPU .
    that is when my pc is idle and screensaver is active,my pc's cpu load is very high,after i move mouse or press any key to inactive screensaver ,cpu usage become normal.
    I install kde 4.1 ,but rare use it . i realize some people said that is might because powerdevil ,so i install the newst powerdevil,but have no affect about the high cpu usage.
    is this a bug,any one have workaround about it?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •