Results 1 to 8 of 8

Thread: Switched to KDE 4.2 beta 2, but reverted...

  1. #1

    Default Switched to KDE 4.2 beta 2, but reverted...

    I didn't know where exactly to put this. But last night I wanted to try the KDE 4.2 beta 2 that is out on my recently installed suse 11.1. I clicked on the "One-Click install" found here K Desktop Environment - KDE 4.2 Beta2 Info Page

    Another reason for me wanting to try this is because I have read that some people are having great results with KDE 4.2 beta 2 fixing the NVIDIA slow scroll speeds in firefox and other programs. (I recently bought a NVIDIA 8400GS due to my ATI 9800 pro self destructing its fan).

    It gave me a bunch of errors about dependencies. I clicked each one to uninstall the old and install the new. Everything worked, so I rebooted. It only booted to the linux shell with "suse login" I logged in and after figuring out on our other computer how to boot. I typed in "startx" It loaded and I confirmed it was KDE 4.2 beta 2. However, things were missing and I couldn't deal with a boot that made it as far as the linux prompt.

    So I proceeded to uninstall KDE 4.2 beta 2 via yast and went back to KDE 4.1 that came with 11.1 Everything went fine, fixed a few dependency errors and restarted. Everything booted fine. However, when I clicked on the suse menu at the bottom left, the screen went black. I tried in failsafe, and the screen went white.

    I thought it was a graphics driver issue so I tried yast at the linux command to reinstall nvidia driver. This did not work. I managed to figure out that it was not this, and was a KDE error with missing files. So I booted into suse, did not click on the menu but brought up command>>yast. Fixed a few dependencies that were still wrong. Rebooted and the menu works.

    Everything appears to be working properly. However, the KDE widget menu to add is showing the KDE logo on the launch application menu...that should be suse.

    Not a big deal but, Anyone know how to repair the widget problem? I am just happy to have it boot and have the menu back.

    Further...anyone know how to properly install KDE 4.2 beta 2? Or am I better off waiting until someone comes out with a package? I am still somewhat new to linux. But I know enough how to install and get things working, screw them up, and somehow fix what I did.

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Switched to KDE 4.2 beta 2, but reverted...

    I have been running it for quite some time, before it was Beta.

    Theoretically the oneclick should work. But I never use them.

    Add the repo's manually.
    Then use Yast software management to do update all unconditionally in each of those repo's you add

    Index of /repositories/KDE:/KDE4:/UNSTABLE:/Desktop/openSUSE_11.1

    Index of /repositories/KDE:/KDE4:/UNSTABLE:/Extra-Apps/openSUSE_11.1

    Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE4_UNSTABLE_Desktop

    I'm adding QT at the moment
    Index of /repositories/KDE:/Qt/openSUSE_11.1

    Check the principles in this post and links:
    Yast - Software Management -Update All_HowTo - openSUSE Forums
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Switched to KDE 4.2 beta 2, but reverted...

    Thanks caf4926, I added those repositories but i get the same thing on boot. Have to boot in to kde with startx.

    Anyone know how to repair this?

    Also, i have the blue start menu instead of suse. Is that what you have?

    Thanks

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Switched to KDE 4.2 beta 2, but reverted...

    Quote Originally Posted by WildSioux View Post
    Thanks caf4926, I added those repositories but i get the same thing on boot. Have to boot in to kde with startx.

    Anyone know how to repair this?

    Also, i have the blue start menu instead of suse. Is that what you have?

    Thanks
    I have the blue start icon -Yes.

    No problem with boot/login

    I have read a few with this 'startx' issue after adding 4.2 beta. But adding kde4.2 should not have altered this.

    Check in /boot/grub/

    look for the working: menu.lst

    and see if there is also a : menu.lst.old

    compare the boot arguments in the default boot line.

    This file should not have been altered anyway. I have had others try re-naming .kde4 to .kde4old to start a new kde4 folder. But for them it didn't solve it.

    What about kde3? Or don't you have that installed.
    =======================

    Make sure you disable auto login in Yast - Users and Group Management

    also

    Check in Yast software management
    filter by repo
    look in the kde4.2 beta repo's - see if any packages are Red or Blue
    If so update
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Switched to KDE 4.2 beta 2, but reverted...

    Ok, it sounds like I have done everything correct since I have the blue menu icon.

    I checked in /boot/grub/ at the menu.lst (only one in that directory). This is what is in there...

    Code:
    # Modified by YaST2. Last modification on Mon Dec 22 15:36:50 EST 2008
    default 0
    timeout 8
    gfxmenu (hd0,5)/boot/message
    ##YaST - activate
    
    ###Don't change this comment - YaST2 identifier: Original name: windows###
    title Windows XP
        rootnoverify (hd0,0)
        chainloader +1
    
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.1 - 2.6.27.7-9
        root (hd0,5)
        kernel /boot/vmlinuz-2.6.27.7-9-pae root=/dev/disk/by-id/ata-Maxtor_6Y080L0_Y2MAGHFE-part6 resume=/dev/disk/by-id/ata-Maxtor_6Y080L0_Y2MAGHFE-part5 splash=silent showopts vga=0x31a
        initrd /boot/initrd-2.6.27.7-9-pae
    
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.1 - 2.6.27.7-9
        root (hd0,5)
        kernel /boot/vmlinuz-2.6.27.7-9-pae root=/dev/disk/by-id/ata-Maxtor_6Y080L0_Y2MAGHFE-part6 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x31a
        initrd /boot/initrd-2.6.27.7-9-pae

    I don't see anything about the "default boot line..." Hmm?

    Also, no I don't have KDE 3.5 installed. Just 4.1

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Switched to KDE 4.2 beta 2, but reverted...

    Quote Originally Posted by WildSioux View Post
    Ok, it sounds like I have done everything correct since I have the blue menu icon.

    I checked in /boot/grub/ at the menu.lst (only one in that directory). This is what is in there...
    Code:
    # Modified by YaST2. Last modification on Mon Dec 22 15:36:50 EST 2008
    default 0
    timeout 8
    gfxmenu (hd0,5)/boot/message
    ##YaST - activate
    
    ###Don't change this comment - YaST2 identifier: Original name: windows###
    title Windows XP
        rootnoverify (hd0,0)
        chainloader +1
    
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.1 - 2.6.27.7-9
        root (hd0,5)
        kernel /boot/vmlinuz-2.6.27.7-9-pae root=/dev/disk/by-id/ata-Maxtor_6Y080L0_Y2MAGHFE-part6 resume=/dev/disk/by-id/ata-Maxtor_6Y080L0_Y2MAGHFE-part5 splash=silent showopts vga=0x31a
        initrd /boot/initrd-2.6.27.7-9-pae
     
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.1 - 2.6.27.7-9
        root (hd0,5)
        kernel /boot/vmlinuz-2.6.27.7-9-pae root=/dev/disk/by-id/ata-Maxtor_6Y080L0_Y2MAGHFE-part6 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x31a
        initrd /boot/initrd-2.6.27.7-9-pae
    I don't see anything about the "default boot line..." Hmm?

    Also, no I don't have KDE 3.5 installed. Just 4.1
    RED = Default boot for openSUSE, only you have switched XP to 1st.

    Mine looks like this:

    Code:
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.1 - 2.6.27.7-9
        root (hd0,1)
        kernel /boot/vmlinuz-2.6.27.7-9-pae root=/dev/disk/by-id/ata-ST9160827AS_5RF16D1B-part2 resume=/dev/disk/by-id/ata-ST9160827AS_5RF16D1B-part1 splash=silent showopts vga=0x367
        initrd /boot/initrd-2.6.27.7-9-pae
    So I can't see anything wrong in yours. Maybe someone else can think why you get this issue.

    Only other thought I had was:
    What window manager are you using?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Switched to KDE 4.2 beta 2, but reverted...

    Check
    /etc/sysconfig/windowmanager

    the line startkde

    ## Type: string
    ## Default:
    ## Path: Desktop
    ## Description: default mouse cursor theme
    #
    # Name of mouse cursor theme for X11. Possible themes can be found
    # in /usr/share/icons/
    #
    X_MOUSE_CURSOR="DMZ"
    ## Path: Desktop/Window manager
    ## Description:
    ## Type: string(kde,fvwm,gnome,windowmaker)
    ## Default: kde
    ## Config: profiles,kde,susewm
    #
    # Here you can set the default window manager (kde, fvwm, ...)
    # changes here require at least a re-login
    DEFAULT_WM="startkde"

    ## Type: yesno
    ## Default: yes
    #
    # install the SuSE extension for new users
    # (theme and additional functions)
    #
    INSTALL_DESKTOP_EXTENSIONS="yes"
    ## Path: Desktop
    ## Description: prepare global sycoca database for faster first startup
    ## Type: list(yes,initial,no)
    ## Default: initial
    #
    # building a global sycoca database, which can be used at first user
    # login in KDE
    #
    KDE_BUILD_GLOBAL_SYCOCA="initial"

    ## Type: yesno
    ## Default: yes
    #
    # To disable IPv6 support within KDE. It might solve large timeouts due to
    # broken servers which claim to have IPv6 support, but do not respond.
    #
    KDE_USE_IPV6="no"

    ## Type: yesno
    ## Default: yes
    #
    # IDN support can get disabled to avoid DNS phishing for example.
    #
    KDE_USE_IDN="yes"
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: Switched to KDE 4.2 beta 2, but reverted...

    I fixed the problem. I deleted kdm.log found in /var/log/kdm.log/var/log/ and rebooted.

    I also changed KDM4 to KDM in the display manager in /etc/sysconfig editor. Not sure if that did it but the first one did. And yes, it says startkde.

    Regardless, it boots in to KDE and I have 4.2 beta2 running. I have noticed it runs better with my nvidia card in firefox, dolphin, and other programs. Not as jumpy but better.

    Now the problem is, during boot after the openSUSE splash screen, and the NVIDIA screen...right before it boots in to KDE it shows a garbled grey horizontal lines with the mouse "X" in the middle.

    Would this be a driver issue with nvidia or is it KDE? It didn't do this in KDE 4.1.

    Thanks for you help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •