Results 1 to 6 of 6

Thread: Celestia KDE

  1. #1

    Default Celestia KDE

    I've been building Celestia KDE for a long time. I built it on Suse 9.2, 9.3, 10.0, 10.2. Now that I installed 11.1, I can't build the kde version anymore. When it starts to build the kde gui, it looks at QT4 headers in /usr/include and fails.

    I noticed that Celestia 1.5.1 is available in Suse 11.1. How was this application built?

  2. #2
    Join Date
    Jun 2008

    Default Re: Celestia KDE


    maybe you want to download the source rpm and have a closer look at the spec file. (The "build" package has a script which simplifies extracting a rpm called unrpm)

    Hope this helps

  3. #3

    Default Re: Celestia KDE

    It might of helped if I could see the files. I downloaded it and tried to install it and YAST downloaded the Celestia app and installed that instead. When I tried to add the /factory/repo/src-oss folder to my repositories that failed because it wanted to see media.1 and the folder has media.3.

    I'm trying to build the kde gui for the svn version of Celestia. This might have given me a clue but I can't see the files.

  4. #4

    Default Re: Celestia KDE

    I figured out I had to use File Roller to extract the individual files to get a peek. It didn't help so far but I only started to track down what is needed. Thank You. Maybe there is light at the end of the tunnel. Just hope it's not a train.

  5. #5

    Default Re: Celestia KDE

    Some progress to note here. Never would have guessed it but I got turned on to this to this little addition to my ./configure line.
    CXXFLAGS="-I /opt/kde3/include".
    Now the kde build works fine.
    I saw something similar in the spec file from the RPM package of Celestia and I tried the libsuffix option but that didn't work. The above option CXXFLAGS="-I /opt/kde3/include" did work.

  6. #6

    Default Re: Celestia KDE

    yes this is 23 months old thread, but for anyone searching "celestia " or "celestia qt4"
    use the /src/ file to build the qt4 build in qt-creator and edit it to point to your cspice install folder , if not "/usr/local/cspice"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts