Results 1 to 5 of 5

Thread: Unable to Disable Print Screen Key in GNOME Desktop

Hybrid View

  1. #1
    chada67 NNTP User

    Question Unable to Disable Print Screen Key in GNOME Desktop

    I am a new-ish Linux developer, coming from a MS Windows background, so please bear with me here...

    I have researched this particular problem for a couple of days now, and have explored some of the suggested solutions without success, other than learning much more about Linux. I am hoping someone can offer some good advice.

    I am working on a kiosk right now and as part of the application, I need to disable the Print Screen keyboard button.

    I have used 'xmodmap' to map keycode 111 to NoSymbol, but that is not stopping the Snapshot dialog from appearing.

    I am using OpenSuSE 10.3 with a GNOME desktop on an IBM PC with a Logitech USB keyboard.

    I have tried swapping the keyboard with a PS/2 keyboard to see if that was the problem, but it was not.

    The strange thing is that when I use VNC 4.1.3 Free Edition to remote into this system from another IBM PC (Windows XP Pro OS), I am able to use the xmodmap -e "keycode 111 = NoSymbol" command to successfully prevent the Snapshot dialog from appearing.

    Is there some kind of keyboard mapping override or shortcut mapping going on here when I am logged into the Linux box locally, but is not happening remotely?

    Please advise.

  2. #2

    Default Re: Unable to Disable Print Screen Key in GNOME Desktop

    Not sure, but take a look in gnome control center -> keyboardshortcuts. Disable the 2 printscreen keys there.

  3. #3
    Ritesh_025 NNTP User

    Default Re: Unable to Disable Print Screen Key in GNOME Desktop

    Did that..but what i need to know is how can disable the print screen key from command line or shell code.

  4. #4
    palladium NNTP User

    Default Re: Unable to Disable Print Screen Key in GNOME Desktop

    > I am using OpenSuSE 10.3 with a GNOME desktop

    i don't know what the executable is named in GNOME, but on my 10.3
    with KDE3 it is /opt/kde3/bin/ksnapshot

    i'd guess if you renamed it to (say)
    /opt/kde3/bin/ksnapshot.NOT
    then it couldn't be found, and couldn't pop-up..

    of course that might cause a error dialog....and, is anyway a
    cludge...probably better would be to (first learn the executable name
    in GNOME, you can do that in the menu with a right click, in KDE
    anyway) and then use YaST to uninstall..

    maybe.

    --
    palladium
    seeding 11.2 DVD (64) and GNOME Live CD (32 & 64)

  5. #5

    Default Re: Unable to Disable Print Screen Key in GNOME Desktop

    Got it! run gconf-editor
    key is /apps/metacity/global_keybindings/run_command_screenshot
    set to "disabled"

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •