Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: How to enable subpixelhinting for Firefox in openSUSE 11.1

  1. #11
    Join Date
    Jun 2008
    Location
    Slovakia
    Posts
    25

    Default How to enable subpixelhinting for Firefox in openSUSE 11.1

    I've just find solution.
    It's needed to update cairo package from repo:
    Index of /repositories/home:/Fisiu/openSUSE_11.1
    Firefox and Gnome have enabled subpixel.

    Quote Originally Posted by 6205 View Post
    mmm...i know what you mean.. my answer was meant more for Axeia than for you
    anyway, i dunno how to fix it in firefox, but those KDE fonts looks sure better than mine in GNOME :/
    Can you confirm, whether it works for you also?

  2. #12
    Join Date
    Sep 2008
    Location
    Bangalore, India
    Posts
    365

    Default Re: How to enable subpixelhinting for Firefox in openSUSE 11

    I was about to write the same, ra100

    See my screenshot: http://img525.imageshack.us/img525/8532/hintingja2.png

  3. #13

    Default Re: How to enable subpixelhinting for Firefox in openSUSE 11


  4. #14
    Join Date
    Nov 2008
    Location
    London, Ont, Canada
    Posts
    94

    Default Re: How to enable subpixelhinting for Firefox in openSUSE 11

    I have a clean install (not an upgrade) of 11.1 x86_64, KDE 3.5. Using native LCD resolution at 1600x1200. With original cairo (1.8.0-5.1-x86_64)(64&32), was able to get a sharp desktop by adjusting font sizes, selecting "full" in KDE fonts, but not enabling sub-pixel hinting. At this stage FF3 CONTENT is nice size and fairly sharp, but the menu, URL entry/display area, dialogue boxes, etc., were very small, although perfectly formed. Yast is exactly the opposite: menu is correctly sized, content is small (like firefox3 menu)

    I added the above (Fisiu) repository, selected cairo (64&32) update in Yast, and then rebooted. I confirm the Fisiu repository version is installed: 1.8.0-19.1-x86_64.

    Neither Firefox 3 nor Yast changed one bit. GTK fonts are set to "use my kde fonts", I've enabled and disabled sub-pixel hinting (with reboots), nothing changes the unfavourable FF3 and Yast display situation.

    Surely there is a fix for this long outstanding problem!

  5. #15
    Join Date
    Nov 2008
    Location
    London, Ont, Canada
    Posts
    94

    Default Re: How to enable subpixelhinting for Firefox in openSUSE 11

    Another thing. IIR, there was a thread somewhere that indicated a replacement for Mozilla-xulrunner was needed to thoroughly effect the sub-pixel functionality with FF3. Can't find it now. But I'll try Googling and see what comes up.

    Moreover, at this time FF3 is a slug compared to Firefox 2 on 10.3 and 11.0. FF2 on those versions is also lazer-sharp, with no strange display behaviour from Yast, either. So I don't know if I'll ever move to 11.1 if all this doesn't get sorted out. From what I hear, Mozilla has pretty well ignored Linux. Maybe Opera, or another distribution will be my next move. Because I won't ruin my eyes because OpenSuse and Mozilla can't get this straightened out.

  6. #16
    Join Date
    Sep 2008
    Location
    Bangalore, India
    Posts
    365

    Default Re: How to enable subpixelhinting for Firefox in openSUSE 11

    For your YaST problem see this: font size in Yast - openSUSE Forums

  7. #17
    Join Date
    Jun 2008
    Location
    Mexico
    Posts
    205

    Default Re: How to enable subpixelhinting for Firefox in openSUSE 11

    Quote Originally Posted by ra100 View Post
    Hi.
    Does anybody know, how to enable subpixelhinting for Firefox and probably for Thunderbird also?
    It works for all system by default, but it doesn't work in Firefox.
    Thanks.
    Hi.

    Take a look to this post: (read it all)
    Firefox 3.0.1: Enable Using Subpixel Hunting! - openSUSE Forums
    Good luck

    Luis

    EDIT. Works perfectly on OS 11.1 GNOME and KDE4... See Post Nr. 30 for the repo.
    La Humildad no es "Status"..
    ... es un �"Don"!

  8. #18
    Join Date
    Sep 2008
    Location
    Bangalore, India
    Posts
    365

    Default Re: How to enable subpixelhinting for Firefox in openSUSE 11

    @ sorenson2743,

    Follow the link given by LuisC-SM above.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •