Results 1 to 10 of 10

Thread: kinternet smpppd policykit

  1. #1

    Default kinternet smpppd policykit

    Hi everyone.
    I've got trouble operating KINTERNET since update to OpenSuse 11.1, and I noticed in this forum that others have similar problems.
    The source of the trouble seems to be related to policykit, because running cinternet responds with "smpppd refused the connection: unprivileged, missing ord.opensuse.smpppd.connect". kinternet starts but has all menu options disabled. I can run kinternet as root user, though.
    Any help would be appreciated!
    Thanks,
    paulishere.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,713
    Blog Entries
    1

    Default Re: kinternet smpppd policykit

    You may need to add the relevant user(s) to the 'dialout' group first. You can do this from

    YaST -> Security and Users -> User and Group Management

    Hopefully, thats all there is to it.

  3. #3

    Default Re: kinternet smpppd policykit

    That doesn't help. It was the first thing I checked.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,713
    Blog Entries
    1

    Default Re: kinternet smpppd policykit

    Sorry, you're correct. Recent changes to smpppd mean that access is now controlled via PolicyKit.

    I'm still using opensuse 11, and PolicyKit changes frequently. Have a look at the /usr/share/PolicyKit/policy directory to see what policy files are included and check configuration. (Many users have had to hand-edit the storage policy in the past in order to get user access for example).

    Good luck.

  5. #5

    Default Re: kinternet smpppd policykit

    Thanks for the tip. It didn't help, though. The file org.opensuse.smpppd.policy was present, and I changed allow_any and allow_inactive from auth_admin_keep_always to yes (allow_active was already yes). The problem persisted. Are there any other places I have to check?

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,713
    Blog Entries
    1

    Default Re: kinternet smpppd policykit

    Thats all I know about. Only reference I could find here. Maybe you should contact the developers directly, or file a bug report.

  7. #7

    Default SOLVED: kinternet smpppd policykit

    It was a configuration problem after all (didn't know how to use policykit). Must call
    polkit-auth --obtain org.opensuse.smpppd.connect
    This will create an entry in a file /var/lib/PolicyKit/user-xyz.auths, and then everythign works fine.

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,713
    Blog Entries
    1

    Default Re: kinternet smpppd policykit

    Good result.

  9. #9

    Default Re: kinternet smpppd policykit

    I wonder if somebody still is keeping track of this: I granted access to my user using polkit-auth --grant ... but it didn't change nothing (polkit-auth --obtain even only worked for root, but not for the user). In /var/lib/PolicyKit I found the file and is says that rights are granted but I still don't see no network-device in the kinternet menu and smpppd is still stopped after having finished the configuration of the network-device.
    Any advice?

  10. #10

    Default Re: kinternet smpppd policykit

    polkit-auth --obtain org.opensuse.smpppd.connect
    must be executet by the intended user of kinternet.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •