hi, everyone. i have following situation:
i have an opteron station with OpenSuSE 11.1 x86-64 system installed.

after installation i've noticed there are several issues:
a) grub x86_64 requires glibc 32bit and ncurses 32bit. if i remove this glibc - i cannot use (reinstall boot loader) grub.
b) even if i decided to forget about those 32bit packages and leave them installed, when i'm trying to install something new ( for example eog- x86_64) - YAST tries to install a huge collection of 32bit software in addition to eog.

anybbody knows solution?
i can leave with gilbc-32bit and libncurses-32bit, but the most critical is B.

PS:
Code:
desktop:/home/yurii/Desktop # file /usr/sbin/grub
/usr/sbin/grub: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.4, dynamically linked (uses shared libs), stripped
however Yast2 says that grub package is 64bit