Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38

Thread: Ugly fonts

  1. #1

    Default Ugly fonts

    Having in mind that this will sound quite rude, I have to say that with openSUSE 11.1 the ugly fonts problem is at their worst ever.

    KDE 4 applications are more or less OK. KDE3 applications has yet different fonts. Firefox and other GTK applications are in their own world of ugly fonts, and OpenOffice is somewhere in between. Not to mention Java/Eclipse based applications, e.g. Lotus Notes.

    Any idea how to de-uglify :-) those fonts? I'd be more than happy to write a document on how to set nice fonts in suse, especially as I have to do that after each system upgrade.

    FWIW, I have openSUSE 10.3 set up pritty nicely, and I avoided upgrades for this ugly fonts problem only...

    Any suggestions are more than welcome.

    On the good side, openSUSE 11.1 seems to run faster (!) than 10.3 on the same hardware! Way to go, SUSE Team! :-)

    Cheers

  2. #2

    Smile Re: Ugly fonts

    Apology is policy

  3. #3

    Default Re: Ugly fonts

    He means the rendering, not just font face. I have plenty of Microsoft fonts here and everything still looks awful.

    I just tested Fedora, Mandriva and PC-BSD. The fonts look fine. I know they also look fine in Slackware. Just spin any distro live CD for five minutes and you will see the difference. openSuse FAIL.

  4. #4

    Default Re: Ugly fonts

    Quote Originally Posted by lucmove View Post
    He means the rendering, not just font face. I have plenty of Microsoft fonts here and everything still looks awful.

    I just tested Fedora, Mandriva and PC-BSD. The fonts look fine. I know they also look fine in Slackware. Just spin any distro live CD for five minutes and you will see the difference. openSuse FAIL.
    Yes, the rendering is problematic. I remember using suse 8.something and since then I'm always fighting with the fonts rendering. But again, it might be the KDE related issue. I never tried Gnome in Suse, nor KDE in some other distribution, but I might try, though.

    Anyway, I'm getting closer to what I'm looking for (my 10.3 setup, actually)...

  5. #5
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    301

    Default Re: Ugly fonts

    Hi,

    I've had some problem with fizzy fonts. For me it got fixed after setting the hinting style to full in the kde4 anti-aliasing settings (kde4 settings -> appearance -> Fonts and look out for the anti aliasing setting. Maybe this helps in your case too

  6. #6
    Join Date
    Jun 2008
    Location
    Friesland
    Posts
    207

    Default Re: Ugly fonts

    i must admit that fonts in OpenSuSe are among the worst in any distro I have come across. I am not an Ubuntu fan but their font rendering is just plain awesome, like mickeysofts. Fedora also (in gnome) does a halfway decent job and on Arch I just install the ubuntu freetype patches to make it look good.

    Wish there were patches like these for OpenSuse since obviously it cannot be solved by selecting different types of fonts and anti-aliassing and hinting only does so much I have seen.

    I also think that KDE4 especially suffers from plain ugly fonts, this goes beyond a SuSe problem imho.

    Stefan
    "The day Microsoft makes something that doesn't suck is the day they make a vacuum cleaner"
    OS: Fedora9, RHEL5, CENTOS5, Arch, OpenSuSe11
    Hardware: Dell Precision M65

  7. #7

    Default Re: Ugly fonts

    Quote Originally Posted by Monex View Post
    Hi,

    I've had some problem with fizzy fonts. For me it got fixed after setting the hinting style to full in the kde4 anti-aliasing settings (kde4 settings -> appearance -> Fonts and look out for the anti aliasing setting. Maybe this helps in your case too
    Anti-aliasing is already set.

    What makes me sad, to say so, is that KDE4 has its own font appearance settings, which don't propagate to KDE3 applications still available (e.g. Network Manager), not to mention GTK based apps, plus Java (SWT) apps are completely different beasts.

    But maybe we'll manage something, we'll see.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: Ugly fonts

    I find this very subjective.

    I personally dislike the fonts with MS-Windows.

    I've visited both Ubuntu and Fedora forums and find the same complaints, only there a small select group of users are complaining about the fonts on their distribution, with statements that they have the worst of any distribution.

    Fortunately the beauty of Linux is its about choice, and there are ways to change the font presentation to tune it to one's HIGHLY SUBJECTIVE tastes.

  9. #9

    Default Re: Ugly fonts

    I would settle with consistent font among applications...

  10. #10
    DallasDrifter NNTP User

    Default Re: Ugly fonts

    > Any suggestions are more than welcome.

    *Search* this site <http://forums.opensuse.org/search.php> for the
    many previous posts with hints on how to fix the problem. After doing
    that myself about six months ago my fonts are beautiful.

    Hope they stay that way because these are the only notes I took
    (dashed line between the various posts that I followed: maybe it
    helps you maybe not--SEARCH for yourself):

    optimal use of MS trueType core fonts for a KDE desktop on SUSE
    http://en.opensuse.org/Optimal_Use_o...esktop_on_SuSE

    ------------------------

    fonts: hinting http://opensuse-community.org/SubpixelHinting

    ------------------------

    I installed MS Fonts from the Windows XP SP2 partition. And changed
    from /etc/sysconfig/fonts-config
    - BYTECODE_BW_MAX_PIXEL="18"
    - EMBEDDED_BITMAPS_LANGUAGES=""

    --------------------------
    fonts: ms fonts
    Just download this package

    http://tinyurl.com/45omuj

    and install with yast 2

    Then set your fonts with "configure desktop" in KDE

    The adjust your bytecode interpreter
    go to

    Yast2 > System ? etc/sysconfig editor > desktop >
    Bytecode_BW_Max_Pixel
    and change setting to 18

    Then enable subpixel hinting using 'Configure Desktop', 'Appearance'
    and 'Fonts' - 'Use anti-aliasing'. I stuck with the default RGB
    Horizontal, full. I haven't forced the fonts to a set dpi either.

    set the antialiasing in your desktop config to how you like.
    Personally I set mine to full antialiasing with font sizes between 6
    and 14..

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •