Results 1 to 5 of 5

Thread: Compiz Desktop Effects in 11.1 with ATI

  1. #1

    Default Compiz Desktop Effects in 11.1 with ATI

    I wanted to post this here, since it was so hard to get it to work. I couldn't get Compiz (Desktop Effects) to work for the longest time, and it ended up being easy. First of all, Don't do 1-click. It doesn't work in Suse 11.1. These exact instructions worked great for me, adapted from the ATI post in the Suse faqs. I won't post the link, because they have distractions of their own and I don't want to loose anyone.

    I will give the condensed instructions for those that don't need hand holding. For all new linux users or even gifted amateurs (spelling disabled) like myself, you might want to read the detailed set.

    CONDENSED-------
    1) Make sure your kernel source is installed, and dowload the ati drivers directly from ati and install them.
    2) Init 3
    3) mv /etc/X11/xorg.conf /etc/X11/xorg.conf-001
    4) sax2 -r -m 0=radeon
    5) aticonfig --initial --input=/etc/X11/xorg.conf
    6) sax2 -r -m 0=fglrx
    7) reboot

    DETAILED--------
    I have an ATI X600 card, and I followed these instructions on a fresh network install, with Gnome as my default desktop. I chose during the setup to install the kernel source, which is required for step 1. If you didn't add any packages during setup, open yast, go to software management and look around until you find Kernel Development as a package or pattern. Read some other faqs on how to add this, I barely get it sometimes...

    1) Download the driver installer from ATI.

    2) Run the installer, don't choose custom, agree to everything.

    3) Log out, and Switch to the first terminal (Ctrl+Alt+F1)

    4) Login as root.

    5) run init 3 to switch to commandline linux with no Xwindows.
    # init 3

    6) Check the X session (Ctrl+Alt+F7) and make sure the login page isn't there. If it is, Sax2 will fail. If this happens, reboot, switch to Ctrl+Alt+F1, login as root again and run init 3

    7) Init 3 will hang on "init 3 has been ...". Just hit enter and it will return your # prompt.

    8) move your existing xorg.conf file to a backup.
    # mv /etc/X11/xorg.conf /etc/X11/xorg.conf-001
    The reason you do this is to get rid of your existing X configuration file. Don't worry, you will be creating a new one soon.

    9) Generate a new xorg.conf for ATI radeon by running:
    # sax2 -r -m 0=radeon
    if you are using NVIDIA, check the NVIDIA instructions for the specific set. If Sax2 says it can't access the display, check the X session (Ctrl+Alt+F7) Is it still running? Did you run init 6? Did you reboot? If you need to reboot again at this point (I did) you will get a ton of errors about gdm, X, etc. Ignore them. Login as root, init 3, carry on.

    10) Now that there is a new xorg.conf, run
    # aticonfig --initial --input=/etc/X11/xorg.conf
    This adds the specific ati schmeck to the xorg.conf file. I don't think you have to do anything in this step for nVidia, but I will test it at home on problematic XPC box.

    11) Now run:
    # sax2 -r -m 0=fglrx
    This tells Sax2 you want to use the cool 3d schmeck.

    12) REBOOT! Other directions insist you can just init 5 to restart X, or whatever, but I'm telling you, if you are a n00b and you just came from windows, go with your comfort zone and give your computer one last three finger salute.

    Each of the above steps assumes the previous one worked. I did this step by step on a fresh install with an X600 card and it worked. None of the other posts I read worked. Hopefully this will help other compiz longing noobs.

    Admins, feel free to delete this post if it's judged to be too incorrect in some way.

  2. #2

    Default Re: Compiz Desktop Effects in 11.1 with ATI

    PPC Variation

    I can't download drivers for PPC. How can I get compiz to work on IMAC G5??? Here is my xorg.conf. GLXGEars works, but compiz gives white screen of death.

    # /.../
    # SaX generated X11 config file
    # Created on: 2008-12-23T19:24:30-0500.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [SaX2] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "Files"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "Module"
    Load "dri"
    Load "dbe"
    Load "freetype"
    Load "extmod"
    Load "glx"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "macintosh"
    Option "XkbRules" "xfree86"
    EndSection

    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Device" "/dev/input/mice"
    Option "Name" "Wacom CTE-640-U V4.0-3"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "Monitor"
    DisplaySize 433 270
    HorizSync 30-82
    Identifier "Monitor[0]"
    ModelName "APPLE COLOR LCD"
    Option "DPMS"
    Option "PreferredMode" "1680x1050"
    VendorName "APP"
    VertRefresh 43-60
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    Modeline "1680x1050" 147.14 1680 1784 1968 2256 1050 1051 1054 1087
    Modeline "1680x1050" 117.00 1680 1728 1760 1840 1050 1053 1059 1080 +HSync -Vsync
    EndSection


    Section "Device"
    BoardName "RV350 AP"
    Driver "radeon"
    Identifier "Device[0]"
    Option "monitor-DVI-1" "Monitor[0]"
    VendorName "ATI"
    EndSection


    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1680x1050"
    Virtual 3840 1200
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1680x1050"
    Virtual 3840 1200
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1680x1050"
    Virtual 3840 1200
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1680x1050"
    Virtual 3840 1200
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Screen "Screen[0]"
    EndSection


    Section "DRI"
    Group "video"
    Mode 0660
    EndSection
    Section "Extensions"
    Option "Composite" "True"
    EndSection

  3. #3

    Default Re: Compiz Desktop Effects in 11.1 with ATI

    nVidia Variation

    nVidia one click worked perfectly. Do that.

  4. #4
    Join Date
    Nov 2008
    Location
    Hungary
    Posts
    32

    Default Re: Compiz Desktop Effects in 11.1 with ATI

    After i installed ati driver, i cant change themes and icons. It's say that it can't start gnome-settings-daemon, because of some other settings-daemon already run (kde or bonobo etc.) and then some options will not take effect. And it's true a lot of options don't do nothing.

  5. #5

    Default Re: Compiz Desktop Effects in 11.1 with ATI

    That's too bad. Are you booting into KDE? or running kdm? I forgot to mention that I am running gdm with Gnome. I did find that compiz still didn't work in KDE4.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •