Results 1 to 2 of 2

Thread: X.org takes most my CPU and Load Avg when I move a window

  1. #1
    FatalisVester NNTP User

    Default X.org takes most my CPU and Load Avg when I move a window

    Hi guys and thanks for taking time to read this.

    I'm a newb at linux and at openSUSE AND this is my first forum post. I switched over to linux a few months ago and loved it. I am running openSUSE 10.3 with gnome. Love the cool apache stuff. Love the compiz rendering.

    But I have noticed that when there is a bug... it's serious business.

    I have, however, taken many days to fix each bug and I believe last night I had finished it all... only to be disappointed... allow me to explain.

    For quite a while, the Online Updater was not working correctly. Then last night I stumbled onto the "online update configuration" tool at the admin settings and let it run for... oh... 4 hours or so.

    After that, wouldn't you know, the updater worked. I began updating all my things... which took... well another 6 hours.

    Once it was done all my problems seemed to be fixed... except now my CPU is erratic!

    ... sorry for the long winded intro but here's the ACTUAL PROBLEM:

    After updating was over I rebooted my computer and every time I moved a window the CPU would jump like crazy. I looked into it and found it was X.org that was making these radical jumps.

    Moreover I looked it up on google and found threads that were remote, but none of them seemed to be due to a package update. Needless to say none of the attempts worked.

    The interesting thing in this case is that it takes up all my cpu with or without 3d rendering. Desktop Effects on or off. In root and when I turn on the "basic" gnome settings.


    Any clue as to what I could do from here???

    Do you need my x.conf file?

  2. #2
    FatalisVester NNTP User

    Default Re: X.org takes most my CPU and Load Avg when I move a windo

    Update: I also found that my sound was not working. I re-installed the sound card drivers with "alsaconf" and got it back working again. I deleted my xorg.conf file and restarted the X server. The X server made a new xorg.conf file but still no luck...

    Does anyone have any ideas for me???

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •