Results 1 to 3 of 3

Thread: Update conflict in 11.1 between zypper and kdeupdate

  1. #1
    Join Date
    Jun 2008
    Location
    Cleveland, TN USA
    Posts
    412

    Default Update conflict in 11.1 between zypper and kdeupdate

    I seem to have a conflict between zypper and kdeupdate, using the default packagekit backend, according to the kdeupdate there are no updates available for my desktop, but zypper lu shows this:

    vendion@SE-02:~> sudo zypper lu
    Loading repository data...
    Reading installed packages...
    S | Repository | Name | Version | Arch
    --+--------------------+---------------------+--------------+-------
    v | kde4 desktop | kde4-ark | 4.1.3-34.1 | x86_64
    v | kde4 desktop | kde4-kcalc | 4.1.3-34.1 | x86_64
    v | kde4 desktop | kde4-kgpg | 4.1.3-34.1 | x86_64
    v | kde4 desktop | kde4-kwalletmanager | 4.1.3-34.1 | x86_64
    v | kde4 desktop | kde4-plasma-addons | 4.1.3-42.10 | x86_64
    v | Packman Repository | libmpg123-0 | 1.6.3-0.pm.1 | x86_64
    v | Packman Repository | mpg123 | 1.6.3-0.pm.1 | x86_64
    v | kde4 desktop | plasma-theme-aya | 4.1.3-42.10 | x86_64
    v | kde4 community | plasmoid-playwolf | 0.3.1-1.1 | x86_64

    Is anyone else seeing this with the packagekit backend as well?
    "We must plan for freedom, and not only for security, if for no other reason than only freedom can make security more secure." Karl Popper

  2. #2

    Default Re: Update conflict in 11.1 between zypper and kdeupdate

    Note that in 11.0 "zypper lu" mean "zypper lu -t patch" while in 11.1 it means "zypper lu -t package".
    By default the "kdeupdate" does the equivalent to "zypper lu -t patch", so you should compare with that.

    ...but yes, I enabled the "kdeupdate" option to also check packages (not just patches) and it seems to ignore it. I just removed the applet and never double checked the problem, but it could be a bug... if so, report it at http://bugzilla.novell.com/.

  3. #3
    Join Date
    Jun 2008
    Location
    Cleveland, TN USA
    Posts
    412

    Default Re: Update conflict in 11.1 between zypper and kdeupdate

    They really should put stuff like this in the Release notes, anyways is it possible to change zypper so that it defaults to packages rather than packages having to add "-t patch" every time will get annoying.
    "We must plan for freedom, and not only for security, if for no other reason than only freedom can make security more secure." Karl Popper

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •