Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: OpenSUSE 11.1 Compiz and QT4

  1. #1
    csgib NNTP User

    Default OpenSUSE 11.1 Compiz and QT4


    It seem that there is a problem with compiz on OS 11.1.
    When you launch a qt4 app it crash compiz (with or without emerald) on
    GNOME.

    If someone can help ... I try original pckage and update ones form XGL
    repo ...

    Stphane


    --
    csgib
    ------------------------------------------------------------------------
    csgib's Profile: http://forums.opensuse.org/member.php?userid=6949
    View this thread: http://forums.opensuse.org/showthread.php?t=402456


  2. #2
    olivn NNTP User

    Default Re: OpenSUSE 11.1 Compiz and QT4


    Same problem here
    Each time a kde application is stopped (okular), compiz crashes.

    If I disable the "fade" effect in ccsm, compiz process does not crash
    but all windows disappear. I'm left with a rotating cube !


    --
    olivn
    ------------------------------------------------------------------------
    olivn's Profile: http://forums.opensuse.org/member.php?userid=17756
    View this thread: http://forums.opensuse.org/showthread.php?t=402456


  3. #3
    Ricochet NNTP User

    Default Re: OpenSUSE 11.1 Compiz and QT4


    Same here, I think.

    I didn't see the qt4 link but I did see that it happens with certain
    apps (qt4?) in combination with effects like ctrl+alt or a window that
    becomes the focussed window.

    The whole screen freezes. Seen it on ATI and on NVidia.


    --
    Ricochet
    ------------------------------------------------------------------------
    Ricochet's Profile: http://forums.opensuse.org/member.php?userid=2399
    View this thread: http://forums.opensuse.org/showthread.php?t=402456


  4. #4
    hillwood NNTP User

    Default Re: OpenSUSE 11.1 Compiz and QT4


    olivn;1913724 Wrote:
    > Same problem here
    > Each time a kde application is stopped (okular), compiz crashes.
    >
    > If I disable the "fade" effect in ccsm, compiz process does not crash
    > but all windows disappear. I'm left with a rotating cube !

    Only QT4 application,I can not use vlc and skype.


    --
    hillwood
    ------------------------------------------------------------------------
    hillwood's Profile: http://forums.opensuse.org/member.php?userid=17986
    View this thread: http://forums.opensuse.org/showthread.php?t=402456


  5. #5
    olivn NNTP User

    Default Re: OpenSUSE 11.1 Compiz and QT4


    Yes QT4 apps (googlearth), I can run some QT3 apps (kooka).

    I have found a workaround: install Cybergorg compiz !

    'CyberOrg Compiz on openSUSE 11.1' (http://tinyurl.com/62qztu)

    I have blindly followed the steps and I can run any applications
    under compiz.


    --
    olivn
    ------------------------------------------------------------------------
    olivn's Profile: http://forums.opensuse.org/member.php?userid=17756
    View this thread: http://forums.opensuse.org/showthread.php?t=402456


  6. #6
    wondercow NNTP User

    Default Re: OpenSUSE 11.1 Compiz and QT4


    Thank you, olivn, your solution solved my problems with Ktorrent and
    Amarok 2.0 killing Compiz when I closed them. I would like to add that
    in addition to the instructions you linked, I also had to go into
    software manager in Yast and make sure I was using the X11GL versions
    of all Compiz-related packages because Compiz window decoration would
    either refuse to load, or certain plugins wouldn't load until I had all
    matching packages. Do not mix X11GL and normal OSS Compiz packages.

    This problem definitely seems specific to QT4 programs, since I can run
    Amarok 1.4 just fine without this problem, but Amarok 2.0 killed my
    Compiz.


    --
    wondercow
    ------------------------------------------------------------------------
    wondercow's Profile: http://forums.opensuse.org/member.php?userid=17996
    View this thread: http://forums.opensuse.org/showthread.php?t=402456


  7. #7
    LinuxArabic NNTP User

    Default Re: OpenSUSE 11.1 Compiz and QT4


    I have try same problem and I will try this resolve..


    --
    LinuxArabic
    ------------------------------------------------------------------------
    LinuxArabic's Profile: http://forums.opensuse.org/member.php?userid=1966
    View this thread: http://forums.opensuse.org/showthread.php?t=402456


  8. #8
    csgib NNTP User

    Default Re: OpenSUSE 11.1 Compiz and QT4


    Can someone tell us if the problem exist in 64 bits or just in 32 bits
    edition ?


    --
    csgib
    ------------------------------------------------------------------------
    csgib's Profile: http://forums.opensuse.org/member.php?userid=6949
    View this thread: http://forums.opensuse.org/showthread.php?t=402456


  9. #9
    dhwalker NNTP User

    Default Re: OpenSUSE 11.1 Compiz and QT4


    It happens to me in 64-bit.


    --
    dhwalker
    ------------------------------------------------------------------------
    dhwalker's Profile: http://forums.opensuse.org/member.php?userid=18867
    View this thread: http://forums.opensuse.org/showthread.php?t=402456


  10. #10
    olivn NNTP User

    Default Re: OpenSUSE 11.1 Compiz and QT4


    On 64bit system, I didn't try on 32bit


    --
    olivn
    ------------------------------------------------------------------------
    olivn's Profile: http://forums.opensuse.org/member.php?userid=17756
    View this thread: http://forums.opensuse.org/showthread.php?t=402456


Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •