Results 1 to 8 of 8

Thread: Logout Issue - openSuse 11.1

  1. #1
    Join Date
    Dec 2008
    Location
    Philadelphia, PA, USA
    Posts
    108

    Exclamation Logout Issue - openSuse 11.1

    Hi,

    I just installed openSuse 11.1 on my IBM T61 laptop and everything is working fine except the Logout feature doesn't work.

    When I click on "Logout" it displays only blank screen and then I'm left with no other choice then reboot the system.

    I'm sure its not frozen because when I do <Ctrl><Alt><Del> twice it starts the shutdown process.

    Please let me know the solution for this issue.


    Regards,
    Anant

  2. #2
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Logout Issue - openSuse 11.1

    anantg wrote:

    >
    > Hi,
    >
    > I just installed openSuse 11.1 on my IBM T61 laptop and everything is
    > working fine except the Logout feature doesn't work.
    >
    > When I click on "Logout" it displays only blank screen and then I'm
    > left with no other choice then reboot the system.
    >
    > I'm sure its not frozen because when I do <Ctrl><Alt><Del> twice it
    > starts the shutdown process.


    When it appears frozen can you access a vt ( Ctrl+Alt+F1 ) if so login as root enter pass and see if:

    shutdown -h now

    has any affect.

    HTH

    --
    Mark....

    Nil illegitimi carborundum

  3. #3
    Join Date
    Dec 2008
    Location
    Philadelphia, PA, USA
    Posts
    108

    Default Re: Logout Issue - openSuse 11.1

    Well my issue is not shutdown.

    My issue is the logout, I want to logout and login as different user

  4. #4
    sebt NNTP User

    Default Re: Logout Issue - openSuse 11.1

    I see the exact same problem as the thread starter.

    When logging out the X server attempts to restart but instead I see a blank screen with a stuck cursor at the top left. Although the system is responsive, nothing is displayed on the screen, so everything happens "blind". Eg. switching to vt1 and logging in, I can issue a find command and see the hard drive going nuts, but I see nothing on the screen: it stays blank with the stuck cursor.

    The only key that restores screen behaviour is CTRL+ALT+DEL, causing a graceful shutdown/restart.. in this case the openSUSE shutdown splash appears. Hitting ESC during shutdown though displays a vt1 with the opensuse logo at the top left and pixel garbage where the shutdown audit should appear.

    I only see this issue when using the proprietary nvidia driver. When I use the X.Org "nv" driver, there is no weirdness when logging out. Thing is, I can't get higher than 16-bit colour from the nv driver on the T61's Quadro NVS 140 graphics (any ideas?)

    I can see the same issue if I switch from my live KDE session to vt1 (ctrl+alt+f1), then login as root, run init 3 (shutting down X) and then init 5 to start X again. So the issue is not with logging out, but instead the restart of X with the nvidia driver, after it's successfully run once. I'm fairly sure it's an nvidia driver issue; I've tried all drivers from 177.82 up to 180.18. I'd love to try 173.xx that I used with openSuse 11.0, but unfortunately this won't compile in 11.1 with the 2.6.27 kernel.

    I would also be interested to see if openSuse 11.0 has this issue with the newer nvidia drivers (177.82+).

    Glad I'm not alone. This issue has been driving me nuts. I've posted some details about this on my blog and invite further comments there until this issue is resolved. I've also filed a bug reports with novell and nvidia about this, see my blog for the links.

    sebt

  5. #5

    Default Re: Logout Issue - openSuse 11.1

    I had the same issue but only after adding Gnome to my desktop where I have logout to change between it and KDE.
    I think I just fixed it, I have a 6800GS Nvidia card and I went into the configuration and set the "Nvidia emulate" option to 1. Now it logs out and does not hang.
    Look in your driver configuration and try to enable emulation on the video card itself.

  6. #6

    Default Re: Logout Issue - openSuse 11.1

    That didn't do it for long. It is back. Now I know I have it. I Disabled 2d acceleration and now it logs out to a new login screen every time. You need to do this for every desktop you run. You can use Yast2 to configure the display/graphics card and uncheck the 3d acceleration box.

  7. #7

    Default Re: Logout Issue - openSuse 11.1

    Of course I meant 3d in both instances.

  8. #8

    Default Re: Logout Issue - openSuse 11.1

    Make sure auto login is turned off.

    GOTO Yast > Security and Users > User and Group Management > In the User and Group Admin window at lower right select expert options > login settings.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •