Results 1 to 5 of 5

Thread: 11.1 unable to access repositories

  1. #1
    gmcbroom NNTP User

    Unhappy 11.1 unable to access repositories

    Have just installed 11.1 with no apparent issues until I went to open Yast. When I do anything that accesses the repositories I get

    Cannot access installation media
    (Medium 1).
    Check whether the server is accessible.

    The only repository I can access is the installation DVD

    I can browse to the URLs and internet access is working otherwise. The firewall is turned off and I've tried zypper up as root but it fails as well.

    zypper lr gives:

    # | Alias | Name | Enabled | Refresh
    --+-----------------+----------------------+---------+--------
    1 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No
    2 | repo-debug | repo-debug | No | Yes
    3 | repo-non-oss | repo-non-oss | Yes | Yes
    4 | repo-oss | repo-oss | Yes | Yes
    5 | repo-source | repo-source | No | Yes
    6 | repo-update | openSUSE-11.1-Update | Yes | Yes

    any suggestions very welcome

  2. #2
    gmcbroom NNTP User

    Default Re: 11.1 unable to access repositories

    Fuller error message

    Download (curl) error for 'http://download.opensuse.org/update/11.1/repodata/repomd.xml':
    Error code:
    Error message: couldn't connect to host

  3. #3
    gmcbroom NNTP User

    Default Re: 11.1 unable to access repositories

    Ok problem solved.

    Two issues.

    Firstly proxy settings removed via yast were still being used by curl & wget. Commenting out the appropriate lines in /etc/sysconfig/proxy and a reboot cured this.

    The DHCP server was not passing dns settings. Used a fixed ip address and manually entered dns settings resolved this.

  4. #4
    Join Date
    Dec 2008
    Location
    Cambridge, UK
    Posts
    74

    Default Re: 11.1 unable to access repositories

    Hi,

    I'm having the same problem. I can't access the repos servers either. However I can browse the internet (I have to use an auto-proxy config script in my web browser).

    Could you please explain to me in detail how you resolved this?

    I'm a complete newbie and I don't even know what my IP addreses are.

  5. #5
    Robert Carlson NNTP User

    Default Re: 11.1 unable to access repositories

    lostidentity wrote:
    > Hi,
    >
    > I'm having the same problem. I can't access the repos servers either.
    > However I can browse the internet (I have to use an auto-proxy config
    > script in my web browser).
    >
    > Could you please explain to me in detail how you resolved this?
    >
    > I'm a complete newbie and I don't even know what my IP addreses are.
    >

    For some people, this problem appears to be resolved by turning off ipv6:

    http://en.opensuse.org/SDBisabling_IPv6_completely

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •