Please check this log and give me hints to install the upgrade. There are many dependencies in question!

8 Problems:
Problem: compizconfig-settings-manager-0.7.8-2.20.i586 requires python < 2.6, but this requirement cannot be provided
Problem: vlc-noX-0.9.8a-1.7.i686 requires libvlc2 = 0.9.8a-1.7, but this requirement cannot be provided
Problem: simple-ccsm-0.7.8-41.7.i586 requires python < 2.6, but this requirement cannot be provided
Problem: nvidia-gfxG01-kmp-pae-173.14.12_2.6.25.18_0.2-0.3.i586 requires kernel(pae:vmlinux) = 19ac3fde1eb13345, but this requirement cannot be provided
Problem: boost-1.34.1-42.4.i586 requires libicuuc.so.38, but this requirement cannot be provided
Problem: python-compizconfig-0.7.8-2.22.i586 requires python < 2.6, but this requirement cannot be provided
Problem: libgpod3-0.6.0-100.pm.9.i586 requires python < 2.6, but this requirement cannot be provided
Problem: libgpod3-0.6.0-100.pm.9.i586 requires python < 2.6, but this requirement cannot be provided

Problem: compizconfig-settings-manager-0.7.8-2.20.i586 requires python < 2.6, but this requirement cannot be provided
deleted providers: python-2.5.2-26.2.i586[@System]
uninstallable providers: python-2.5.2-26.1.i586[openSUSE-DVD 11.0]
python-2.5.2-26.1.i586[Main Repository (OSS)]
Solution 1: Following actions will be done:
do not install python-2.6.0-2.16.i586
do not install python-gtk-2.12.1-63.3.i586
do not install python-numeric-24.2-195.8.i586
do not install python-cairo-devel-1.6.4-1.35.i586
do not install python-gobject2-devel-2.15.4-2.28.i586
Solution 2: do not install compizconfig-settings-manager-0.7.8-2.20.i586
Solution 3: Ignore some dependencies of compizconfig-settings-manager

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/C]: