Page 4 of 4 FirstFirst ... 234
Results 31 to 37 of 37

Thread: Truecrypt 6.1a on openSUSE 11.1

  1. #31

    Default Re: Truecrypt 6.1a on openSUSE 11.1

    Seems to be working after the latest upgrades:

    uname -a
    Linux warp 2.6.27.19-3.2-default #1 SMP 2009-02-25 15:40:44 +0100 x86_64 x86_64 x86_64 GNU/Linux

    ntfs-3g
    http://download.opensuse.org/reposit...2.1.x86_64.rpm

    mount -l
    /dev/mapper/truecrypt1 on /media/truecrypt1 type fuseblk (rw,allow_other,default_permissions,blksize=4096)

  2. #32
    maniel NNTP User

    Smile Re: Truecrypt 6.1a on openSUSE 11.1

    you're right, it works!
    the package doesn't provide /sbin/mount.ntfs symlink though

  3. #33
    Join Date
    Jul 2008
    Location
    WORLD
    Posts
    35

    Question Re: Truecrypt 6.1a on openSUSE 11.1

    original post from "pressanykey":
    mount -l
    /dev/mapper/truecrypt1 on /media/truecrypt1 type fuseblk (rw,allow_other,default_permissions,blksize=4096)
    can someone explain this part a little bit more detailed, please?

    Thank you

    Greetings
    -------------------------------------------------

    openSUSE 11.3 x86_64 - Toshiba Tecra A9

  4. #34

    Default Re: Truecrypt 6.1a on openSUSE 11.1

    Using the command "mount -l", "type fuseblk" shows that ntfs-3g is being used to mount the media under truecrypt. If the builtin driver is handling the mount, it will be "type ntfs". ntfs-3g is a filesystem in user space (fuse). The builtin driver is mounted in kernel mode.

    As maniel pointed out, you have to have a symlink from /sbin/mount.ntfs -> /bin/ntfs-3g for truecrypt to use fuse.

  5. #35
    gr3g NNTP User

    Default Re: Truecrypt 6.1a on openSUSE 11.1

    I'm using openSUSE 11.1, fresh install and going to install truecrypt 6.1a right now. My containers are formated with ext3 FS and located inside the NTFS partition (mounted with ntfs-3g/rw).

    Now, when i mount my container, truecrypt hangs forever. Also, i cannot kill the mount process within the truecrypt and my laptop cannot be shutdown (freeze), i don't know why this is happen in 11.1, while in 11 it runs perfectly..

    Any idea?

    Thank you for support..

    PS: my containers run smoothly on Ubuntu 8.10 with Truecrypt 6.1a

  6. #36
    soeren_nb NNTP User

    Thumbs up Re: Truecrypt 6.1a on openSUSE 11.1

    Just a small reprise from me:
    I could mount my NTFS-formatted container with TrueCrypt after having installed a newer ntfs-3g driver from anubis' repository. But I had problems writing into that container (couldn't create or delete files/directories).
    This problem was solved for me by following the advice above to create a symlink to /bin/ntfs-3g from /sbin/mount.ntfs.

    Code:
    ln -s /bin/ntfs-3g /sbin/mount.ntfs
    Unfortunately this symlink is missing by default.

    ciao, Sren

  7. #37
    dsbahr NNTP User

    Default Re: Truecrypt 6.1a on openSUSE 11.1

    So, has this problem been solved now? Does truecrypt 6.1a work under OpenSuse 11.1 using KDE4?

    I can't really understand all these commands, my linux skills aren't quite sufficient for that yet.

    Based on feedback elsewhere, the problem also seems to be related to OpenSuse 11.1 using KDE4. There should be no problems while using Gnome? Can someone confirm if this is true?

    Thx, looking forward to use OpenSuse as my primary OS as soon as this is fixed

Page 4 of 4 FirstFirst ... 234

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •