Results 1 to 5 of 5

Thread: Recomended repositories

  1. #1

    Default Recomended repositories

    Hi guys!
    I'm new on OpenSUSE, I've came from Kubuntu.
    What repositories do you recomend for KDE4 desktop?

    Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Recomended repositories

    Quote Originally Posted by quisoc View Post
    Hi guys!
    I'm new on OpenSUSE, I've came from Kubuntu.
    What repositories do you recomend for KDE4 desktop?

    Thanks!
    Here is the list for KDE 4.1.3 repositories (Stable):
    KDE/Repositories - openSUSE. Version xx.x need to match with your openSuSE version.
    Do not forget to add the Qt repositories:
    11.0 - http://download.opensuse.org/reposit...openSUSE_11.0/,
    11.1 - http://download.opensuse.org/reposit...openSUSE_11.1/.
    How to add repositories in YaST: Add Package Repositories to YaST - openSUSE
    I recommend this.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  3. #3

    Default Re: Recomended repositories

    In addition to those listed here: Package Repositories - openSUSE
    One can/must add packman (and other if wanted): Additional YaST Package Repositories - openSUSE

    There are also lot of OBS repositeries made by users.

  4. #4

    Default Re: Recomended repositories

    Just in case you were looking more for advice on which repos to keep enabled for a SUPPORTED system rather than bleeding edge, I decided to add a post.

    When you check out that page regarding YaST repos, you'll see oss, non-oss, updates. Those 3 are how to keep fully supported by Online Update repos on your system.

    But of course if you want your multimedia to work, you'll need to activate, for ONLY ONE PACKAGE, then deactivate the vlc repo, installing libdvdcss then deleting the repo.

    Then you add the Packman repo, which you can always leave enabled as they build their packages to upgrade and co-exist with the standard oss and non-oss OpenSUSE repos.

    For ati or nvidia 3D drivers you can also add the one there that matches your card. Older ATI Radeons up through the x850 series do not need the additional driver install as the included ati radeon driver includes 3D support for those cards. For more info see the wiki.opensuse.org pages (search up top) for either ATI or NVidia and Compiz Fusion.

    Once KDE releases KDE4 4.2, you may want to add those KDE repos and upgrade, or not, it's up to you. But anything other than oss, non-oss, and updates is unofficial. Of course, nearly everyone goes ahead anyway especially for Packman and their videocard drivers!

    For the latest Wine, there's a Wine repo. The Mozilla repo is usually not necessary as Online Updates eventually upgrades Firefox and Thunderbird. But if you want the update quicker (sometimes takes quite a long time before it gets to Online Updates) it's available.

    VirtualBox also has a Build Service repo, but of course it's the oss version just like on the SUSE oss repo, just upgraded to the latest. Most install either from the virtualbox repo on the virtualbox.org download website or they download the full version .run file and install it themselves.

    There are lots of choices for you! Nowadays it's even easier to find software you want from a repo you don't currently have activated in YaST Software by searching at software.opensuse.org (click the big find software thing on the right and it'll bring you to the Build Service search page) or through webpin. They even have one-click installers that'll install the repos along with the software.

    In you open the repositories in YaST Software Management and choose the additional 3rd party one, you'll get a built in list of some of the most popular ones to choose from.
    Epox EP-8KRAIPRO AthlonXP3200+ GeForce 6600GT 2GB PC3200 DDR-SDRAM Audigy 2 ZS

  5. #5

    Default Re: Recomended repositories

    Thanks to all!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •