Results 1 to 10 of 10

Thread: Emerald on 11.1

  1. #1

    Default Emerald on 11.1

    I installed successfully compiz-gnome and all its dependencies, it works well except emerald, the window decorator. When i type
    emerald --replace
    the decorations disappear and nothing is written in the terminal, i have to go back to gtk.
    I'm running x86_64, all the compiz rpms come from the XGL repo.
    Any ideas?

  2. #2

    Default Re: Emerald on 11.1

    I'm wondering the same thing for KDE 4 and Compiz/Emerald...
    I'm confused...No, wait...Maybe I'm not...

  3. #3

    Default Re: Emerald on 11.1

    I had the same problem with emerald from suse repos. I tried emerald from compiz repos Additional YaST Package Repositories - openSUSE and those do work. However compiz is very buggy in my version. It often falls back to metacity...

  4. #4

    Default Re: Emerald on 11.1


    the same here with KDE 3.5. and Nividia 8800GTS. Compiz doesn't work at all.
    I also tried this one: openSUSE 11.1 Compiz & NOMAD (xrdp) | Ben Kevan's Blog, but it does nothing.

  5. #5

    Default Re: Emerald on 11.1

    Hi !

    The same here with KDE4 and 11.1

    emerald --replace doesn't work

    I have made some researches on the internet and I found that I had to go to kcontrol->advanced tab->session manager and choose between kwin and emerald but there isn't such a choice in that tab.


  6. #6

    Default Re: Emerald on 11.1

    I followed the link openSUSE 11.1 Compiz & NOMAD (xrdp) | Ben Kevan's Blog as you said and now compiz runs much better. No bugs until now. However I can't get emerald to work with this version of compiz. I also tried to install emerald from the compiz repo to use with compiz from the XGL repo but no success...

  7. #7

    Default Re: Emerald on 11.1

    Update got emerald back by using emerald packages from standard opensuse repositories. Now got a working compiz and emerald. Turned of the compiz repos and never going to update compiz because now it works and I want to keep it that way.

  8. #8

    Default Re: Emerald on 11.1

    Just to confirm, I had the issue of emerald not loading. However, after reverting emerald to the version in the original opensuse 11.1 repository, it worked. I had installed the version from the X11GL repository, where I got a working version of compiz.

    Thanks for the help, suskewiet!

  9. #9

    Default Re: Emerald on 11.1

    I ended up removing all traces of Compiz and Emerald, clearing out my Compiz settings, and reinstalling successfully via 1-click install; however, while Compiz works now, Emerald still does not.
    I'm confused...No, wait...Maybe I'm not...

  10. #10
    Join Date
    Sep 2008
    Naples, Italy

    Default Re: Emerald on 11.1

    On 11.0 I was able to enable Compiz+Emerald by going into Desktop Management\Default apps\Window Manager and selecting Compiz.

    Now I can't see window decorations. I can't start Emerald nor rotate the cube or whatever.

    I have an ASUS G71V with nVidia 9700M GT with proper drivers installed. glxgears works fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts