Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42

Thread: VNC Broken in 11.1 KDE and GNOME

  1. #1
    neiby NNTP User

    Default VNC Broken in 11.1 KDE and GNOME

    I installed the KDE version of 11.1 today and enabled remote administration. When I tried to connect to the machine, I got the login screen and entered my credentials, but the screen closed immediately after that.

    Just for grins, I installed the GNOME version. With that version, I don't even get the login screen. I can see that I'm connecting to the X server, but no login screen appears.

    Any thoughts?

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,490
    Blog Entries
    37

    Default Re: VNC Broken in 11.1 KDE and GNOME

    Quote Originally Posted by neiby View Post
    I installed the KDE version of 11.1 today and enabled remote administration. When I tried to connect to the machine, I got the login screen and entered my credentials, but the screen closed immediately after that.

    Just for grins, I installed the GNOME version. With that version, I don't even get the login screen. I can see that I'm connecting to the X server, but no login screen appears.
    I confess I had not tested this yet.

    So I installed x11vnc on my openSUSE-11.1 PC running kde-3.5.10 (tightvnc was already installed) and then from my openSUSE-10.3 PC, I started a vnc server session on my openSUSE-11.1 PC. No problem. I had previously opened the 11.1 PC firewall for ssh and vnc.

    Perhaps you have a configuration problem?

    Note, I am NO expert on this. It (vnc) pretty much has always "just worked" for me, so I have never learned the 'ins and outs' of it.

    What I do is open 2 konsoles on my 10.3 PC. In the first konsole I type:
    Code:
    ssh -t -L 5900:localhost:5900 oldcpu@lan-ip-address-of-11-1-pc 'x11vnc -localhost -nolookup -nopw -display :0'
    and enter my password when prompted.

    Then on my 2nd terminal on my 10.3 PC I type:
    Code:
    vncviewer -encodings "tight copyrect hextile" localhost:0
    and it simply works.

    Other than explain what I do to make it work, I can't offer any other advice/help.

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: VNC Broken in 11.1 KDE and GNOME

    Quote Originally Posted by neiby View Post
    I installed the KDE version of 11.1 today and enabled remote administration. When I tried to connect to the machine, I got the login screen and entered my credentials, but the screen closed immediately after that.

    Just for grins, I installed the GNOME version. With that version, I don't even get the login screen. I can see that I'm connecting to the X server, but no login screen appears.

    Any thoughts?
    When you enable Remote Administration in Yast what happens behind the scenes is that firewall ports 5901 and 5801 are opened and also xinetd is set to receive queries from a remote vncviewer and to enable the executable /usr/bin/Xvnc as appropriate. This is different from what oldcpu is talking about. He's talking about the sister application x11vnc which runs on port 5900 and serves the already active :0 Xwindow.

    Getting back to Xvnc --> it doesn't work in KDE4 in 11.1 but it does work in Gnome and KDE 3.5 in 11.1 I have reported the bug for KDE4. I am puzzled as to why it didn't work for you in Gnome. You got no response at all for the Gnome effort which suggests the firewall port was closed. Check that.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: VNC Broken in 11.1 KDE and GNOME

    Just a further note. I looked into the xinetd config to see if there were clues about Gnome. It says in the comment there that this function enables a KDM logon. So maybe the Remote Admin facility is not available in Gnome at all. Xvnc is of course available, but the "Remote Admin" setup might not be. I'll look into it.

    So @neiby: have you experiences with Remote Admin serving a Gnome desktop previously?
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  5. #5
    neiby NNTP User

    Default Re: VNC Broken in 11.1 KDE and GNOME

    I haven't used GNOME much at all. I just wanted to take a look at it and thought that was a good time to do it.

    When I tried 11.0 earlier this week, all I had to do was go into Remote Administration and enable VNC. I also checked the box to automatically open up the firewall port.

    I did exactly the same thing in 11.1 (KDE). I used Real VNC from my other desktop PC to access it. I got the login screen, but the entire screen would close after I entered my password and hit Enter.

    When I tried this in GNOME, I got to the X server window, but the login screen did not display. I'll check the firewall settings. It should have opened a port, but perhaps it didn't.

  6. #6
    neiby NNTP User

    Default Re: VNC Broken in 11.1 KDE and GNOME

    I just verified that the firewall port is open, but I still don't see the login screen using 11.1 GNOME. I at least got the login page with KDE.

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: VNC Broken in 11.1 KDE and GNOME

    Quote Originally Posted by neiby View Post
    I just verified that the firewall port is open, but I still don't see the login screen using 11.1 GNOME. I at least got the login page with KDE.
    For me in Gnome there is no Remote Administration option in Yast's Network Services when using Gnome. That could be because the Remote Admin is really just a link that turns on VNC for KDM via Xinetd in Yast's Network Services. Now if you haven't got KDE installed then this cannot work (because the KDM login is the setup in xinetd).

    So, probably, that variation on VNC won't work in Gnome. I know that TightVNC will work in Gnome in openSUSE 11.1 and oldcpu has given another option with the x11vnc, so you can have VNC in gnome.

    You cannot have Remote Admin when using KDE4 in openSUSE 11.1 because there's a bug. But oldcpu has shown you an alternative until the bug is addressed. I reported it to Bugzilla only 10 days ago.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  8. #8

    Default Re: VNC Broken in 11.1 KDE and GNOME

    Yes in 10.3 I use to go in Yast/hardware/video and enable vnc...now it is no longer there.
    Krfb dont'work well for me...
    Hope a solution will come out soon

  9. #9
    neiby NNTP User

    Default Re: VNC Broken in 11.1 KDE and GNOME

    I wonder why you don't have Remote Administration in 11.1 with GNOME? I just did a fresh installation of it from the LiveCD and it's there. It doesn't seem to work the same way it did in 11.0, but it's there.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,490
    Blog Entries
    37

    Default Re: VNC Broken in 11.1 KDE and GNOME

    Earlier this evening I tested vnc (with the x11vnc/tightvnc commands I noted above) from KDE-4.1.3 (on openSUSE-11.1) taking over an openSUSE-10.3 desktop and it "just works"

    Two minutes ago, I tested this the other way, by using vnc (via x11vnc/tightvnc) from my openSUSE 10.3, taking over a openSUSE-11.1 KDE-3.5.10. That "just works".

    However I was not able to go from openSUSE-10.3 taking over an openSUSE-11.1 KDE-4.1.3 session (with x11vnc/tightvnc). That does NOT work.

    So using the command method I noted, there is a problem using openSUSE-11.1 KDE-4.1.3 as a server for vnc. The firewall has the correct ports open.

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •