Results 1 to 8 of 8

Thread: Difficulties installing Virtual Box on OpenSuSE10.3

  1. #1

    Unhappy Difficulties installing Virtual Box on OpenSuSE10.3

    I've been trying to install the version 2.0.2 of Virtual Box, provided on the cover disc of the recent "Linux Format coding special" using the rpm package provided for SuSE. The install failed with the following message:

    *********************************************************************************************
    Subprocess failed. Error: RPM failed: error: unpacking of archive failed: cpio: Bad magic

    ---

    2008-12-17 21:16:58 lzma-devel-4.32.5-0.pm.1.i586.rpm installed ok
    Additional rpm output:
    warning: /var/adm/mount/AP_0x00000012/i586/lzma-devel-4.32.5-0.pm.1.i586.rpm: Header V3 DSA signature: NOKEY, key ID 9a795806

    2008-12-17 23:07:57 xen-devel-3.1.0_15042-51.3.i586.rpm installed ok
    2008-12-18 09:20:06 VirtualBox-2.0.2_36488_openSUSE11-1.i586.rpm install failed
    rpm output:
    error: unpacking of archive failed: cpio: Bad magic
    ***********************************************************************************************

    The method I used was to browse the contents of the coverdisk (Using Konqueror) then right click and install using YasT.


    I noticed in the string of numbers a portion referencing OpenSUSE11. Then realising I am running OpenSUSE10.3 and not wishing to be defeated at the first hurdle I next tried a generic rpm within a shell script provided separately on the DVD. Sadly no success with that either! The following is the error message I received from that attempt.


    **************************************************************************
    # sh VirtualBox-2.0.2-36488-Linux_x86.run
    Verifying archive integrity... All good.
    Uncompressing VirtualBox for Linux installation........
    VirtualBox Version 2.0.2 (2008-09-12T13:39:17Z) installer
    Please install the build and header files for your current Linux kernel.
    The current kernel version is 2.6.22.19-0.1-default
    Problems were found which would prevent VirtualBox from installing.
    Please correct these problems and try again.

    **************************************************************************

    I poked about in the sources on my installation and as far as I can see I had an earlier version (1.5) of Virtual Box already installed on my machine. That version runs but has no USB support and so I tried uninstalling it but to no avail - still the same problems. The build and headers for my kernel seem to be present on my hard drive where they were originally put by the SuSE installer, although I'm not familiar with kernel naming and location conventions. Can anyone please give any solid guidance out of this maze??

    Sigh - almost defeated oldie!
    Last edited by dave_cass; 18-Dec-2008 at 12:02. Reason: version inclusion

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Difficulties installing Virtual Box on OpenSuSE10.3

    Have you installed

    kernel-source

    ??
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    google01103 NNTP User

    Default Re: Difficulties installing Virtual Box on OpenSuSE10.3

    dave cass wrote:

    >
    > I've been trying to install the version provided on the cover disc of
    > the recent "Linux Format coding special" using the rpm package provided
    > for SuSE. The install failed with the following message:
    >
    > *********************************************************************************************
    > Subprocess failed. Error: RPM failed: error: unpacking of archive
    > failed: cpio: Bad magic
    >
    > ---
    >
    > 2008-12-17 21:16:58 lzma-devel-4.32.5-0.pm.1.i586.rpm installed ok
    > Additional rpm output:
    > warning:
    > /var/adm/mount/AP_0x00000012/i586/lzma-devel-4.32.5-0.pm.1.i586.rpm:
    > Header V3 DSA signature: NOKEY, key ID 9a795806
    >
    > 2008-12-17 23:07:57 xen-devel-3.1.0_15042-51.3.i586.rpm installed ok
    > 2008-12-18 09:20:06 VirtualBox-2.0.2_36488_openSUSE11-1.i586.rpm
    > install failed
    > rpm output:
    > error: unpacking of archive failed: cpio: Bad magic
    > ***********************************************************************************************
    >
    > The method I used was to browse the contents of the coverdisk (Using
    > Konqueror) then right click and install using YasT.
    >
    >
    > I noticed in the string of numbers a portion referencing OpenSUSE11.
    > Then realising I am running OpenSUSE10.3 and not wishing to be defeated
    > at the first hurdle I next tried a generic rpm within a shell script
    > provided separately on the DVD. Sadly no success with that either! The
    > following is the error message I received from that attempt.
    >
    >
    > **************************************************************************
    > # sh VirtualBox-2.0.2-36488-Linux_x86.run
    > Verifying archive integrity... All good.
    > Uncompressing VirtualBox for Linux installation........
    > VirtualBox Version 2.0.2 (2008-09-12T13:39:17Z) installer
    > Please install the build and header files for your current Linux
    > kernel.
    > The current kernel version is 2.6.22.19-0.1-default
    > Problems were found which would prevent VirtualBox from installing.
    > Please correct these problems and try again.
    >
    > **************************************************************************
    >
    > I poked about in the sources on my installation and as far as I can see
    > I had an earlier version (1.5) of Virtual Box already installed on my
    > machine. That version runs but has no USB support and so I tried
    > uninstalling it but to no avail - still the same problems. The build and
    > headers for my kernel seem to be present on my hard drive where they
    > were originally put by the SuSE installer, although I'm not familiar
    > with kernel naming and location conventions. Can anyone please give any
    > solid guidance out of this maze??
    >
    > Sigh - almost defeated oldie!
    >
    >

    did you try dl'ing form virtualbox.org?
    http://www.virtualbox.org/wiki/Linux_Downloads

    kindly note current version is 2.1.0

    --
    Suse 11.0 x64, Kde 4.2beta (unstable repo), Opera 9.x weekly

  4. #4

    Default Re: Difficulties installing Virtual Box on OpenSuSE10.3

    I found:

    franklin:/usr/src # ls -l
    total 1
    lrwxrwxrwx 1 root root 19 Dec 18 21:38 linux -> linux-2.6.22.19-0.1
    drwxr-xr-x 20 root root 800 Dec 18 21:37 linux-2.6.22.19-0.1
    drwxr-xr-x 3 root root 96 Dec 18 21:36 linux-2.6.22.19-0.1-obj
    lrwxrwxrwx 1 root root 23 Dec 18 21:38 linux-obj -> linux-2.6.22.19-0.1-obj
    drwxr-xr-x 7 root root 168 Sep 21 2007 packages
    franklin:/usr/src #

    However I just checked in YasT and it looks like kernel source is not selected. I've just set it to install. so I'll try again after it completes.

    Thanks for the pointer .... I'm holding my breath in hope!

  5. #5

    Default Re: Difficulties installing Virtual Box on OpenSuSE10.3

    I haven't tried version 2.1 as yet. I see on the VirtualBox site that has been released as of yesterday but I did try version 2.0.6 and that produced the same header and build errors that I had from 2.0.2.

    DC

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Difficulties installing Virtual Box on OpenSuSE10.3

    The first error is because the RPM format for 11.0 in which VirtualBox on the DVD was distributed is not readable in 10.3 without upgrading 10.3's rpm program.

    The second error is because you need the kernel-source package to build the vboxdrv module. I hope you also have gcc and make installed, they will also be needed.

  7. #7

    Default Re: Difficulties installing Virtual Box on OpenSuSE10.3

    Many thanks for both replies. The install has now gone ahead so I'll tryt o get the virtual machine up and running now with Ubuntu 8.10...da daaaa

    DC

  8. #8

    Default Re: Difficulties installing Virtual Box on OpenSuSE10.3

    Looking much better now - make is there, as is gcc I've managed to get as far as defining a virtual machine with a .vdi file for ubuntu 8.10 setting all in but then I get the following:


    Failed to initialize Host Interface Networking.
    VBox status code: -3100 (VERR_HOSTIF_INIT_FAILED).


    Result Code:
    NS_ERROR_FAILURE (0x80004005)
    Component:
    Console
    Interface:
    IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}

    Looks lke a networking issue maybe?? I need to sort out in my head how the abstraction layer of a virtual machine deals with using the network interface physically located in the hardware of a real machine with an operating system up and running..... all a bit new for me ... but fascinating. Once again many thanks for the help thus far received.


    DC (Grateful if Puzzled Penguin)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •