Results 1 to 7 of 7

Thread: sub-pixel rendering for one user but not another?

Hybrid View

  1. #1

    Red face sub-pixel rendering for one user but not another?

    Hello all,

    I'm trying to migrate my wife over to linux and have set up an account for her on my openSUSE 11.0 install. Everything is going smoothly with the exception that I can't get the sub-pixel rendering enabled on HER account. It is enabled on mine, and the fonts look great. Without sub-pixel rendering, the fonts look terrible on our LCD monitor.

    I have searched the forum and reviewed several threads on font settings and enabling sub-pixel rendering, but unless I'm missing something (quite possible) I don't think they apply, here. I can't figure out why this option is grayed-out for her. The only difference in permissions between the two accounts is that mine includes the DISK group, but I'm not clear why that would be necessary for the font settings. Any help would be greatly appreciated! I want as smooth a transition for her as possible, and appearance is very important.

    Thanks,

    Swamp Yankee

    PS This is my 1st foray into multiple user accounts on the same install, so I am not 100% on which settings are system-wide and which are account-specific. I apologize if there is an obvious answer that I missed in my searches.

  2. #2
    Join Date
    Jul 2008
    Location
    Ljubljana
    Posts
    522

    Default Re: sub-pixel rendering for one user but not another?

    This may be a far shot, but the only thing that comes to mind is file permissions. Have you perchance compiled the cleartype library for your account only or placed it somewhere in your /home? Or maybe, it's located where it should be, but its file permissions are wrong? That would explain the behaviour you're describing.
    http://stopsoftwarepatents.eu/
    Even if free software were ****, it should still get our preference over the non-free **** secreted by IT corporations.
    A free rephrasing of RMS

  3. #3

    Default Re: sub-pixel rendering for one user but not another?

    Josip,

    Thanks for the suggestion. I don't recall compiling anything to get the sub-pixel rendering enabled for my account, but its been a while since I set everything up. Is there a simple way to determine the location of the cleartype library to help me resolve this?

    Swamp Yankee

  4. #4

    Default sub-pixel rendering enabled but does not appear to function

    I installed the patched freetype2 rpm from here:
    SubpixelHinting - openSUSE-Community

    This enabled the "sub-pixel rendering" options under: desktop settings > appearance > fonts - these options had been grayed-out in my wife's account previously.

    However, changes to these settings do not appear to have any effect on the font rendering. If I toggle between the two accounts, the difference is stark, even with identical font settings. This includes menu items, window titles, etc. not just firefox & openoffice, which I understand render fonts differently.

  5. #5
    Join Date
    Jul 2008
    Location
    Ljubljana
    Posts
    522

    Default Re: sub-pixel rendering for one user but not another?

    I'm afraid I can't help you there. I thought you couldn't enable font smoothing at all -- now I understand you can (it's not greyed-out), it just doesn't have any effect. Try double-checking if other font settings (which fonts, what sizes etc.) match in both accounts. There may be other settings interfering. Maybe if you create a temporary dummy account and try enabling font smoothing there, it can help you troubleshoot the thing. Depends also on what desktop environment you're using -- KDE (3.x or 4.x) or Gnome.
    http://stopsoftwarepatents.eu/
    Even if free software were ****, it should still get our preference over the non-free **** secreted by IT corporations.
    A free rephrasing of RMS

  6. #6
    Join Date
    Jun 2008
    Location
    Brisbane, Australia
    Posts
    207

    Default Re: sub-pixel rendering for one user but not another?

    Quote Originally Posted by swamp_yankee View Post
    Hello all,

    I'm trying to migrate my wife over to linux and have set up an account for her on my openSUSE 11.0 install. Everything is going smoothly with the exception that I can't get the sub-pixel rendering enabled on HER account. It is enabled on mine, and the fonts look great. Without sub-pixel rendering, the fonts look terrible on our LCD monitor.

    I have searched the forum and reviewed several threads on font settings and enabling sub-pixel rendering, but unless I'm missing something (quite possible) I don't think they apply, here. I can't figure out why this option is grayed-out for her. The only difference in permissions between the two accounts is that mine includes the DISK group, but I'm not clear why that would be necessary for the font settings. Any help would be greatly appreciated! I want as smooth a transition for her as possible, and appearance is very important.

    Thanks,

    Swamp Yankee

    PS This is my 1st foray into multiple user accounts on the same install, so I am not 100% on which settings are system-wide and which are account-specific. I apologize if there is an obvious answer that I missed in my searches.
    Try looking into "ls ~/.*font*" AFAIK those files have to do with font configuration in your user account. you can backup your wife's files, and then copy yours (.*font*) to her ~/wife directory.

    I'm not sure about all this, just giving a suggestions! YMMV. No warranty, blah blah =)
    NVIDIA! Listen to your customers! We want Free drivers.
    Petition #1. Petition #2. Use your VOICE! Sign the petitions!

  7. #7

    Default Sucess! Don't know why, but...

    Following the suggestions above, I replaced my wife's ~/.fontconfig contents with the files from my accounts ~/.fontconfig.

    Finally, everything looks good. Perhaps I missed some basic configuration settings between the two accounts, even though I went through them numerous times. I was running parallel sessions for the two accounts and was switching back and forth, and I thought I had everything matched. Oh well, It is working well now, and that was my main goal.

    Thanks again for your help!

    Appreciative,

    Swamp Yankee

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •