Results 1 to 9 of 9

Thread: Missing development packages

  1. #1
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Missing development packages

    openSUSE 11.0 (2.6.25.18-0.2-default)

    I am trying to build an rpm for the newest version of iscan to see if it solves a problem I am experiencing. Bug # 459215.

    Command I am using for build as per iscan readme file.
    rpmbuild -tb iscan_2.14.0-3.tar.gz

    I fail two dependencies:
    libtools-ltdl-devel and sane-backends-devel.

    they are not in the normal repositories, or on the retail DVD. I also searched on Webpin and it did not find them. can anyone tell me where I can get these rpms?

    Is this correct group to be asking?

    Thanks in advance
    --
    Russ
    Register Linux User# 441463

  2. #2

    Default Re: Missing development packages

    With libtool and sane-backends you probably have enough. The problem is that every distro uses different names for packages... use "--nodeps" and it should build anyway.

  3. #3
    RedDwarf NNTP User

    Default Re: Missing development packages


    With libtool and sane-backends you probably have enough. The problem is
    that every distro uses different names for packages... use "--nodeps"
    and it should build anyway.


    --
    RedDwarf
    ------------------------------------------------------------------------
    RedDwarf's Profile: http://forums.opensuse.org/member.php?userid=374
    View this thread: http://forums.opensuse.org/showthread.php?t=401836


  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,529
    Blog Entries
    15

    Default Re: Missing development packages

    Quote Originally Posted by russbucket
    openSUSE 11.0 (2.6.25.18-0.2-default)

    I am trying to build an rpm for the newest version of iscan to see if
    it solves a problem I am experiencing. Bug # 459215.

    Command I am using for build as per iscan readme file.
    rpmbuild -tb iscan_2.14.0-3.tar.gz

    I fail two dependencies:
    libtools-ltdl-devel and sane-backends-devel.

    they are not in the normal repositories, or on the retail DVD. I also
    searched on Webpin and it did not find them. can anyone tell me where I
    can get these rpms?

    Is this correct group to be asking?

    Thanks in advance
    Hi
    Had a look at the spec file for the 2.10 version and these were the
    build requirements;
    Code:
    BuildRequires:  db1-devel e2fsprogs-devel esound-devel gcc-c++
    gdk-pixbuf-devel gimp-devel gnome-common libgphoto2-devel libjpeg-devel
    libxml-devel openssl-devel popt-devel sane-backends update-desktop-files
    There are also patches to apply for gcc43 and others, grab a source rpm
    and use that to build a proper rpm....

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 x86 Kernel 2.6.27.7-4-default
    up 20:15, 3 users, load average: 0.42, 0.37, 0.40
    GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82


  5. #5
    Malcolm NNTP User

    Default Re: Missing development packages

    Quote Originally Posted by russbucket
    openSUSE 11.0 (2.6.25.18-0.2-default)

    I am trying to build an rpm for the newest version of iscan to see if
    it solves a problem I am experiencing. Bug # 459215.

    Command I am using for build as per iscan readme file.
    rpmbuild -tb iscan_2.14.0-3.tar.gz

    I fail two dependencies:
    libtools-ltdl-devel and sane-backends-devel.

    they are not in the normal repositories, or on the retail DVD. I also
    searched on Webpin and it did not find them. can anyone tell me where I
    can get these rpms?

    Is this correct group to be asking?

    Thanks in advance
    Hi
    Had a look at the spec file for the 2.10 version and these were the
    build requirements;
    Code:
    BuildRequires:  db1-devel e2fsprogs-devel esound-devel gcc-c++
    gdk-pixbuf-devel gimp-devel gnome-common libgphoto2-devel libjpeg-devel
    libxml-devel openssl-devel popt-devel sane-backends update-desktop-files
    There are also patches to apply for gcc43 and others, grab a source rpm
    and use that to build a proper rpm....

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 x86 Kernel 2.6.27.7-4-default
    up 20:15, 3 users, load average: 0.42, 0.37, 0.40
    GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82


  6. #6
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: Missing development packages - Partially Solved

    russbucket wrote:

    > openSUSE 11.0 (2.6.25.18-0.2-default)
    >
    > I am trying to build an rpm for the newest version of iscan to see if it
    > solves a problem I am experiencing. Bug # 459215.
    >
    > Command I am using for build as per iscan readme file.
    > rpmbuild -tb iscan_2.14.0-3.tar.gz
    >
    > I fail two dependencies:
    > libtools-ltdl-devel and sane-backends-devel.
    >
    > they are not in the normal repositories, or on the retail DVD. I also searched
    > on Webpin and it did not find them. can anyone tell me where I can get these
    > rpms?
    >
    > Is this correct group to be asking?
    >
    > Thanks in advance

    I down loaded the tar.gz file from the AVASYA website and tried to compile it. But it ran into two dependences, whose files are not available on the opensuse repositories or webpin for openSUSE 11.0. I also downloaded the rpm package
    2.14.0-3.c2.i386.rpm from your website. It installed with YaST and it runs. The
    default scan is a .png and scanning to file works with no problem. Scanning to
    printer now works but it will not print in color. My lpr command is:
    lpr -P Phaser_6120. If I put the -c in for color I get an error that cups no
    longer supports the -c option. This all used to work before my upgrade to KDE
    4.1.3, and a new 64 bit system. Is there a package like the propriatory driver
    or firmware I need to install. Under the 2.10 version there was.
    --
    Russ
    Register Linux User# 441463

  7. #7
    russbucket NNTP User

    Default Re: Missing development packages - Partially Solved

    russbucket wrote:

    > openSUSE 11.0 (2.6.25.18-0.2-default)
    >
    > I am trying to build an rpm for the newest version of iscan to see if it
    > solves a problem I am experiencing. Bug # 459215.
    >
    > Command I am using for build as per iscan readme file.
    > rpmbuild -tb iscan_2.14.0-3.tar.gz
    >
    > I fail two dependencies:
    > libtools-ltdl-devel and sane-backends-devel.
    >
    > they are not in the normal repositories, or on the retail DVD. I also searched
    > on Webpin and it did not find them. can anyone tell me where I can get these
    > rpms?
    >
    > Is this correct group to be asking?
    >
    > Thanks in advance

    I down loaded the tar.gz file from the AVASYA website and tried to compile it. But it ran into two dependences, whose files are not available on the opensuse repositories or webpin for openSUSE 11.0. I also downloaded the rpm package
    2.14.0-3.c2.i386.rpm from your website. It installed with YaST and it runs. The
    default scan is a .png and scanning to file works with no problem. Scanning to
    printer now works but it will not print in color. My lpr command is:
    lpr -P Phaser_6120. If I put the -c in for color I get an error that cups no
    longer supports the -c option. This all used to work before my upgrade to KDE
    4.1.3, and a new 64 bit system. Is there a package like the propriatory driver
    or firmware I need to install. Under the 2.10 version there was.
    --
    Russ
    Register Linux User# 441463

  8. #8
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: Missing development packages Resolved

    russbucket wrote:

    > openSUSE 11.0 (2.6.25.18-0.2-default)
    >
    > I am trying to build an rpm for the newest version of iscan to see if it
    > solves a problem I am experiencing. Bug # 459215.
    >
    > Command I am using for build as per iscan readme file.
    > rpmbuild -tb iscan_2.14.0-3.tar.gz
    >
    > I fail two dependencies:
    > libtools-ltdl-devel and sane-backends-devel.
    >
    > they are not in the normal repositories, or on the retail DVD. I also searched
    > on Webpin and it did not find them. can anyone tell me where I can get these
    > rpms?
    >
    > Is this correct group to be asking?
    >
    > Thanks in advance

    Installing the latest Iscan version iscan-2.15.0-3.c2 fixed this problem.
    --
    Russ
    Register Linux User# 441463

  9. #9
    russbucket NNTP User

    Default Re: Missing development packages Resolved

    russbucket wrote:

    > openSUSE 11.0 (2.6.25.18-0.2-default)
    >
    > I am trying to build an rpm for the newest version of iscan to see if it
    > solves a problem I am experiencing. Bug # 459215.
    >
    > Command I am using for build as per iscan readme file.
    > rpmbuild -tb iscan_2.14.0-3.tar.gz
    >
    > I fail two dependencies:
    > libtools-ltdl-devel and sane-backends-devel.
    >
    > they are not in the normal repositories, or on the retail DVD. I also searched
    > on Webpin and it did not find them. can anyone tell me where I can get these
    > rpms?
    >
    > Is this correct group to be asking?
    >
    > Thanks in advance

    Installing the latest Iscan version iscan-2.15.0-3.c2 fixed this problem.
    --
    Russ
    Register Linux User# 441463

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •