Results 1 to 5 of 5

Thread: Emails in Thunderbird won't open in Firefox

  1. #1

    Default Emails in Thunderbird won't open in Firefox

    I know this has been discussed a few times on various Linux boards, but I've tried those fixes and they don't work.

    I'm trying to get my links within Thunderbird to open in Firefox. It worked at one time on this same install, and at some point it quit working. I'm not sure when or if anything changed (upgraded to Firefox 3 is all). I go so long without rebooting that I wondered if it was just a memory leak or glitch. But alas, no, a logoff or reboot doesn't help.

    Just to give you some background info, I have openSUSE 11. I've got Firefox 3.0.4 and Thunderbird 2.0.0.18. I'm using KDE 3.5.9 "release 49.1", right off the openSUSE.org site / DVD.

    I'm also NOT using the Firefox / Thunderbird that came with openSUSE, but instead using the pre-compiled ones that come right off mozilla.com's website. I have both apps in /opt (/opt/firefox and /opt/thunderbird).

    I've also got Firefox and Thunderbird registered as the default browser / email app in both GNOME and KDE3.

    Moreover, I have gone into the Thunderbird config editor and added the "network.protocol-handler.app.http" and "network.protocol-handler.app.https" elements. They point to the right Firefox binary, /opt/firefox/firefox.

    But those config editor entries have been in there for a long time (before I started having problems). I have a matching "mailto" entry in the Firefox config editor to get the "File -> Send Link" feature to send links via Thunderbird, which it does correctly.

    I'm not a regular KMail user (I prefer Thunderbird's consistency over multiple platforms), but I did try it temporarily to see what happened. Links from KMail properly opened in Firefox without a hitch, which tells me this is likely a Thunderbird problem.

    I've also tried several script variations that perform the launching of Firefox, and temporarily changed the "http" and "https" variables in Thunderbird to point to the script instead of directly to Firefox, and that didn't seem to help.

    I can also pass URLs to Firefox on a shell and it opens correctly.

    And lastly, I renamed my ~/.thunderbird and started up Thunderbird with a new profile. No go - links still won't open in Firefox (all of my mailboxes are exclusively IMAP).

    So do any of you have any ideas? I'd love to have this working again!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Emails in Thunderbird won't open in Firefox

    The setting is in the Control Center - Not sure where exactly as I'm in kde4 at the moment.

    Look for default applications I think.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Emails in Thunderbird won't open in Firefox

    As I said in my previous post, I've already done that... in both KDE3 and GNOME. I've tried all the documented fixes (that I'm aware of) and it doesn't work.

  4. #4
    dmoinescu NNTP User

    Default Re: Emails in Thunderbird won't open in Firefox

    I ran into a similar problem once I decided to try a Firefox version (Firefox 3) downloaded from mozilla.org instead of the one installed via OpenSUSE rpm (Firefox 2 in OpenSUSE 10.3).
    Once I ran the new version, links in Thunderbird stopped working.
    After much frustration with different solutions posted on the web that didn't work for me, I set network.protocol-handler.warn-external.http to true in Thunderbird's about:config, to see what it was trying to do. Next time I clicked on a link, Thunderbird popped up a window showing that it was about to run /usr/local/firefox3/firefox (presumably because I had answered 'yes' to FF3's question of whether it should make itself the default browser).
    I then ran the old firefox with the -setDefaultBrowser option, which duly got the links working again (displayed with /usr/bin/firefox)
    Next, I changed the /usr/bin/firefox symlink to point to /usr/local/firefox-3/firefox instead to the old binary. Thunderbird links stopped working again.

    In conclusion, if /usr/bin/firefox points to something other than the stock firefox version, Thunderbird won't run it. So it looks to me that Thunderbird somehow does more than simply run the http-handler application - it seems to run some sort of checks.

  5. #5
    Martin Jost NNTP User

    Default Re: Emails in Thunderbird won't open in Firefox

    dmoinescu schrieb:
    > I ran into a similar problem once I decided to try a Firefox version
    > (Firefox 3) downloaded from mozilla.org instead of the one installed via
    > OpenSUSE rpm (Firefox 2 in OpenSUSE 10.3).


    My usual check is to make sure you have "user.js" in
    ~/.thunderbird/$yourprofil/
    containing something like this:
    user_pref("network.protocol-handler.app.http","/opt/firefox/firefox");
    user_pref("network.protocol-handler.app.https","/opt/firefox/firefox");
    user_pref("network.protocol-handler.app.ftp", "/opt/firefox/firefox");
    (Change the FF path to your needs)

    HTH

    Martin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •