Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: Latest ATI Driver leads to a black screen

  1. #1

    Unhappy Latest ATI Driver leads to a black screen

    Hi folks,

    i am using OpenSuse 11.0 with the ATI-Drivers repository. 3d was working perfectly until i guess the drivers update on november 14.
    (i use to update all my packages via yast to the latest versions)
    Now my screen turns black as soon as x is starting. In the menu of my monitor i can see, that the graphics card is set to weird resolutions, that obviously cant be displayed. The failsafe option works.

    I am trying to search for errors in /var/log/Xorg.0.log. Unfortunately this file is overwritten as soon as i boot in the failsafe mode.

    Any ideas? Can i add an option to grub like "boot to console"? So i can search for the error logs before the next start of x?

    I also tried reinstalling the drivers, because i heard of corrupted ati driver files. I didnt help.

    Using an old backup of the xorg.conf file i can boot normally, but i dont have 3D-Accelaration.

    Thanks in advance!

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: Latest ATI Driver leads to a black screen

    jostschoenleben wrote:

    > Any ideas? Can i add an option to grub like "boot to console"? So i can
    > search for the error logs before the next start of x?


    When you boot with GRUB, use the e key to get to the kernel options line and
    enter a plain 3 there. That will bring the system up in console mode. If you
    don't find the error file you are looking for, issue a startx command and see
    the errors on the screen.

    Larry

  3. #3
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,114

    Default Re: Latest ATI Driver leads to a black screen

    I had a similar problem. In 10.3 I fixed it by typing:
    sudo aticonfig --initial
    and then restarting the sever and running sax2.
    Look at ATI - openSUSE

  4. #4

    Default Re: Latest ATI Driver leads to a black screen

    @whych: Thanks, i tried that several times before. It didn't work for me this time.

    @lwfinger: i added 3 to the bootoptions in grub and it worked, thanks. I didn't need to press "e" before.

    grep -e EE /var/log/Xorg.0.log only shows one error:

    (EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 7

    No idea what this means.

    I will try Catalyst 8.12 as soon as it is available via Yast.

  5. #5
    Join Date
    Jun 2008
    Location
    P.R.China
    Posts
    25

    Red face Re: Latest ATI Driver leads to a black screen

    As Usual, the ati*.run which can be updated from ati.com every month would installed very well, and if you choose the special installation for suse, it would come out an fglrx.rpm, and we gotta install the fglrx.rpm manually. and then, use the comand : sax2 -r -m 0=fglrx to set sax2's 3D Active item before we open 3D.

    but someth. seemed changed since the ati *.8.11.run.
    thr is no fglrx.rpm comes out, and use the sax2 -r -m 0=fglrx would make screen black. what is wrong ?

    I dunnt try 8.12 till now.
    上善若水,水善萬物而不爭,處眾人之所惡,故幾於道。

  6. #6
    Join Date
    Jun 2008
    Location
    United Kingdom
    Posts
    58

    Default Re: Latest ATI Driver leads to a black screen

    To install 8.12 on OpenSUSE 11 I did:

    Code:
    zypper in gcc make kernel-source compat-libstdc++ patch
    wget https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/64bit/ati-driver-installer-8-12-x86.x86_64.run
    sh ati-driver-installer-8-2-x86.x86_64.run
    Ran Through All the Automatic Steps
    aticonfig --initial -f
    sax2 -r -m 0=fglrx
    Saved all Settings
    Logged Out
    Restarted X
    Logged back in
    fglrxinfo
    This worked for me, building the RPMs hasn't worked in the past 2 releases for me, but this method is great either way.

  7. #7

    Default Re: Latest ATI Driver leads to a black screen

    The below worked like a dream for me in OpenSUSE 11.1

    Thankyou!

    Quote Originally Posted by Vince4Amy View Post
    To install 8.12 on OpenSUSE 11 I did:

    Code:
    zypper in gcc make kernel-source compat-libstdc++ patch
    wget https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/64bit/ati-driver-installer-8-12-x86.x86_64.run
    sh ati-driver-installer-8-2-x86.x86_64.run
    Ran Through All the Automatic Steps
    aticonfig --initial -f
    sax2 -r -m 0=fglrx
    Saved all Settings
    Logged Out
    Restarted X
    Logged back in
    fglrxinfo
    This worked for me, building the RPMs hasn't worked in the past 2 releases for me, but this method is great either way.

  8. #8

    Default Re: Latest ATI Driver leads to a black screen

    Hello,

    Keep in mind that I am new to suse and linux. But I somehow managed to install the ati 8-12 driver (wouldn't work 3 times before). I used the above method this time minus the wget (on desktop). I have a 9800 Pro, running 32bit.

    I now get the black screen when suse starts. I see the green background with the mouse briefly. But my monitor says, "Out of Frequency," 15 seconds later, poof and its gone. Also, What I do see. It is a smaller box in the middle surrounded by black and the icons are fuzzy.

    I am able to boot in failsafe mode. But what am I to do with the blank screen?

    I also found that in yast (completely greek to me), I am missing some of the required packages as per http://http://en.opensuse.org/Howto/...r#The_Easy_Way

    Those are...
    # compat-libstdc++
    # libstdc++
    # libstdc++-devel
    # libgcc

    I don't know if that has any thing to do with my problem. But its odd that I was even able to install. I am looking for any help you may have.

    Thank you

  9. #9

    Default Re: Latest ATI Driver leads to a black screen

    ^^^EDIT^^^

    OMG, I don't know how I did this. But I have it working!!!

    In failsafe, I opened up the Graphics card and Monitor in Control Center. Changed the resolution to one that wasn't so big. Saved settings and rebooted. It started up and I now have ATI drivers intalled in Suse 11.1. I even have the ATI Catalyst program.

    I do remember that I didn't do the "Save Settings" and rebooted because when I did that step, the screen went blank.

    I hope this helps someone. If it blanks out, boot failsafe, save settings in graphics/monitor and reboot normally.

  10. #10

    Default Re: Latest ATI Driver leads to a black screen

    I hate to keep adding to this thread. But my ATI driver in suse 11.1 didn't last long.

    I had gnome installed perfectly with XP dual boot. I didn't like the gnome menu in suse. (Its not the same as the linuxMint mintmenu that I tested). So I decided to try the KDE desktop. Installed the KDE stuff in yast. I didn't have time to try it out because we left to go shopping. Computer went to screen saver and shut the screen off after 45 minutes (all set in suse).

    When I came back, I moved the mouse and the screen had all kinds of vertical lines, and artifacts (LCD). I have had the computer since 2003 so I thought the screen finally crapped out.

    Nothing worked, turning it off, reboot, and switching to the onboard graphics just showed a black screen. I thought I had screwed up everything by adding the KDE. So I started another format...

    Then I got to thinking, the graphics card STUPID. If I switched to the board card and just got a blank screen...it was because the other one was still installed.

    Tore apart the computer and found the fan from the Radeon 9800 Pro had broke off and was laying on the bottom of my case. So this would explain the lines due to it being too hot. I am surprised it didn't start a fire. I just wish I could have been here to hear what it sounded like when it broke off.

    This wasn't due to installing suse, gnome or KDE. It was a card I bought used a few years ago. And the fan on it had been making noises for the past few months and it just now gave out.

    Any recommendations on a card?

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •