Results 1 to 10 of 10

Thread: Quitting KDE4 applications on GNOME desktop kills Compiz

  1. #1
    wondercow NNTP User

    Default Quitting KDE4 applications on GNOME desktop kills Compiz


    Hello all,

    I did a fresh install of OpenSUSE 11.1 a few days ago and selected the
    GNOME desktop. However, I use a few KDE programs, specifically Amarok
    and Ktorrent because I prefer their interface/features over their GNOME
    equivalents. Whenever I quit the KDE4 version of Amarok or Ktorrent
    while using GNOME, Compiz will get turned off (not sure if it's crashing
    or just quitting). When I quit those programs, the screen will flicker
    and all my windows will redraw, and all my Compiz plugins will be turned
    off. If I then go to Desktop Effects in Control Center, the "use desktop
    effects" box will be unchecked and I have to activate it again.

    One note is that this only seems to happen when I quit the KDE4 version
    of Amarok (version 2.0). If I quit Amarok 1.4, my desktop effects keep
    running unphased. I haven't tried an older version of Ktorrent, but I
    am suspecting it would leave my desktop effects alone as well.

    Has anyone else seen this happen? Have you had any success fixing it?
    Any ideas how I would go about diagnosing this?


    --
    wondercow
    ------------------------------------------------------------------------
    wondercow's Profile: http://forums.opensuse.org/member.php?userid=17996
    View this thread: http://forums.opensuse.org/showthread.php?t=402758


  2. #2
    fecam NNTP User

    Default Re: Quitting KDE4 applications on GNOME desktop kills Compiz


    Hi, I have the same problem but, with VLC. When I close VLC Compiz
    Compiz will get turned off...


    --
    openSUSE 11.0 (i586) Gnome + Compiz Fusion (AMD 64 3200+ Nvidia 8800GT)
    ------------------------------------------------------------------------
    fecam's Profile: http://forums.opensuse.org/member.php?userid=8957
    View this thread: http://forums.opensuse.org/showthread.php?t=402758


  3. #3
    bela42 NNTP User

    Default Re: Quitting KDE4 applications on GNOME desktop kills Compiz


    Hi,

    so it is a general problem with Qt(4) Apps?

    The same applies to VirtualBox...




    --
    bela42
    ------------------------------------------------------------------------
    bela42's Profile: http://forums.opensuse.org/member.php?userid=5809
    View this thread: http://forums.opensuse.org/showthread.php?t=402758


  4. #4
    wondercow NNTP User

    Default Re: Quitting KDE4 applications on GNOME desktop kills Compiz


    Ok, I have solved this problem now. There is another thread reporting
    this same problem (here: 'OpenSUSE 11.1 Compiz and QT4 - openSUSE
    Forums' (http://tinyurl.com/94jhfw) ) and user olivn posted the
    solution:

    'CyberOrg Compiz on openSUSE 11.1' (http://tinyurl.com/62qztu)

    I had to do some extra steps to get everything working, though.

    CyberOrg Wrote:
    >
    >
    > Although openSUSE 11.1 is almost ready, Compiz that is in it is still
    > not there yet. If you run into some of the remaining annoyances, here is
    > how to get Compiz Fusion bliss on openSUSE 11.1.
    >
    > Add X11GL repository that contains compiz without NOMAD patches
    >
    > zypper ar 'Index of /repositories/X11:/XGL/openSUSE_11.1'
    > (http://download.opensuse.org/reposit...openSUSE_11.1/)
    > X11GL
    >
    > Update all compiz packages from that repo
    >
    > zypper up -t package -r X11GL
    >
    > After making sure compiz is switched off and disabled, remove old
    > configuration:
    >
    > rm -rf /home/your-username/.config/compiz


    The step it doesn't cover that I had to do was go into Yast Software
    Manager and make sure that ALL my compiz-related packages were from the
    X11GL source. By following those quoted directions alone, I had mixed
    XGL and OSS packages, and they didn't play nice together (plugins
    failing, window decoration not loading, etc.).

    Then you go back to the CyberOrg solution:

    CyberOrg Wrote:
    >
    >
    > Launch simple-ccsm and enable Compiz.
    >
    > Have a lot of fun
    >
    >


    Hope this helps you as much as it did me!


    --
    wondercow
    ------------------------------------------------------------------------
    wondercow's Profile: http://forums.opensuse.org/member.php?userid=17996
    View this thread: http://forums.opensuse.org/showthread.php?t=402758


  5. #5
    LuisC-SM NNTP User

    Default Re: Quitting KDE4 applications on GNOME desktop kills Compiz


    wondercow;1914467 Wrote:
    > Ok, I have solved this problem now. There is another thread reporting
    > this same problem (here: 'OpenSUSE 11.1 Compiz and QT4 - openSUSE
    > Forums' (http://tinyurl.com/94jhfw) ) and user olivn posted the
    > solution:
    >
    > 'CyberOrg Compiz on openSUSE 11.1' (http://tinyurl.com/62qztu)
    >
    > I had to do some extra steps to get everything working, though.
    >
    >
    >
    > The step it doesn't cover that I had to do was go into Yast Software
    > Manager and make sure that ALL my compiz-related packages were from the
    > X11GL source. By following those quoted directions alone, I had mixed
    > XGL and OSS packages, and they didn't play nice together (plugins
    > failing, window decoration not loading, etc.).
    >
    > Then you go back to the CyberOrg solution:
    >
    >
    >
    > Hope this helps you as much as it did me!


    Hi.

    I've followed the steps you kindly posted and also made the changes in
    Yast to use X11 repos instead of OSS but I still have the meralld
    problem... here is the simple-cssm output:

    > cacho@linux-vkrj:~> simple-ccsm
    > Checking for Xdmx: not present.
    > Checking for Xgl: not present.
    > Detected PCI ID for VGA: 02:00.0 0300: 10de:01d3 (rev a1) (prog-if 00
    > [VGA controller])
    > Checking for texture_from_pixmap: present.
    > Checking for non power of two support: present.
    > Checking for Composite extension: present.
    > Comparing resolution (1280x1024) to maximum 3D texture size (4096):
    > Passed.
    > Checking for nVidia: present.
    > Checking for FBConfig: present.
    > Checking for Xgl: not present.
    > Dry run finished: everything should work with regards to Compiz and
    > 3D.
    > No compiz manager config found!
    > Checking for Xdmx: not present.
    > Checking for Xgl: not present.
    > Detected PCI ID for VGA: 02:00.0 0300: 10de:01d3 (rev a1) (prog-if 00
    > [VGA controller])
    > Checking for texture_from_pixmap: present.
    > Checking for non power of two support: present.
    > Checking for Composite extension: present.
    > Comparing resolution (1280x1024) to maximum 3D texture size (4096):
    > Passed.
    > Checking for nVidia: present.
    > Checking for FBConfig: present.
    > Checking for Xgl: not present.
    > * Detected Session: kde
    > * Searching for installed applications...
    > * NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
    > * Using the GTK Interface
    > * Decorator "compiz-decorator --replace" is invalid.
    > * Setting decorator to Emerald ("emerald --replace")
    > /usr/bin/compiz (core) - Error: Plugin 'core' has ABI version
    > '20081121', expected ABI version '20080828'.
    >
    > /usr/bin/compiz (ccp) - Error: InitObject failed
    > /usr/bin/compiz (core) - Error: Couldn't activate plugin 'ccp'
    >


    If I use emerald I get no window borders.
    Is there any solution??

    Thanks in advance

    Luis


    --
    La Humildad no es "Status"..
    ... es un "Don"!

    My Desktop HW Specs: http://tinyurl.com/9vttxu
    ------------------------------------------------------------------------
    LuisC-SM's Profile: http://forums.opensuse.org/member.php?userid=652
    View this thread: http://forums.opensuse.org/showthread.php?t=402758


  6. #6
    LuisC-SM NNTP User

    Default Re: Quitting KDE4 applications on GNOME desktop kills Compiz


    I can answer myself... After 4 hours of search in suse mailing lists..
    and the bug archives, I found the same answer all the time.

    There is NO solution... emerald is borked

    So I'll go back to OS 11.0

    Luis.


    --
    La Humildad no es "Status"..
    ... es un "Don"!

    My Desktop HW Specs: http://tinyurl.com/9vttxu
    ------------------------------------------------------------------------
    LuisC-SM's Profile: http://forums.opensuse.org/member.php?userid=652
    View this thread: http://forums.opensuse.org/showthread.php?t=402758


  7. #7
    wondercow NNTP User

    Default Re: Quitting KDE4 applications on GNOME desktop kills Compiz


    Bummer that you couldn't get it to work. If I understand correctly, you
    don't need Emerald to use Compiz and still get window borders, though.
    I just checked, and I don't even have Emerald installed on my machine.
    So, if you just want the neato Compiz effects, you could probably remove
    Emerald packages and be ok, but if you have your heart set on using
    Emerald, then I've got no solution for you. Sorry.


    --
    wondercow
    ------------------------------------------------------------------------
    wondercow's Profile: http://forums.opensuse.org/member.php?userid=17996
    View this thread: http://forums.opensuse.org/showthread.php?t=402758


  8. #8
    LuisC-SM NNTP User

    Default Re: Quitting KDE4 applications on GNOME desktop kills Compiz


    wondercow;1916209 Wrote:
    > Bummer that you couldn't get it to work. If I understand correctly, you
    > don't need Emerald to use Compiz and still get window borders, though.
    > I just checked, and I don't even have Emerald installed on my machine.
    > So, if you just want the neato Compiz effects, you could probably remove
    > Emerald packages and be ok, but if you have your heart set on using
    > Emerald, then I've got no solution for you. Sorry.


    Thanks for your comments.

    However I seemed to have "partially" fixed the emerald issue, Take a
    look to this blog from cyberorg

    'CyberOrg Compiz Fusion Git snapshot for openSUSE 11.1'
    (http://tinyurl.com/9awnz4)

    It seems that git repos fix in some way this problem... My bad was that
    I installed it without removing the old compiz packages.. I'm still
    having issues but it seems to be just a matter of time.. (which I don't
    have now), so maybe tomorrow or in some days I'll bring back some news.
    I really hope so.

    Kind REgards

    Luis


    --
    La Humildad no es "Status"..
    ... es un "Don"!

    My Desktop HW Specs: http://tinyurl.com/9vttxu
    ------------------------------------------------------------------------
    LuisC-SM's Profile: http://forums.opensuse.org/member.php?userid=652
    View this thread: http://forums.opensuse.org/showthread.php?t=402758


  9. #9
    LuisC-SM NNTP User

    Default Re: Quitting KDE4 applications on GNOME desktop kills Compiz


    Hi again.

    So far, emerald is now working perfectly....

    I just updated one or 2 packages to cyberorg s git repos..and installed
    compiz-kde4 (it did not get installed with one-click-install. I also
    installed fusion-icon-kde.

    That was all... they work greaat... BTW... QT4 apps dont break compiz
    anymore

    I've not shutdown my desktop but if something happens I'll update this
    post...

    Good luck and enjoy "emerald"

    Luis


    --
    La Humildad no es "Status"..
    ... es un "Don"!

    My Desktop HW Specs: http://tinyurl.com/9vttxu
    ------------------------------------------------------------------------
    LuisC-SM's Profile: http://forums.opensuse.org/member.php?userid=652
    View this thread: http://forums.opensuse.org/showthread.php?t=402758


  10. #10
    LuisC-SM NNTP User

    Default Re: Quitting KDE4 applications on GNOME desktop kills Compiz


    UPDATE:

    @Admin.. -I hate to repost-.. is there somehting I can do to overpass
    the 10 minutes edit time limit? TIA

    Everything is ok after the reboot....
    sound Works, QT4 apps work ;=)... VirtualBox works... ... but... I must
    "<Alt + F2> fusion-icon" to have emerald... Maybe there is a way with
    the "echo" comand to change this like in GNOME... This is my first
    attempt with KDE4 and I'm planning to stick to it, it's really
    impressive. (and I was a Kde hater), but I must find the way... Fonts
    were so ugly in kde but after some minor teawks they are almost as
    perfect as in gnome..........

    Good luck and happy emerald themming (Also happy new year).

    Luis


    --
    La Humildad no es "Status"..
    ... es un "Don"!

    My Desktop HW Specs: http://tinyurl.com/9vttxu
    ------------------------------------------------------------------------
    LuisC-SM's Profile: http://forums.opensuse.org/member.php?userid=652
    View this thread: http://forums.opensuse.org/showthread.php?t=402758


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •