Results 1 to 3 of 3

Thread: Set up routing

  1. #1
    Kevin Miller NNTP User

    Default Set up routing

    I'm running 10.3, and am trying to use my main box to route for a new
    box I'm setting up. My main box connects to the internet on wan0 and to
    the new box on eth0. I can ping each host from the other. I'd like
    myhost to route for newbox since it doesn't have a wireless nic.

    Basic ascii diagram below:

    newbox 192.168.2.2/24, gw: 192.168.2.1
    |
    |
    |eth0: 192.168.2.1
    myhost
    |wan0: 192.168.1.2<----->WAP:192.168.1.1<---->DSL<---->Internet


    What do I have to do on myhost to enable it to act as a router for newbox?

    Thanks...

    ....Kevin
    --
    Kevin Miller
    http://www.alaska.net/~atftb
    Juneau, Alaska
    Registered Linux User No: 307357, http://counter.li.org

  2. #2
    Kevin Miller NNTP User

    Default Re: Set up routing

    Kevin Miller wrote:
    > I'm running 10.3, and am trying to use my main box to route for a new
    > box I'm setting up. My main box connects to the internet on wan0 and to
    > the new box on eth0. I can ping each host from the other. I'd like
    > myhost to route for newbox since it doesn't have a wireless nic.
    >
    > Basic ascii diagram below:
    >
    > newbox 192.168.2.2/24, gw: 192.168.2.1
    > |
    > |
    > |eth0: 192.168.2.1
    > myhost
    > |wan0: 192.168.1.2<----->WAP:192.168.1.1<---->DSL<---->Internet
    >
    >
    > What do I have to do on myhost to enable it to act as a router for newbox?


    Just a quick followup - I figured it out. I needed to set a static
    route on the WAP so it knew how to get back to the 192.168.100.x subnet.
    (I'd already set the forwarding flag in YaST, Networking)
    Doh. Working like a charm now.

    ....Kevin
    --
    Kevin Miller
    http://www.alaska.net/~atftb
    Juneau, Alaska
    Registered Linux User No: 307357, http://counter.li.org

  3. #3
    Kevin Miller NNTP User

    Default Re: Set up routing

    Kevin Miller wrote:
    > I'm running 10.3, and am trying to use my main box to route for a new
    > box I'm setting up. My main box connects to the internet on wan0 and to
    > the new box on eth0. I can ping each host from the other. I'd like
    > myhost to route for newbox since it doesn't have a wireless nic.
    >
    > Basic ascii diagram below:
    >
    > newbox 192.168.2.2/24, gw: 192.168.2.1
    > |
    > |
    > |eth0: 192.168.2.1
    > myhost
    > |wan0: 192.168.1.2<----->WAP:192.168.1.1<---->DSL<---->Internet
    >
    >
    > What do I have to do on myhost to enable it to act as a router for newbox?


    Just a quick followup - I figured it out. I needed to set a static
    route on the WAP so it knew how to get back to the 192.168.100.x subnet.
    (I'd already set the forwarding flag in YaST, Networking)
    Doh. Working like a charm now.

    ....Kevin
    --
    Kevin Miller
    http://www.alaska.net/~atftb
    Juneau, Alaska
    Registered Linux User No: 307357, http://counter.li.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •