Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: OpenOffice Error Saving to Samba Share

  1. #11
    Join Date
    Jun 2008
    Location
    Natchez, MS, USA
    Posts
    518

    Default Re: OpenOffice Error Saving to Samba Share

    By the way. I am no expert at CIFs shares. Every time I have to set one up, I go to Swerdna's site and study it. He has gathered all you need to know and put it in one place for easy reference. It should be in your bookmarks.

  2. #12

    Default Re: OpenOffice Error Saving to Samba Share

    In Konqueror, when I open the Samba share I just click Workgroup then Centraldata. Then I am presented with a bunch of directories. They are all shared. One problem is, all the directories have spaces in the names; that's why I had the \ in there. For instance, one of the directories I use a lot is called "Vortex Folders".

    I have tried the IP address, but I keep getting "Permission Denied".

    Why does Konqueror have no trouble at all with it, but cifs can't do it?

    I will try it again when I get back to work, but I'm really confused atm. I pretty much wasted a work day trying to get this done.

    I appreciate the help very much, I'm just getting frustrated.


  3. #13
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: OpenOffice Error Saving to Samba Share

    Aha -- a light comes on!

    To escape a space in the name in fstab replace two words with two\040words

    Sort of like this
    //centraldata/storage\040volume /mnt/vortex cifs user=name_of_owner_on_windows,password=windows_password,_netdev,nobrl,uid=mooretid,gid=users 0 0
    Last edited by swerdna; 13-Dec-2008 at 12:34.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  4. #14

    Default Re: OpenOffice Error Saving to Samba Share

    Wow, who makes up this stuff? Do they think we have a crystal ball? I would kill for some standards!

    Thanks swerdna, I'll try that tomorrow. Then I'll go back to your site and fine-tune for OO documents.

  5. #15

    Default Re: OpenOffice Error Saving to Samba Share

    Okay, changed fstab entry to:

    //Centraldata/Storage\040Volume /mnt/vortex cifs user=ted,password=computer,_netdev,nobrl,uid=mooreted,gid=users 0 0

    Now I'm back to:

    mount error 113 = No route to host
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

    Might be easier just to save documents to my hard drive, edit them and copy them back to the server.

    Thanks for the help. Have a good weekend.

  6. #16

    Default Re: OpenOffice Error Saving to Samba Share

    I tried replacing "Centraldata" with the IP address and still get the same error. I checked the router, didn't see any problems; no blocked ports internally. Something about our network just wont let cifs work.

    Oh well, thanks for the help everyone. I have to actually get some work done now.

  7. #17
    Join Date
    Jun 2008
    Location
    Natchez, MS, USA
    Posts
    518

    Default Re: OpenOffice Error Saving to Samba Share

    Did you create the folder /mnt/vortex ? Also, I see this ,uid=moore ted, and I don't think it will work with that space in the name. Try using the number of the uid instead.

  8. #18

    Default Re: OpenOffice Error Saving to Samba Share

    Yes, I created the /mnt/vortex directory first.

    Okay, sucess (sort of). I went to the server and found the right IP address. traceroute hopped right out of our network and found some unknown host lost in the cloud somewhere.

    With the right IP address, I can mount it with:

    su
    <password>
    mount -a

    However, it's not mounting automagically at bootup. I have a Remote Shares icon on the desktop, but when I click it I get "Permission Denied". I have to mount it as root first.

    I am investigating the problem. At least I'm down to just a permission problem.

  9. #19
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: OpenOffice Error Saving to Samba Share

    Go to the ref by Wilson_Phillips and check the FAQs there, particularly "SuSEfirewall2 bug", "Slow Networks" and "Using OpenOffice.Org and Word Files".
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  10. #20

    Default Re: OpenOffice Error Saving to Samba Share

    Thanks for all the help guys.

    No idea why "centraldata" points to the wrong IP address; curious, but I don't really care anymore. At least CIFS mounting is working.

    I guess I'll have to use the crontab tip to get it to mount at boot time.

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •