Results 1 to 2 of 2

Thread: Fail on updating or removing Openoffice 2.4

  1. #1

    Default Fail on updating or removing Openoffice 2.4

    Hello... I'm at my wits end here. I'm one step away from "rm -Rf" and deleting Openoffice 2.4 wherever I can find it on sda1.

    I have a relatively fresh install of openSuse 11.0 x86_64 with Gnome. I ran into trouble with a system update to Openoffice 2.4. I was going to install 3.0 sooner or later, but decided to update 2.4 anyway. The update failed with various errors similar to below...

    Prpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30977) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery

    I have tried updating and then eventually removing all Openoffice packages I could find. Some packages uninstalled with Yast, but the base Openoffice_org pkg remains. I get the panic error in any package manager I try. I've tried yast, smart, zypper... both from gnome and from a terminal session... no luck.

    Any ideas? Thanks in advance for any suggestions.

  2. #2
    Join Date
    Jun 2008
    The English Lake District. UK - GMT/BST
    Blog Entries

    Default Re: Fail on updating or removing Openoffice 2.4

    You don't need to remove 2 to install 3

    Do this in a terminal as su:

    zypper refresh

    rpmdb --rebuilddb
    Now open Yast software management and install OOffice
    Now add this repo:
    Index of /repositories/

    In Yast software management
    filter by repo
    update all in the newly added repo for OOffice

    You now have OO 3
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts