Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Refresh failed: . Error: verification of 'repomd.xml' in my openSUSE 11.0 system

  1. #1
    Join Date
    Aug 2008
    Location
    SouthWest part Netherlands
    Posts
    81

    Default Refresh failed: . Error: verification of 'repomd.xml' in my openSUSE 11.0 system

    Hello

    I got the below copied error while the openSUSE Updater wanted to make 2
    security updates today.

    Refresh failed: . Error: verification of 'repomd.xml' with
    key '[33DE8FB7C8DA93D2-457aded7] [Dominique Leuenberger (VLC openSUSE
    Repository) ] [BC8D780DE3308581B2E0708533DE8FB7C8DA93D2]' failed Error:
    Could not refresh repository 'VideoLan Repository': Valid metadata not
    found at specified URL(s) History: - Signature verification failed for
    repomd.xml

    What should be the correct URL. My system has taken the URL from the YAST/
    Software/Add-On-Product/Community Repository and now it looks like it is
    not valid anylonger.

    Any suggestion?
    --
    Regards / Groeten,
    Frans

  2. #2
    kailee NNTP User

    Question Re: Refresh failed: . Error: verification of 'repomd.xml' i

    I'm having the same problem. Does anyone know how to fix this???

  3. #3
    Join Date
    Aug 2008
    Location
    /Linux/Userland
    Posts
    279

    Default Re: Refresh failed: . Error: verification of 'repomd.xml' i

    Post output of

    Code:
    zypper lr -u
    Linux User 483705 @ http://counter.li.org/

  4. #4
    Join Date
    Jun 2008
    Location
    34 04 17.35S 18 50 02.23E
    Posts
    266

    Default Re: Refresh failed: . Error: verification of 'repomd.xml' i

    I had similar problem, and downgraded zypper from 0.11.10-03 to 0.11.6-4.1, and now it works.
    Seems like the problem is new zypper or related software (possibly curl).

    Since doing the update, zypper has again been upgraded to 0.11.10-03 . I did notice that curl was updated.
    Will see how it goes.
    openSUSE Leap + KDE

  5. #5

    Default Re: Refresh failed: . Error: verification of 'repomd.xml' i

    Same here on my Suse 10.0 after upgrade of curl en libcurl.
    I downgraded curl but seems that zypper too needs to be downgraded for it to work again, as pointed out by my fellow poster.

  6. #6

    Default Re: Refresh failed: . Error: verification of 'repomd.xml' i

    I also had a similar problem. I just removed the extra forward slash "/" at the end and it got working... May be you can give it a try

  7. #7
    Join Date
    Feb 2009
    Location
    East Stroudsburg
    Posts
    153

    Default Re: Refresh failed: . Error: verification of 'repomd.xml' i

    Input

    Code:
    zypper lr -u
    Output

    Code:
    #  | Alias                        | Name                         | Enabled | Refresh | URI                                                                    
    ---+------------------------------+------------------------------+---------+---------+------------------------------------------------------------------------
    1  | /home/A13k/Desktop/Wine.repo | /home/A13k/Desktop/Wine.repo | Yes     | Yes     | dir:///home/A13k/Desktop                                               
    2  | ATI Repository               | ATI Repository               | Yes     | Yes     | http://www2.ati.com/suse/11.1                                          
    3  | ATI_Video_Drivers            | ATI Video Drivers            | Yes     | Yes     | http://www2.ati.com/suse/11.1/                                         
    4  | Java_Repositories            | Java Repositories            | Yes     | Yes     | http://download.opensuse.org/repositories/Java:/packages/openSUSE_11.1/
    5  | Packman                      | Packman                      | Yes     | Yes     | http://packman.unixheads.com/suse/11.1/                                
    6  | Packman Repository           | Packman Repository           | Yes     | Yes     | http://packman.mirrors.skynet.be/pub/packman/suse/11.1                 
    7  | VLC_VideoLAN_Client          | VLC VideoLAN Client          | Yes     | Yes     | http://download.videolan.org/pub/vlc/SuSE/11.1                         
    8  | X11:XGL                      | X11:XGL                      | Yes     | No      | http://download.opensuse.org/repositories/X11:/XGL/openSUSE_11.1/      
    9  | openSUSE 11.1-0              | openSUSE 11.1-0              | Yes     | No      | cd:///?devices=/dev/sr0                                                
    10 | repo-debug                   | openSUSE-11.1-Debug          | No      | Yes     | http://download.opensuse.org/debug/distribution/11.1/repo/oss/         
    11 | repo-non-oss                 | openSUSE-11.1-Non-Oss        | Yes     | Yes     | http://download.opensuse.org/distribution/11.1/repo/non-oss/           
    12 | repo-oss                     | openSUSE-11.1-Oss            | Yes     | Yes     | http://download.opensuse.org/distribution/11.1/repo/oss/               
    13 | repo-source                  | openSUSE-11.1-Source         | No      | Yes     | http://download.opensuse.org/source/distribution/11.1/repo/oss/        
    14 | repo-update                  | openSUSE-11.1-Update         | Yes     | Yes     | http://download.opensuse.org/update/11.1/
    Here's your answer. I personally agree that zypper is causing it.
    | OpenSuSE 11.4 Gnome Shell 64-bit | 4.2 i7-930 | ATI Raden 5750

  8. #8
    Join Date
    Aug 2008
    Location
    /Linux/Userland
    Posts
    279

    Default Re: Refresh failed: . Error: verification of 'repomd.xml' i

    Try removing Nos. 2 (duplicate) and 7 (if you already have installed VLC Media Player, you won't need the VideoLan Repo till a new version of VLC is released).

    Then "refresh all enabled" (drop-down menu at bottom) and try again.

    Also, for Wine repo (No. 1), I get Wine Repo-openSUSE 11.1 (for openSUSE 11.1) as the repo. Not sure how you got it on desktop ?
    Linux User 483705 @ http://counter.li.org/

  9. #9

    Default Re: Refresh failed: . Error: verification of 'repomd.xml' i

    All,

    The problem lies not with zypper, it got upgraded and it still works, but must lie with the libcurl4 update which removes libcurl3, curl-ca-bundle (ca certificates) and even demands to remove my flash-plugin-10.0.0.569-release-i386 (which I don't want).

    I feel this is al little bit too much change to go unnoticed.

    For the meantime I blocked the libcurl4 install till I figure out what the status is or until I gather courage again to mess up my system by giving it another try.

    I noticed no change in functionality yet.

    Gtz,
    Guy.

  10. #10
    zepfan221 NNTP User

    Default Re: Refresh failed: . Error: verification of 'repomd.xml' i

    Quote Originally Posted by vendetta18 View Post
    I also had a similar problem. I just removed the extra forward slash "/" at the end and it got working... May be you can give it a try
    I had the same problem, and this was what fixed it. Thank You!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •