Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: YaST problem - 11.0 32bit (GOME 2.22)

  1. #1

    Default YaST problem - 11.0 32bit (GOME 2.22)

    Good evening

    After having updated my PC I do not get to open YaST2 anymore, so I tried to run yast2 from gnome-terminal, I can open YaST2 main menu getting the follow message:
    Code:
    dhcppc0:/home/carla # yast2
    /usr/share/themes/Synchronicity/gtk-2.0/gtkrc:46: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
    After if I try to open any YaST2 sub menu but I can't open them at all, and I get the following messages in the gnome-terminal:
    Code:
    /usr/share/themes/Synchronicity/gtk-2.0/gtkrc:46: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
    /usr/share/themes/Synchronicity/gtk-2.0/gtkrc:47: Clearlooks configuration option "listviewitemstyle" is not supported and will be ignored.
    /usr/share/themes/Synchronicity/gtk-2.0/gtkrc:48: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.
    Really I don't understand... It was working very well so far, someone has an idea how to solve the problem?

    Many thanks.
    Amos

  2. #2

    Default Re: YaST problem - 11.0 32bit (GOME 2.22)

    How about changing your theme see if it will start yast
    People who do not break things first will never learn to create anything

  3. #3

    Default Re: YaST problem - 11.0 32bit (GOME 2.22)

    Many thanks

    Do you mean Glossy, openSUSE 11 Gilouche, Clearlooks etc...
    In my italian version the application name is "Aspetto".
    If is that I tried but still same problem.

    What I can do? I can't work without yast..

  4. #4

    Default Re: YaST problem - 11.0 32bit (GOME 2.22)

    Ok you did try changing your theme already. Something went wrong with your last update. You are using gnome and maybe the yast installed in your machine is the yast gtk, not sure though i am not using gnome. Just for kicks there might be a yast qt installed also, are you using some kde apps by any chance?
    if yes try in terminal kdesu yast2. With gnome try gnomesu yast2 or gksu yast2
    If none works maybe you have to fix yast installation either by using the install dvd/cd or using smart. or using yast in text mode by running the command yast in a terminal (not yast2)
    People who do not break things first will never learn to create anything

  5. #5

    Default Re: YaST problem - 11.0 32bit (GOME 2.22)

    Thank you.

    I don't think to use any KDE apps..
    I tried
    Code:
    dhcppc0:/home/carla # gnomesu yast2
    Invalid MIT-MAGIC-COOKIE-1 key
    (y2controlcenter-gnome:15441): Gtk-WARNING **: cannot open display: :0.0
    I say give the comman yast in a terminal, I did and I get to open yast2, but what I have to do to fix the problem?

    Sorry but I am not so expert.

    Thank you again.

  6. #6

    Default Re: YaST problem - 11.0 32bit (GOME 2.22)

    Sorry I didn't made it clear. What I was trying to imply was to try those commands for yast2 and if it will fail to work the last resort is to try to run yast in text mode and repair your yast installation by maybe downgrading it either from the opensuse oss repositories or from your installation cd/dvd.
    People who do not break things first will never learn to create anything

  7. #7

    Default Re: YaST problem - 11.0 32bit (GOME 2.22)

    Thank you.

    Did you mean the command
    Code:
    # yast2
    In order to try to open yast interface?

    I tried, I can open it but I can't open any sub menu.

    I went to yast text mode, but, if I want to try to uninstall yast, which package I should choose?

    There are so many....
    yast2 is OK?

    after I could try to install it again..

    Is it correct the procedure?


    Thank you again.

  8. #8

    Default Re: YaST problem - 11.0 32bit (GOME 2.22)

    Quote Originally Posted by amosse View Post
    Thank you.

    Did you mean the command
    Code:
    # yast2
    In order to try to open yast interface?

    I tried, I can open it but I can't open any sub menu.

    I went to yast text mode, but, if I want to try to uninstall yast, which package I should choose?

    There are so many....
    yast2 is OK?

    after I could try to install it again..

    Is it correct the procedure?


    Thank you again.
    Let's do it slowly and go back from the start.
    It seems that this is a gnome related problem generated from your last update and it affected your yast gtk which I assume is the gnome default. As I said I am not using gnome but using xfce and using the yast qt.

    Lets try if you can run the yast qt from the terminal and hope it is installed in your system.

    Open a terminal type su, type your root password and type yast2 --qt
    People who do not break things first will never learn to create anything

  9. #9

    Unhappy Re: YaST problem - 11.0 32bit (GOME 2.22)

    Many thanks again.

    By the time, I don't know if it has been a good idea, I uninstalled yast2 using testual version (I mean typing yast from root) and all relative dependecies.

    Afer I tried to install it again with this command
    Code:
    # zypper in yast2
    Now I can open it (by terminal) but I have only the main mask without all relative menus, my 1st question is:
    How I can re-install yast2 and all relatives dependencies?

    With reference to your instruction I tried
    Code:
    # yast2 --qt
    I get to open testual interface, but is empty, maybe because I uninstalled yast2...

    Here I am, thank you again for your help.

  10. #10

    Default Re: YaST problem - 11.0 32bit (GOME 2.22)

    Why did you uninstall yast? you could have just update or downgrade it. I never use zypper
    So can't give you advise on ins and outs regarding it.

    Let's try and check your yast installation using your browser.
    Do you have konqueror installed in your system or firefox installed?

    Open a terminal and type su type your root password

    If you are using konqueror run this command in the terminal as root

    Code:
    siga kon
    If you are using firefox run this command in the terminal as root

    Code:
    siga fox
    As soon as you run those command just wait for a while and there will be information that will come out as soon as your browser open. In your browser (konqueror or firefox) look for the rpm and click it and look for the yast packages installed in your machine, copy and paste it and post it here so we can compare and see what are the missing yast packages.
    That's all I can advise you for now.

    Note:
    Siga only run with root permission
    In short you have to open the terminal-type su-type the root password-type siga kon or siga fox

    Hope this helps a bit in diagnosing your problem
    People who do not break things first will never learn to create anything

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •