Results 1 to 3 of 3

Thread: Unable to connect to CUPS server localhost

  1. #1

    Default Unable to connect to CUPS server localhost

    Dec 9 14:15:26 RBMNAS1421 smbd[5719]: [2008/12/09 14:15:26, 0] printing/print_cups.c:cups_cache_reload(85)
    Dec 9 14:15:26 RBMNAS1421 smbd[5719]: Unable to connect to CUPS server localhost - Connection refused


    this smb error is filling my messages log and is making finding a real problem very difficult as i get 4 entires every second

    my smb.conf is here

    # smb.conf is the main Samba configuration file. You find a full commented
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
    # samba-doc package is installed.
    # Date: 2007-05-16
    [global]
    load printers = no
    smb passwd file = /etc/samba/smbpasswd
    printing = none
    workgroup = redbeemedia.net
    security = user
    max disk size = 4192376
    disable spoolss = yes
    [cs_design]
    comment = IBM Storage share
    path = /IBMraid
    readonly = no
    public = yes
    create mask = 0770
    directory mask = 0770
    any ideas?

  2. #2
    PV NNTP User

    Default Re: Unable to connect to CUPS server localhost

    On Tue December 9 2008 08:26 am, mattfletcher wrote:

    >
    > Dec 9 14:15:26 RBMNAS1421 smbd[5719]: [2008/12/09 14:15:26, 0]
    > printing/print_cups.c:cups_cache_reload(85)
    > Dec 9 14:15:26 RBMNAS1421 smbd[5719]: Unable to connect to CUPS
    > server localhost - Connection refused
    >
    >
    > this smb error is filling my messages log and is making finding a
    > real problem very difficult as i get 4 entires every second
    >
    > my smb.conf is here
    >
    >>
    >> # smb.conf is the main Samba configuration file. You find a full
    >> commented
    >> # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if
    >> the
    >> # samba-doc package is installed.
    >> # Date: 2007-05-16
    >> [global]
    >> load printers = no
    >> smb passwd file = /etc/samba/smbpasswd
    >> printing = none
    >> workgroup = redbeemedia.net
    >> security = user
    >> max disk size = 4192376
    >> disable spoolss = yes
    >> [cs_design]
    >> comment = IBM Storage share
    >> path = /IBMraid
    >> readonly = no
    >> public = yes
    >> create mask = 0770
    >> directory mask = 0770


    >
    > any ideas?
    >
    >

    Mattfletcher;

    I will not guarantee this will work, but I will suggest the following, if it
    does not work it should do no harm. In the global section
    of /etc/samba/smb.conf try adding the parameter:

    Code:
    printcap name = /dev/null
    To the best of my knowledge "none" is not a valid value for "printing" but
    since "printing" has no default value I suspect the results is the same. You
    might want to check with the command:

    Code:
    testparm -v /etc/samba/smb.conf
    This should return all the values of your parameters, including default
    values. If the printcap deal above does not work by itself, try ALSO adding:

    Code:
    printing = BSD
    For more information on the use of samba parameters see: man smb.conf.
    --
    P. V.
    Is this on the test?

  3. #3

    Default Re: Unable to connect to CUPS server localhost

    Thanks PV , i'll try this out and see what happens

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •