Results 1 to 10 of 10

Thread: OpenOffice from Factory missing Math catalog

  1. #1

    Default OpenOffice from Factory missing Math catalog

    Just upgraded to OO.o 3.0.0.9-1.6 using the factory repository to clear up some other issues I was having. Everything seems to be working, except when I try to make a math formula, the catolog seems to have lost almost all of its math and greek symbols. Same problem if I try to enter them in the %pi format in the equation editor as well.

    I can't seem to figure out the issue or find a similar problem in the forums. Anyone else have this weirdness or can make a suggestion?

  2. #2
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: OpenOffice from Factory missing Math catalog

    Quote Originally Posted by novelgazer View Post
    Just upgraded to OO.o 3.0.0.9-1.6 using the factory repository to clear up some other issues I was having. Everything seems to be working, except when I try to make a math formula, the catolog seems to have lost almost all of its math and greek symbols. Same problem if I try to enter them in the %pi format in the equation editor as well.

    I can't seem to figure out the issue or find a similar problem in the forums. Anyone else have this weirdness or can make a suggestion?
    I can use the pi sign, example
    Code:
    %pi approx  22 over 7
    renders without any problem.
    I can't use the permutation sign.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  3. #3

    Default Re: OpenOffice from Factory missing Math catalog

    I get a blank for the %pi. I also noticed that I get odd symbols in place of normal characters like parentheses and the plus sign. I imagine I can go through the catalog and redefine every available symbol, but it seems like there should be a better solution.

  4. #4

    Default Re: OpenOffice from Factory missing Math catalog

    CORRECTION: The OpenOffice.org Math version is 3.0.0.9-2.3 (1.6 is Writer, I guess.)

  5. #5

    Default Re: OpenOffice from Factory missing Math catalog

    So I don't know if this information helps -- I can go into the catalog editor and fill in the Greek characters one by one. That's a pain in the neck, but if that's what has to happen, I'm cool with it.

    But, I'm noticing that almost all the mathematical operators, like plus, circle, , times, etc. give me entirely wrong characters. Plus gives me a little c that's two characters out of place, for example. Plus minus gives me a circle with the number 6 in it. These characters are apparently not changeable using the catalog editor?

    Still don't know what the deal is.

  6. #6
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: OpenOffice from Factory missing Math catalog

    Quote Originally Posted by novelgazer View Post
    CORRECTION: The OpenOffice.org Math version is 3.0.0.9-2.3 (1.6 is Writer, I guess.)
    Where you get this package? In the OpenOffice repository the latest version is 3.0.0.3.6-1.1.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  7. #7

    Default Re: OpenOffice from Factory missing Math catalog

    From openSUSE-ftp 11.1-0 repository:
    Index of /factory/repo/oss

    Package is dated November 30, 2008.

  8. #8
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: OpenOffice from Factory missing Math catalog

    Quote Originally Posted by novelgazer View Post
    From openSUSE-ftp 11.1-0 repository:
    Index of /factory/repo/oss

    Package is dated November 30, 2008.
    My OOo is from this repo:
    Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.0. Try to change your version.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  9. #9

    Default Re: OpenOffice from Factory missing Math catalog

    Although your suggestion has the benefit of good sense and a high likelyhood of working, I can't help but be disappointed that I can't figure this out. =)

    I'll downgrade when I return home this evening and report back the results for posterity. Thanks for the suggestion.

  10. #10

    Default Re: OpenOffice from Factory missing Math catalog

    Okay... too many tangled dependencies to downgrade satisfactorally, so I did some more digging -- found this link where someone was having a similar problem.

    [WONTFIX] Formula only shows small squares instead of glyphs (View topic) • OpenOffice.org Community Forum

    So, I fired up kcmfontinst (the KDE3 Font Installer) and added /usr/share/ooo3/basis3.0/share/fonts/truetype/opens___.ttf as a system font and that seemed to do the trick. I guess somewhere along the way, that font wasn't registered and OOo was defaulting to some lesser variation.

    I'm noticing some other, similar issues with galleries and whatnot, so I'm probably going to start the whole system fresh when OpenSuse 11.1 comes out next week. Nice that it coincides with winter/Christmas break so well.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •