Results 1 to 10 of 10

Thread: I get "repo exception" every time I try 2 install things.

  1. #1

    Default I get "repo exception" every time I try 2 install things.

    This is making my life really hard.

    Any help?

  2. #2
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default Re: I get "repo exception" every time I try 2 install things

    Which version of openSUSE are you running, 11.1 beta or RC1? Maybe one of your repos is no longer valid. Did you try zypper on the commandline to get some meaningful output? If nothing helps, just delete all your repos and add them again.

  3. #3

    Default Re: I get "repo exception" every time I try 2 install things

    Okay, zypper and what modifier?

  4. #4
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default Re: I get "repo exception" every time I try 2 install things

    Well, you can do "zypper ref" (then it tries to refresh your repositories) and see which repos are broken and then you can type "zypper --help" to see what else it can do for you. You can try "zypper in I-dont-know-what-package", just to see if installing works in the commandline. You can also post the output of "zypper lr", then we see which repos you have enabled. Which version of openSUSE are you running by the way? That is important to know when you get asked for help.

  5. #5

    Default Re: I get "repo exception" every time I try 2 install things

    Linux L1y8 (Kernel 2.6.25.18-0-2pae)

    ...

    Code:
    linux-l1y8:/home/marianox # zypper lr
    #  | Alias                                                        | Name                      | Enabled | Refresh
    ---+--------------------------------------------------------------+---------------------------+---------+--------
    1  | openSUSE-DVD 11.0                                            | openSUSE-DVD 11.0         | Yes     | No     
    2  | 11.0                                                         | 11.0                      | Yes     | Yes    
    3  | http://download.opensuse.org/distribution/11.0/repo/non-oss/ | Main Repository (NON-OSS) | Yes     | Yes    
    4  | Main Update Repository                                       | Main Update Repository    | Yes     | Yes    
    5  | PK_TMP_DIR                                                   | PK_TMP_DIR                | Yes     | Yes    
    6  | repo-debug                                                   | openSUSE-11.0-Debug       | No      | No     
    7  | http://download.opensuse.org/update/11.0/                    | Main Update Repository    | Yes     | Yes    
    8  | openSUSE-11.0-Updates                                        | openSUSE-11.0-Updates     | Yes     | Yes    
    9  | http://download.opensuse.org/distribution/11.0/repo/oss/     | Main Repository (OSS)     | Yes     | Yes    
    10 | NVIDIA Repository                                            | NVIDIA Repository         | Yes     | Yes    
    11 | Yast1                                                        | Yast1                     | Yes     | Yes

  6. #6
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default Re: I get "repo exception" every time I try 2 install things

    Hm... no errors during "zypper ref"? ..... you have two update repos, (1) Main Update Repository and (2) openSUSE-11.0-Updates. One should be enough. Then you have the oss and non-oss repos and the DVD (all three are ok) plus a repo called 11.0. I don't know that repo. Nor do I know PK_TMP_DIR or Yast1 repos. I am more the type of user who adds the packman repository first ;-)
    Did you find out which repo causes your exception, e.g with "zypper ref"? If it tells you that a repo is broken you can remove it with "zypper rr the_repo_that_does_not_work". Of course you can do all these things in Yast, too.
    [sidenote]
    Plus, in Yast you can you can assign priorities to repositories. That is particularly useful when you don't want to insert your dvd all the time. In that case, just give the DVD a higher number (mine is 120) and it will have a lesser priority over the online (oss and non-oss) repos (which are 99 here).
    [/sidenote]

  7. #7

    Default Re: I get "repo exception" every time I try 2 install things

    Thanks a lot for the info! =)

    Well, the thing is that everytime I try to install MadWifi rpm's I get the "repo exception" error and no other details.

  8. #8
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default Re: I get "repo exception" every time I try 2 install things

    Where is madwifi? You can figure out in Yast. Search for your desired package, mark it and click the "Versions" tab. Then delete the repo and add it again later. You know, there's a repository cache. That may be broken. You can really delete all of the repos and add them again, just to kill the cache (Maybe there's another way to do it).

  9. #9

    Default Re: I get "repo exception" every time I try 2 install things

    You mean the software management app? Cos since I've installed MadWifi, I have never seen any sort of app or nothing related to it.

  10. #10

    Default Re: I get "repo exception" every time I try 2 install things

    I get a lot of "lib.c.6" requests as well, and I'm not able to find this either. =S

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •