Results 1 to 5 of 5

Thread: Problem with Virtualbox on openSUSE 11 x86_64

  1. #1
    Dixie17 NNTP User

    Default Problem with Virtualbox on openSUSE 11 x86_64

    I am fairly new to openSUSE and I wanted to set up a virtual machine to run Windows XP. As I had used VirtualBox on Windows and was familiar with it, I decided to give it a try.

    I am running openSUSE 11 x86_64 KDE 4, so I downloaded the appropriate rpm (VirtualBox-2.0.6_39765_openSUSE11-1.x86_64.rpm) from the VirtualBox website and installed it with no problem.

    I started it up and created a virtual machine and again had no problems. Then when I went to run the virtual machine I got the two following error messages:





    I then did as suggested and tried to re-setup the kernel by executing the command displayed in the above error message and got the following results:



    So I then went and viewed the log as instructed which contained the following:

    /usr/share/virtualbox/src/build_in_tmp: line 99: make: command not found

    I have no idea what this means and have searched for a while to find an answer but I am completely stuck. I appreciate any help that can be given.

    Many Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Problem with Virtualbox on openSUSE 11 x86_64

    check the steps here:
    VirtualBox Installation - openSUSE
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Problem with Virtualbox on openSUSE 11 x86_64

    When using the PUEL version from the VirtualBox download site, you need to compile the vboxdrv module. This requires extra packages to be installed, and these are:

    make, gcc, kernel-source, pam-devel

    I think that's the list. Anyway if something is missing the log file will tell you what else is needed. The kernel-source package must match in version with the running kernel. So you should have the updates repository enabled and install using YaST.

    I believe there's a howto on the OpenSUSE wiki about this.

  4. #4
    Dixie17 NNTP User

    Default Re: Problem with Virtualbox on openSUSE 11 x86_64

    Thanks for the help, that resolved the problem.

    However I cannot set my resolution on the guest machine higher than 1024x768. My resolution on the host is 1400x900 as I have a widescreen monitor. I have installed the guest additions, but I only have two options 800x600 and 1024x768. Does any know if it is possible to have a resolution of 1400x900 on a Windows XP guest machine.

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Problem with Virtualbox on openSUSE 11 x86_64

    Yes to 1400x900 it works fine.
    Here is a screen of mine
    Imagep guest in VBox Seamless Mode.jpeg - openSUSE

    I have trouble getting it to work sometimes in Linux guests.

    What happens when you select seemless?

    Try the tabs across the top of the main GUI, the first one I think, there are screen options, choose 'adjust window size' - now hit the maximize button top right of the GUI. It gives me XP over the whole window.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •