Results 1 to 4 of 4

Thread: Zypper problem:says to update packages that are up-to-date

  1. #1
    Join Date
    Jun 2008
    Location
    Concord, California
    Posts
    262

    Question Zypper problem:says to update packages that are up-to-date

    My updater applet in the tray tells me two updates are available. I go to update and nothing happens, it just refreshes and says there are two updates.

    I have run into this before with 10.2 and 10.3 so I deleted the local cache and forced a refresh. Still had the same thing.

    I ran "zypper up" from CLI and got this:
    Code:
    2 Problems:
    Problem: patch:kdenetwork3-InstantMessenger-235.noarch conflicts with kdenetwork3-InstantMessenger.x86_64 < 3.5.9-39.2 provided by kde4-kopete-4.1.3-43.5.x86_64
    Problem: patch:fileshareset-124.noarch conflicts with kdebase3-session.x86_64 < 3.5.9-65.2provided by kdebase4-session-4.1.3-23.2.x86_64
    
    Problem: patch:kdenetwork3-InstantMessenger-235.noarch conflicts with kdenetwork3-InstantMessenger.x86_64 < 3.5.9-39.2 provided by kde4-kopete-4.1.3-43.5.x86_64
     Solution 1: deinstallation of kde4-kopete-4.1.3-43.4.x86_64
     Solution 2: do not install patch:kdenetwork3-InstantMessenger-235.noarch
    
    Problem: patch:fileshareset-124.noarch conflicts with kdebase3-session.x86_64 < 3.5.9-65.2 provided by kdebase4-session-4.1.3-23.2.x86_64
    It then wants me to uninstall KDE4.1.3 and then install the updates. How do I fix this? has anyone else seen this?

    running opensuse 11 with KDE 4.1.3 "Release 63.3"
    OpenSUSE Leap 15, KDE5 (plasma 5.16.5, frameworks 5.62, QT 5.13.1)

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,378
    Blog Entries
    1

    Default Re: Zypper problem:says to update packages that are up-to-da

    I think this is a recent known problem. For now use the yast software manager to update.

    http://forums.opensuse.org/applicati...ug-report.html

  3. #3
    Join Date
    Jun 2008
    Location
    Concord, California
    Posts
    262

    Default Re: Zypper problem:says to update packages that are up-to-da

    Thanks, I must have just missed that when searching. Exactly what I'm having problems with.
    OpenSUSE Leap 15, KDE5 (plasma 5.16.5, frameworks 5.62, QT 5.13.1)

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Zypper problem:says to update packages that are up-to-da

    The suse updater reports those updates/patches. Just ignore them. Personally I don't use the updater anyway. I switch it off.

    If you use software management you can apply updates in there as deano said. And it is not affected by the bug.
    A fix may be on the way.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •